Showing results for 
Search instead for 
Do you mean 
Reply
rick_christopher
Posts: 3
Registered: ‎01-25-2009
Accepted Solution

Problems with WET11 MAC cloning functionality

Hi,

 

I am having a heck of a time configuring my WET11 v2 to allow my XBOX to be fully connected. I can configure and connect the bridge, ping, ftp files to XBOX etc. Only issue is when I try linked play. I can see the game in progress on the second XBOX but cannot join. Linked play works perfectly when XBOXes are cabled to the router.  I know that linked play depends on each game console broadcasting their MAC so I need to clone the XBOX's MAC address to use the bridge.

 

Unfortunately the WET11 web config interface does not allow me to do this. Under Advanced Settings/Cloning Mode all controls are disabled - greyed out. That includes the control that allows you to turn on Cloning.  I took a look at the script behind the page and it seems that it checks to see if "disable cloning" is selected and if so, disables all the cloning controls, including the one that would allow me to turn it back on. Since the default is disabled, its the programmatic equivalent of locking the keys in the car. You can take a look at an emulated interface here:

 

http://ui.linksys.com/files/WET11/v2/advanced.html 

 

Of course the demo is fully functional and doesn't exhibit the problem..

 

Many people have described solving their XBOX linked play issues by cloning the XBOX MAC address and refer to changing the settings using the web interface.

 

I have tried various versions of the firmware 2.06, 2.07, 2.08 US and 2.08 EU. Same results. Tried the setup wizard ver 1.06 but it doesn't even include MAC settings.

 

Had two different chats with support agents online and both seemed to be as puzzled as I am.

 

Am I missing something obvious? Is the availability of the cloning options dependent on settings elsewhere in the config utility?  Is the interface designed for v1 and cloning taking place without user intervention on the v2? (doubt that)

 

Has anyone else seen this?

 

I know that people have written some code to pull settings strings off the unit so maybe the inverse is true and I can write script to alter settings directly.

 

Any suggestions would be appreciated.

 

Rick

 

 

 

 

 

Carrot
Posts: 3,271
Registered: ‎09-07-2006

Re: Problems with WET11 MAC cloning functionality

If you want to use MAC Address Cloning Mode on your WET11, you need to set it to Enable, if you set it to Auto mode, the Bridge will automatically use the MAC Address of the X-Box connected to the Ethernet port of the Bridge without manually entering the MAC Address and that's why the option to Enter MAC Address field is Grey...
rick_christopher
Posts: 3
Registered: ‎01-25-2009

Re: Problems with WET11 MAC cloning functionality

No - what I am saying is that I cannot set it to enable since that is greyed out as well. I sent my friend to the link that I included in my original post and he reported different behaviour on the advanced settings. So I am now investigating th epossibility that that the web interface is not compatible with IE 7.  Stay tuned.

 

Rick

rick_christopher
Posts: 3
Registered: ‎01-25-2009

Re: Problems with WET11 MAC cloning functionality

Well well well - apparently the firmware is not fully compatible with IE7. Downloaded Firefox and interface functions as advertised.

 

Rick