Reply
ckblackm
Posts: 9
Registered: ‎01-31-2008

Trying to get WRT54g and a WAP54g talking wirelessly

Just moved into a new home and would like to have my wife's office, which consists of her desktop computer, and a networked printer connected via a hub/switch to a WAP54g, connect wirelessly to our wrt54g running Tomato firmware.  (The only thing

physically connected to the wrt54g is the dsl "modem"... but that's our access to the internet).  All other devices connect wirelessly to the wrt54g.

 

I've tried each of the settings on the wap, but the two just don't seem to be talking.  I spent the most time with it on AP Client,

and it sees my router and can grab the MAC addr and ask for the WEP key... but when that's done... I still can't get from her

computer to the internet.

 

Any ideas/help?

 

Thanks,

Christopher.

 

castor
Posts: 3,376
Registered: ‎09-07-2006

Re: Trying to get WRT54g and a WAP54g talking wirelessly

The WAP54G will work as a wireless repeater with the following devices:

Linksys Wireless-G Access Point (WAP54G)

Linksys Wireless-G Router (WRT54G)

 

To configure the access point as a wireless repeater, you need to perform two steps:

 

Checking the Wireless MAC Address of a Wireless Router/Access Point

Setting-Up Wireless Repeater Mode on the WAP54G 

 

So in short you have to enter the wireless MAC address instead of LAN MAC address.. Second, you have to enter same SSID. Here is the link for configuring an Access Point as a Wireless Repeater: http://www6.nohold.net/Cisco2/ukp.aspx?vw=1&docid=5c7c2256bbcd4a04ae048a2d80088938_4200.xml&pid=80&r...

BradS
Posts: 5
Registered: ‎03-12-2012

Re: Trying to get WRT54g and a WAP54g talking wirelessly

Christopher, I have almost this exact configuration running at home. The trick was to set the WAP54G wireless security to be identical to that of the WRT54G. Also, it seems that WPA2 is not supported in client mode...I had to drop back to WPA with AES. WEP should also work.  Finally, after you make the switch to client mode and select the WRT54G, the mac address of the WRT54G should appear in the box. Click save and then wait...and wait....the mac address should change from red to blue. Re boot the WAP and you should be up and running.

 

 

ckblackm
Posts: 9
Registered: ‎01-31-2008

Re: Trying to get WRT54g and a WAP54g talking wirelessly

That was the trick... had to drop it down to WPA instead of WPA2.

 

Thanks,

Christopher.