Posts: 2
Registered: ‎12-12-2010

WAP54G/WRT54G repeater mode

Well, it took over 20 hours, but I figured it out.


Long Story Short:  Is there a way to configure the WAP54G/WRT54G to work with WPA2 in repeater mode?


Long Story is as follows:


My setup:

     WRT54G v6 - located in living room, on one side of the house - this is where my network comes into the house

     WAP54G v3.1 - located in guest bedroom/computer room on the other side of the house - in repeater mode

     BEFSR41 - configured as a switch (i.e. DHCP server disabled) in the computer room, to give "wired" access to several computers.


First, a little grief to the Cisco/Linksys folks... Note: This is constructive criticism:

Don't have two places to download the 'most recent firmware'.  For WAP54G I originally downloaded 'the most recent firmware' from here (v. 3.04.03) when I should have downloaded it here (v. 3.05.01).  The same can be said for WRT54G, I downloaded 'the most recent firmware' here (v 1.02.5) when I should have downloaded it here (v. 1.02.8).  This cost me several hours of troubleshooting trying to figure out why WPA and WPA2 encryption wasn't working at all!


The long story:

I am mainly posting this in an attempt to help someone else that is setting up their WAP54G in repeater mode for the first time, and it won't work. 


I'm not a network genius, but I can poke my way around and generally get things done.  So, I jumped right in to configure WAP54G as a wireless repeater, in order to get a 'wired' signal to a couple computers in my computer room.  Seems easy enough, just update my firmware, select my current security settings (I had been using the WRT54G as a wireless router with WPA2 security), verify my SSID's are the same, and verify my channels are the same as well.  And it should work!  Right? Wrong!


I spent 1.5 days trying all sorts of different ways to configure the router and the access point, to no avail.  I triple checked my MAC addresses, my security settings, and my IP addresses.  Nothing worked!  I talked to my brother who IS a network genius, and he thinks I'm doing everything right, but he suggests that I try to make it work without any security enabled.


So I do all of the same things, but with security disabled, and low-and-behold... It works!  So I spend the next 30 minutes or so figuring out how to start the encryption without mucking anything up... WPA2... doesn't work... WPA... doesn't work... WEP finally works, but who in their right mind can remember a 10 digit word of hexadecimal to plug into all of my wireless devices?  So I look around some more, and find out that my firmware isn't up to date - and I thought it was (See above)!


Update the firmware and finally... WPA works with TKIP.  Awesome... this will work for me, but I would still prefer to use WPA2 with AES encryption or even TKIP+AES.  So, my question... has anyone been able to get this setup to work with WPA2 encryption?  Also, why even have WPA2 as an option on the access point if it won't work?


The outcome in case anyone cares:

The Good:  I have access to all of my linksys devices via static ip address - from one computer, or any computer on the network, so I can change something in a hurry if I ever need too.  Connecting additional 'wired' peripherals should be no problem, though I haven't tried yet.

The Bad:  I lose 4Mb/s of download speed going through the repeater wirelessly!  YIKES!  But wired through the switch and repeater, I lose about 1Mb/s, not too bad.  So, it may be better for me to use the weaker signal of the wireless router than the stronger signal of the repeater for streaming movies, gaming, and other data intensive work.  I'll have to look into that more.

Posts: 3,117
Registered: ‎09-07-2006

Re: WAP54G/WRT54G repeater mode

If you are trying to setup the Access Point in a Repeater Mode, then WAP2 security will not work, either you need to choose WEP or WPA security.