Posts: 2
Registered: ‎04-08-2010
Accepted Solution


[ Edited ]

I recently purchased a WAG320N, primarily for the faster networking speeds and the ability to attach a USB hard drive to my network.


The only problem is that I have little idea how I get this network storage thing to work. Cisco haven't really supplied any documentation on how to work this.

So far I've plugged in a hard drive and formatted it through the router's web interface, with no trouble at all.

But, after doing this I have no idea how to access my hard drive on the network.

I would assume that it would appear automatically on my network for me to access freely.


Have I missed something? I must also point out that I'm in a Mac computer only home, no PCs.


Many thanks.

Posts: 2
Registered: ‎04-08-2010


I have the same problem and cannot find anything to give me a clue on how to solve this issue.  I cannot believe that it is just us two that have had this problem.  Someone please help.

Posts: 2
Registered: ‎04-08-2010


Hello again, well managed to chat briefly on the live chat on Cisco's support page.

Finally got the answer to my problem, although it isn't as obvious as it seems at first.


These instructions are for Mac users.


I'll run through the basics:

 - Grab your Hard drive/USB stick and plug it it.

 - Logon to the router's address in your browser

 - Followed by your user and password. (Should click add to keychain to make life easier)

 - Then hit the storage tab!

 - Format your drive to the exact size of the drive. (I find partitions fiddly so I just leave it as one chunk, us Mac users are used to it.)


Once the drive has been picked up by the router, click the format button.

The router says the drive's size is 57,216 MB, so I copy that figure into partition 1 text box, tick the partition 1 box. The hit "apply".

This bit shouldn't take long.

Make a not of the name of the hard drive after the formatting, you'll need this later.


 - At this point the router should of done most of the fiddly bits.

 - Okay, under the storage tab there should be a administration bit, click that.

 - Towards the button of the page should be a User Management Section.

 - I'd suggest adding some users to the User List to make life easier when connecting. What I did was type in the user name of my mac's user account. I.e. "scruffydoo", so first and last name put together. Then add a different password than my computer for security reasons. (You can do this for every mac on your network.)

 - Once you've done that hit the "create" button.


Okay router bit done. On to the Mac.


 - In the finder, click the "go" drop down menu.

 - Then select "Connect to server" or hit command-K

 - Under "server addresses", type in "smb://". Then add the name of the hard drive that router gave it. You can find this on the storage tab under shared folder.

 - So the resulting address would look something like this "smb://"

 - Click the "+" to save for later, then hit "connect".

 - The computer will then ask for a user and password.

 - Just type in the user name that you added on the router, which should be the same as your user name on your mac. Makes life easier, hopefully.

 - Type in the password you chose on the router. I.e. scruffydoo and the password would be dingleberries.

 - All done, you have connected to the hard drive on your router.


Just remember that next time you want to connect, go to the "Go" drop down and select "Connect to server" and double click you book marked server address.

From here on out you can start adding bits to the address.

I never liked seeing the HDD_1_1 name in the finder so I added a folder to the drive, like "Storage" then in the "Connect to server" address bit typed in "smb://"


Hope that helps!

Posts: 1
Registered: ‎07-08-2010


Thanks, very much for this wonderfull information, I was realy sad, Even the service Technique for Cisco in Belgium where no able to tell me that, they just say that ma hhd was not compatible........ but well thanks to you now i see it, ufffff, what an story -Sad- with a happy ending!!!!!!

Posts: 2
Registered: ‎07-21-2010


[ Edited ]


I buy my WAG320n week ago and same problem in Windows. Any help? No access LAN or FTB

Posts: 2
Registered: ‎11-10-2010


I have followed the advice above (Thankyou).


Finder mounts the volume OK (HDD_1_1). I can see it, log off and come back and connect quickly and easily etc. BUT I can only see the folders in the drive - Finder just hangs when it attempts to list the files.


When I browse the HDD_1_1 folder via the Storage and Administration tabs in the routers own WebGUI Setup. I can see the folders, files, etc everything.


I'm running MAC OS X 10.6.4


Any idea's? I noticed this problem listed in another thread following upgrade to FW version 1.00.12

I purchased my WAG320N only last week so already had the latest FW onboard.


Any bright idea's?



Posts: 1
Registered: ‎11-12-2010


I've got same kind of problems too. Finder freezes  when attempting to copy files or list files inside folder. I have Mac  OS X 10.6.4.  I'm gonna return the unit next week and buy something else instead. I've tried pretty much everything but haven't found any solution so far.  External drive is Iomega 1,5 TB.

Posts: 1
Registered: ‎11-30-2010


I have the same problem.


Disk is mounted ok but i have no idea how to access my its files...

Maybe by mapping network device in my computer?


I've tried it but couldnt connect to it.


I'm using Windows 7 Pro 64.


Any help?

Posts: 2
Registered: ‎12-19-2010


[ Edited ]

Hi i have same problem like you.

everything works ok except USB storage. i have even payed to one of the Cisco tech £9.99 to help me with it, but no luck.

it connects to external hard drive very quickly, but it can see only maine folder (HDD_1_1) and as soon i go in too see other folders it hangs. i run MAC OS X 10.6.4. i was browsing in internet and as i understand many other peoples has same problem with this  practiqular model. (WAG320N)    


Any suggestions to resolve this?


sorry for my English as it not my first language, but i am sure i made my point very clear -)) 


(Mod note: Edited for guideline compliance. Stay on topic. Thanks!)




Posts: 2
Registered: ‎12-19-2010


[ Edited ]

Ok. update on USB problem.. i have spent last nite about 3 hours with one of Linksys staf on live chat to get USB working, NO LUCK..  in the end they told me to replace unit as it CAN be  faulty.


(Mod Note: Edited for guideline compliance.)