Posts: 2
Registered: ‎05-07-2010
Accepted Solution

WAG54G v2 Faulty LAN

[ Edited ]

It seems there is a very common issue with these models working fine for a period and then for no apparent reason the ethernet wired ports stop working. I have had 4 devices connected for 2 years without issue until last week when none of the devices would connect with no changes made in any way. Worked one minute then nothing. This is obviously a hardware issue (manufacturing/MTBF component fault) as the LEDs on the router ports do not come on (only on the initial power up port test), nor do they on any of the network devices - they always did but not anymore. If this wasn't the case then surely a FW release could fix it.

What does seem to work is changing the device setting speed, Auto - 10mb/s & the duplex mode to half. This is stated in many places even by Cisco as an acceptable work around...WHAT?!?! Fine it connects now but no more streaming video, no more large file transfers, no more full speed ethernet. Not good enough!


(Mod note: Do not veer off topic.)

Posts: 3,012
Registered: ‎09-07-2006

Re: WAG54G v2 Faulty LAN

Have you tried resetting and re-configuring the device...? Try to reset the WAG for 33-40 seconds,power cycle it and re-configure it from scratch.


If that does not work then,try to upgrade/reflash the firmware of WAG54G.After re-flashing the firmware,reset it and re-configure.

Posts: 2
Registered: ‎05-07-2010

Re: WAG54G v2 Faulty LAN

This is not a firmware issue this is a faulty hardware issue. I have done everything the consumer can do to rectify this however as I have since found this highly common problem is from a faulty capacitor on the device. I have since replaced the faulty hardware and everything is working as it should.


I would recommend this fix to anyone who has even just a little know how with a soldering iron. Very quick, simple and it WORKS. I would hope that this message is not also edited or deleted as it can be helpful to the many Cisco/Linksys customers out there also suffering though this.


Here is a link I found for a walk-through on what to do, I'm lazy to make one up so here you go:


Props to Gavin for this tutorial.