Reply
Posts: 4
Registered: ‎08-20-2014

WGA600N unstable when co-existing with 802.11ac clients

I have just started having issues with my WGA600N connected to a WRT1900AC. In my case, things were initially connected and stable using the following settings:

 

WRT1900AC

Same SSID for both radios

WPA2 Personal

2.4GHz

-channel width 20MHz

-network mode mixed

5GHz

-channel width 40MHz

-network mode mixed

 

WGA600N

802.11 band: 2.4GHz and 5GHz

Static IP

 

Other wireless clients connected to the WRT1900AC

2.4GHz: 802.11g/n

5GHz: 802.11n

 

Shortly after I added an 802.11ac capable wireless client (new Macbook Pro w/ Retina) to the WRT1900AC, the WGA600N started getting unstable. The symptoms are that after a random period of time (30 minutes to several hours later) all bridged devices attached to the WGA600N drop off the network, the WGA600N's IP address is no longer pingable from the bridged devices attached to the WGA600N, and the ethernet LED on the WGA 600N blinks indicating traffic, but the wireless LED is on, but does not blink. This even happens after the AC client is disconnected from the WRT1900AC as though this some time of latent effect of having the AC client having ever connected. If I power-cycle the WGA600N (the only method of recovering I have found) and do not connect the AC client, the WGA600N is stable.

 

Any thoughts?

Posts: 627
Registered: ‎10-26-2013

Re: WGA600N unstable when co-existing with 802.11ac clients

Hi JinTu. Try adjusting the wireless settings on your router. The SSID for 2.4 GHz and 5 GHz. should be different. Set wireless security to WPA2/WPA Personal. For 2.4 GHz set channel width to 20 MHz only and channel to 1,3,6 or 9.  For 5 GHz set Security mode to WPA2/WPA Mixed Personal. Channel width to 80 MHz and channel to 153. You may also try relocating the WGA600n to another location. 

Posts: 4
Registered: ‎08-20-2014

Re: WGA600N unstable when co-existing with 802.11ac clients


geekychix wrote:

Hi JinTu. Try adjusting the wireless settings on your router. The SSID for 2.4 GHz and 5 GHz. should be different. Set wireless security to WPA2/WPA Personal. For 2.4 GHz set channel width to 20 MHz only and channel to 1,3,6 or 9.  For 5 GHz set Security mode to WPA2/WPA Mixed Personal. Channel width to 80 MHz and channel to 153. You may also try relocating the WGA600n to another location. 


Thanks for the suggestions geekychix.

 

I already had 2.4Ghz set for 20MHz only and set for channel 6 before making changes. I am unable to modify the security mode from anything other than WPA2-only on either radio as TKIP is enabled by default in mixed mode on the WRT1900AC and there is no method of forcing AES-only with the stock firmware. Also, there is no explicit method of forcing the 5GHz channel width to 80MHz with the WRT1900AC ("auto" seems to be the only way to allow it to operate with this channel width). The WGA600N is in the same location as it has always been and signal levels continue to be excellent.

 

I have since changed the WGA600N to use 2.4GHz only and this seems to have alleviated this issue as far as device stability goes. Unfortunately the 2.4GHz ISM band is extremely crowded in the location where the devices are used, so this is not ideal (lower throughput, higher latency, etc.) I need to find a way to use the 5GHz radio with the WGA600N without forcing my AC-capable devices to use N.

 

Now for your comment that the SSID for the two bands needing to be different, I have yet to read a satisfactory explanation on why this should be done. It is a common practice in enterprise installs to share a common SSID across channels/bands to expand wireless reach across a campus. In my case the 5GHz reception in several locations where the setup is located is too poor to use. Portable clients seamlessly switch over to 2.4GHz when in these areas and things work just fine.

 

 

 

Posts: 627
Registered: ‎10-26-2013

Re: WGA600N unstable when co-existing with 802.11ac clients

[ Edited ]

Hmm, just try it. It works to a lot of people here in the community and it may work for you too. See the example below on how I set it to WPA/WPA2 Mixed Personal. 

 

Capture.PNG

Posts: 4
Registered: ‎08-20-2014

Re: WGA600N unstable when co-existing with 802.11ac clients


geekychix wrote:

Hmm, just try it. It works to a lot of people here in the community and it may work for you too. See the example below on how I set it to WPA/WPA2 Mixed Personal. 

 

Capture.PNG


 

Thanks geekychix,

 

I do appreciate your help.

 

It would appear that you have revealed another bug in the WRT1900AC's current firmware. There is no technical reason that 80MHz channel width should not be a selectable option with WPA2 only for the 5GHz radio 

 

Unfortunately I cannot use WPA2/WPA mixed mode for security reasons given the current implimentation on the WRT1900AC. An inability to disable TKIP is a NOP in my situation. I would suggest having a look at Beck-Tews and 

Ohigashi-Morii if you want to know why using TKIP is not a good idea.

 

I have done some additional experiments and by forcing the WGA600N to use 5GHz-only I can reproduce the issue with locking up the device. As periodically power-cycling the WGA600N every time it locks up is undesirable it looks like I don't have any option but to get a replacement bridge. I ordered a WUMC710, but from the forum postings here it looks like this device has it's own stability issues. Fingers crossed that they won't affect me as well...

 

 

Posts: 1,306
Registered: ‎10-27-2013

Re: WGA600N unstable when co-existing with 802.11ac clients

Try using other channel width for the 5 GHz band and make sure that both devices (router and game adapter) are using the latest firmware version. Hope these help.

Posts: 4
Registered: ‎08-20-2014

Re: WGA600N unstable when co-existing with 802.11ac clients


dadayzee wrote:

Try using other channel width for the 5 GHz band and make sure that both devices (router and game adapter) are using the latest firmware version. Hope these help.


Sorry, lowering the channel width of the 5GHz radio defeats the purpose of having AC devices. All devices had been running the latest firmware. 

 

I received my WUMC710 yesterday and set it up that evening. Apart from a few initial setup issues (initial attempt to configure made the device inaccessible requiring a factory reset, setting a static IP didn't take effect until the device was power-cycled) it has been up and stable at a wireless rate of 1170Mbps.