Showing results for 
Search instead for 
Do you mean 
Reply
YucA
Posts: 2
Registered: ‎01-10-2010
Accepted Solution

NAS200 Hard drive???

I have the NAS200 with a single drive.  I would like to remove this drive from the NAS200 unit and use it accessing the same files on a removable USB adapter.

 

If i simply remove the drive and plug it into the usb caddy, the computer can see the drive, but cannot read any of the info on the drive....

 

Anything i can do to make this work?

 

jac_goudsmit
Posts: 317
Registered: ‎02-28-2008

Re: NAS200 Hard drive???

The NAS200 uses ext2 for non-journaled partitions and XFS for journaled partitions. You should be able to read it with a Linux machine that supports these file systems. Under Windows, there's a program called ext2ifs which works with ext2 but I'm unaware of any Windows solutions for XFS at this time.

 

===Jac

--------

Frequent NAS200 Answers:
1. DISABLE the "convert failed logins to guest logins" option to fix permission problems.
2. NEVER insert or remove hard disks while the power is on. NAS200 doesn't support hot swapping.
3. ALWAYS use the power button to turn the NAS200 off, don't just unplug it.
4. Don't trust RAID. Make BACKUPS!
5. To ACCESS the disks directly, you will need ext2 and/or XFS file systems. I recommend using SystemRescueCD.
6. Disks will get HOT with standard fan, use "green" disks or consider replacing the fan.
7. FTP server is insecure and doesn't work behind a NAT router. Use my firmware and SCP instead.
8. MY FIRMWARE supports SSH shell prompt and SCP for secure file access, and allows running other software.
dibbler
Posts: 3,173
Registered: ‎09-07-2006

Re: NAS200 Hard drive???

I agree with jac and all the suggestion provided by him.It is basically due to incompatible file system.
YucA
Posts: 2
Registered: ‎01-10-2010

Re: NAS200 Hard drive???

I was trying to access the drive through OSX, which doesn't support the file system. After reading your reply, i hooked her up to my linux box and everything was kosher.

 

Thank you for the help.  I should have RTFM... =P.