Posts: 8
Registered: ‎11-05-2006

NSLU2 Strange behaviour

I have 2 x 400Gb drives connected to my NSUL2 f/w63. Both EXT3 formatted.

1. I never managed to get the CD setup utility to configure the unit. Whenever I came to save the configuration I got the progress thingy for about 5 minutes followed by an error message saying words to the effect "Unable to save configuration - check a list of pretty basic things" which I tried without success several times.

2. I had no problem configuring and saving with the web browser.

3. I have set up the disks so that 2 is a backup of 1 but every time I power down the unit that selection is lost and I have to reselect it from admin/advanced/disks/backup. That is a pain.

4. I tried backing up an entire C drive from one of my networked machines (ie root directory down). Maybe @ 30% of the disk was actually backed up on completion. OK I said to myself - can't back up 'system files' but, on investigation it had left out a pile of other non-system files too - seemingly at random.

5. I decided the attempt at full system backup might be the underlying cause and so did another backup of another share containing just data files. It took nearly 3 hours to back up (allegedly) 19Gb of data; but again on investigation it had ommitted a couple of sub-directories and files (just a few this time but none remotely connected with the OS).

6. I tried to delete the directory containing the failed attempt at a full backup. In spite of no files being visible, and having made sure that none of the 'hide system' etc files options was on, I cannot delete one system file directory (i386) because it is reported as 'contains files'.

7. Thought "I'll go back to the drawing board, start again and reformat the disks" but I can't. Disk log reports 'Format failed'.

I bought this thing with the idea of having a reliable networked backup solution - with the emphasis on RELIABLE. I am rapidly losing faith in its suitability to fulfil that - or any other purpose reliably.

Any comments observations gratefully received.
Posts: 8
Registered: ‎11-05-2006

Re: NSLU2 Strange behaviour

More on this:

I finally succeeded in reformatting both disks, but only after removing all EXT3 partition information using Windows disk management tools whilst connected directly to a computer. Lesson: you can't reformat EXT3 disks that are already validly formatted using the NSLU2- Why not? Also, the apparently empty but nonetheless unremoveable directory is a separate issue (see root post).

I tried another backup of data-only files. Left it running overnight with just the backup machine running. 2.5 hours for 19Gb this time. The same files were ommitted from the backup as before. They comprised all files in the last (alphabetically) directory of the deepest subdirectory and the last file (alphabetically) in the same (deepest) subdirectory. Haven't researched whether it missed any others yet (i've got real work to do!). All were either .csv, MSAccess, MSWord or MSExcel files and none were open or in use in any way by another machine.

There are also some annoying inconsistencies with the browser management console - like reverting to the default admin password simply because both disks are disconnected/reconnected

Lesson? - until these issues are addressed (especially the missing out of files to be backed up - apparently on a last alphabetical file or directory basis) I judge the NSLU2 to be not up to the task of providing a reliable network backup solution.

I've spent quite enough time on this now so it's going into the spare kit drawer until I'm persuaded otherwise.
Posts: 8
Registered: ‎11-05-2006

Re: NSLU2 Strange behaviour

Got it! The missing-out of selected data files for back up that is:

NSLU2 (or perhaps the EXT3 file naming requirements) does not recognise files beginning with the '$' character - whereas Windows FS's do. So, can someone at Linksys TS address this issue please? I have more files that I need to backup that begin with a '$' character than anything else because that is the character that prefixes most of the symbols for financial index data series and I collect about 100 Mb of such data on various timeframes every day.

If that is not possible then NSLU2 can hardly be marketted as a network backup solution for windows based systems. Also, I have to worry that there may be other such inconsistencies that would result in files being missed out. Some assurances (or a list of such things) needed please.