Posts: 2
Registered: ‎06-28-2009

NSLU2 can't change user rights

Firmware version V2.3R63 


I have a few directories on the primary drive that don't allow me to delete files, rename files, or change rights to the files.


I've done a bit of searching and haven't found much help beyond formatting the drive (last option I'll use) and running ScanDisk (just completed and no joy, still can't delete stuff).


I've tried connecting as root using  Gnome Commander - delete denied.


I've thought about connecting the drive directly to my Linux box and using root to reset the user rights.  If I go this route, any 'gotchas' I need to be careful about?





Posts: 3,025
Registered: ‎09-07-2006

Re: NSLU2 can't change user rights

Before you format the Drive you should try to reset the NSLU2 to factory settings and then try to re-configure it.


Press the Reset button at the back of the network storage for 30 seconds.Power cycle the NSLU2 for 30 seconds.

NOTE : This procedure will reset your network storage to factory defaults. Any settings on the network storage will be erased. The network storage IP address will be “” and the username and password will be “admin” after resetting...Make sure to disconnect the drives before you reset the NSLU2...


After resetting the NSLU2 you could re-confiugure it.Now you can create new users on your network storage to manage the NAS or access shared folders in the NAS.

Posts: 2
Registered: ‎06-28-2009

Re: NSLU2 can't change user rights

Sorry for the lag responding and thank you for the suggestion.  I'll probably take an inventory of the drive, make sure I know where all of the original source material is, then do the reset and see what happens.
Posts: 1
Registered: ‎12-18-2009

Re: NSLU2 can't change user rights



Sorry for the late response - your message still showed up at the top page of the NSLU2.

Anyhow, the correct procedure to restore the access rights always has been to perform a disk scan.

You can do that by going into the "Administration" section of your NSLU2, selecting the "Disk" tab, and then click "Start/Stop Disk #" (# == 1 or 2, depends where you have the issues).

Hope that will help sometime down the road if needed again. It has always worked for me.


Good luck!

Posts: 1
Registered: ‎01-04-2010

Re: NSLU2 can't change user rights

HI all,


I have the same problem with on e of my NLSU2 (I have two).

On one, I have two disks of  1TB each and I a m not able to run a scandisk: after one hour, scandisk stop and the log message is just "scandisk failed". 

I have tried to disconnect the network during the scandisk for disabling any possibility to access the disk during the scan, but the result is the same.

I have several folders which are turned in Read Only mode and I am not able anymore to add any file or folder. 

On the other one, with disks of 160GB, I have not this issue. 

Is it a size issue or maybe other actions like defrag start automatically once per hour? 

How to be sure to disable defrage or other function during the scandisk?

Thanks in advance if someone can help.


Posts: 5
Registered: ‎09-28-2006

Re: NSLU2 can't change user rights

Just tried the scandisk thing - no joy. 
Guess it's time to try a reset and see what happens.


Posts: 14
Registered: ‎03-04-2010

Re: NSLU2 can't change user rights

If the scandisk doesn't rectify the user permissions, reset. If you tried accessing the drives directly by usb from a computer and you still couldn't , you should be ok resetting user permissions on all files as root, then back up drive contents to desktop, and start fresh by having the nslu2 format the drive. If you continue to have issues, as I did for the first year or two I had my NSLU2, your problem could be 'dirty' power from the power utility. Try putting that bad boy on a UPS and see if that does anything for you. Also, I have had very good luck with the 2.3R76 firmware. Linksys/Cisco doesn't put it on their www, you'll have to search it out. Try or one of the other NSLU2 communities for the R76 firmware. I have had zero problems out of mine since updating to the R76 and putting mine on UPS Smiley Happy

13-node home network including:
WRT54GSv7.2, WRT54Gv5, and EZXS88W providing the connections.
Two NSLU2 , one with 320GB and one with 2 1TB drives providing storage for media and machine backups.
An AppleTV, Wii, PSP and Ipod Touch for entertainment. (sorry, WD TVLive, you weren't iTunes freindly)
Vonage VoIP box and two laptops for communication and general surfing and so on.
A mini print server, and a partridge in a pear tree.
Posts: 1
Registered: ‎03-26-2012

Re: NSLU2 can't change user rights

Is there a solution to this problem? I'm having the same issue and I can't seem to resolve it using this thread, or any other googling I've done. I can't delete folders, They seem to be read only and can't have ther permissions changed.i have run scandisk and it passes. I have tried different users, from different windows and mac pc. I have reset the slug as far as I can tell ( it doesn't reset any of the user pref) it resets the password but when I restart with the drive attached it reverts back to excepting the old password. I have deleted all the user accounts except admin and guest. Is there anything else I can do? Help thanks