Showing results for 
Search instead for 
Do you mean 
Reply
Anonymous
Posts: 0

TCP/IP Printing on WPS54G

[ Edited ]

Hey guys, I hope I can share this information about how I setup my Wireless printserver... (WPS54G) You can use the standard Transmission Control Protocol (TCP) and the Internet Protocol (IP) procedure. In order to install the print server you can run the setup CD that came with your print server and follow the procedures from the wizard, but if it asks you to detach the print server from the Router just leave it as is and click next. It will then ask you to print a test page. You must make sure you check if the wireless settings on your printserver are the same as what you have on your Router, otherwise they would not be able to communicate wirelessly. You can also follow these steps indicated below if in case it does not work:


Installation of WPS54G Print Server

Using standard TCP/IP Procedure (Windows XP/2000)

  1. Make sure your printer already has its drivers installed on all PC's prior to attempting to install this print server.

  2. Be sure also that your printer can print when it is connected directly to your computer.

  3. Click on Start go to Printers and Faxes.

  4. Right click your printer and go to Properties.

  5. Click on the Ports Tab on the top.

  6. Click Add Port. Select   Create a new port: and select the Type of port: Standard TCP/IP Port, click Next.

  7. This will bring the Add Standard TCP/IP Printer Port Wizard, click Next

  8. In the field for Printer Name or IP Address: enter the IP address of the Print Server and click Next. (You can get the IP address of your print server by pressing the reset button on your device for 3 seconds then it will print out it's status).

  9. Select Custom, click Settings.

  10. Under Protocol select LPR, and for Queue Name: type L1.  Click Ok, then Next, and Finish.


You should be able to print on the device afterwards. You can refer to your Router's Wireless Settings and match them on the WPS54G so that they would be able to communicate wirelessly.

If you are still having difficulties installing your print server, check this out: Setting up a Print server under Windows XP/2000 using LPR

 

 


To have your wireless settings checked if you are using a Linksys Wireless Router, here's how:

Wireless Security Check

 

  1. Go to your desktop and double click on Internet Explorer (Located on the Start Menu in Windows XP)

  2. When "Internet Explorer" opens type http://192.168.1.1 into the "Address" bar and click on Go

  3. The "Enter Network Password" window will appear.

  4. Skip user name and type admin (admin is the default password) as the password, and click OK If it does not accept the default password, try the password you might have typed in when you ran the run me first CD that came with your router.

  5. On the Setup page of the router, click the Wireless Tab on the top and take note of the SSID, change the channel to 1 3 5 7 9 or 11 to get a better frequency then click the save settings button on the bottom. You would need this for the wireless settings.

  6. Click the Wireless Security Sub tab then take note of the KEY1 if WEP is enabled, if this part is disabled then your router is for open access(means no security is enabled and any device should be able to obtain a connection). You should have no trouble connecting if this part is disabled.

  7. After typing in the network key on your wireless computer, your wireless connection should be established. Launch your Internet Explorer, and then you should be connected afterwards.

  8. Go to your WPS54G's setup page by typing it's IP address on your address bar. (You can get the IP address of your print server by pressing the reset button on your device for 3 seconds then it will print out its status).

  9. Leave the username blank and type admin as your password. Hit OK afterwards.

  10. Click the wireless tab on the top and make sure the SSID is the same as your SSID on the Router. Then click the WEP key settings button if you have WEP enabled on your Router.

  11. Save the settings.

  12. Detach the printserver from the Router and unplug its power cable. Plug it back again and wait for the WLAN or Wireless light to turn on.

  13. Then try printing wirelessly now.


This should get your printer working wirelessly afterwards. Make sure your printer is online at all times. Hope your printer works! Good luck!

Message Edited by Maximus on 07-19-2006 07:26 PM

KENS
Posts: 1
Registered: ‎01-07-2007

Re: TCP/IP Printing on WPS54G

I read your post about setting up the wireless printer.
I have the wireless print server connected to a Brother Hl-2040.
From the connector I have it set up with, it prints fine.
How do I get the other computers in my house to be able to print to the printer / printserver?
 
Thanks!
Ken
ianus
Posts: 1
Registered: ‎01-09-2007

Re: TCP/IP Printing on WPS54G

Don't forget to change "Printer Port:" (in the Web administration interface under "Printer" -> "Logical Port") to "Logical Printer 1"
fourmirly
Posts: 2
Registered: ‎01-10-2007

Re: TCP/IP Printing on WPS54G

I tried this three times. It still does not work wirelessly.
gomathi
Posts: 4
Registered: ‎01-12-2007

Re: TCP/IP Printing on WPS54G

hi..
 
Match the wireless settings  (wireless ssid , channel , security if you have enabled)from the router to the print server properly. Because its all case sensitive. still it is not working means need to go for firmware upgrade for the router. please mention the model no of the router and the print server with version number.
 
                                                                                                 thanks
 
 
bailar
Posts: 1
Registered: ‎02-06-2007

Re: TCP/IP Printing on WPS54G

I got a KPG-4010/E printserver (serialnr: 301WU461L00612, MACadress: 00031B563131) [from KTI Networks]

I have recently upgraded the firmware and the printserver can print to the printer when in a LAN (RJ45 cable from Printserver to the router), but when I unplug that cable to see if the printserver works wireless, it wont work and I cant ping the printserver.

 I have also the same SSID, channel and WEP-key on the Printserver as on the WLan-router (a 3Com- OfficeConnect router)

The wireless-led is on too

what else is there to do to get this server up and running wireless? :smileyfrustrated:

 

regards!

DoctorA
Posts: 4
Registered: ‎01-19-2007

Re: TCP/IP Printing on WPS54G

Sir, you just saved me from terminal frustration-Thank You!  I did the normal install and for some reason one of my computers would not communicate with the print server.  I did your step by step procedure and I am fine now.  I do not print server PS diagnostic in taskbar but as long as printer works for both computers I am happy.  You did more for me than Linksys Tech Support I am sad to say. 
Stay in good health!
Doctor A   
anatman
Posts: 1
Registered: ‎02-28-2007

Re: TCP/IP Printing on WPS54G

bailar I am having the same exact problem. I also would like to add more WEPs and in the page to add them the empty boxes are acting like "gray boxes" (uneditable). If anyone has an answer that would be great b/c linksys doesn't...
stormer
Posts: 1
Registered: ‎03-02-2007

Re: TCP/IP Printing on WPS54G

"

Make sure your printer already has its drivers installed on all PC's prior to attempting to install this print server. "

Do you mean have the drivers that came with the printer installed on the computers or do you mean have the printer server drivers for the computer installed?

 

    Be sure also that your printer can print when it is connected directly to your computer.

      Does the printer remain plugged into the computer with this set up?  Or do I just check to see that the computer can print and then connect it by USB directly to the printserver?

       

      Thanks

      BeanDip
      Posts: 1
      Registered: ‎03-07-2007

      Re: TCP/IP Printing on WPS54G

      I was following these instructions and could not get it to work.

      I wanted to give in and return the unit but couldn't give up :smileyhappy:

      In the TCP/IP port config I changed the LPR queue name from L1 to USB1 and now it prints like a champ.

      I couldn't find this info anywhere in the forums or the support site. The WPS54G firmware is 6050 so I don't know if that has something to do with it since 6049 is the latest available on the site.

      It fixed my problem so I wanted to share.