Showing results for 
Search instead for 
Do you mean 
Reply
Linksys
Product Review
Posts: 59,461
Registered: ‎05-09-2011

E4200v2 - Awful wifi

The good:
Wired speed is great. Same speed as being plugged directly into cable modem, even with router's firewall enabled.
The UPnP Streaming Media Server functionality is fast and responsive. Works great with Windows 7 and Windows Media Player. With Apple, not so much. But that's Apple refusing to support the standard, not an issue with the router.

The bad:
Wifi is terrible.

Basic Connectivity:
The N connection is just broken. Thinkpad w520 (with intel centrino advanced n 6205 adapter) and brand new macbook air cannot connect to the n connection on 2.4 or 5GHZ.
You're limited to G speeds on 2.4Ghz range.
On 5Ghz range, N is also broken, so wifi adapter reports 54Mbps max connection on mixed mode.

Speed:
Awful. Takes a 20Mbps wired connection and cripples it down to 1Mbps. Never seen such a horrible degradation of performance.

Many wasted hours in forums and trying all possible settings and factory 30/30/30 reboots, etc.

Cisco brand team should be embarrassed that their name is on top of this device. This is a classic Linksys product. i.e. No Quality. Stay away.

Running firmware:
01/04/2012
Ver.2.0.36
[...]

helm
Posts: 3,650
Registered: ‎09-07-2006

Re: E4200v2 - Awful wifi

First of all, please verify that you have got an 802.11n card in your computer. New generation routers (i.e. E4200) speaks an entirely different language with 802.11g cards, so while those adapters can work with the E4200, but they are not optimized to provide good performance. It is like having to translate from one language to another in real time when going from N to G.

SECOND, make sure the adapter driver is up to date.

 

Try to do the following steps:

 

A] With the help of Cisco Connect Software (if at all you have installed the router with the help of this software)

1] Open the software and go to the option which says "Router Settings"

2] Then click on the option which says "Advanced Settings" which will take you to the router's configuration page.

3] Then go to the Wireless tab, keep network mode as mixed,

For Channel Settings of 2.4 GHz you can make Channel Width to 20 MHz only and Channel to 6, 9, 11..

For Channel Settings of 5 GHz you can make Channel Width to 20 MHz only and Channel to 40 or 161...

 

 

B] If you haven't installed Cisco Connect then you can log on to the router's user interface using it's default IP address in the browser which is 192.168.1.1 and type in 'admin' as the password leaving the username field blank. This will take you to the router's web interface and then follow steps as mentioned above to make the changes.