Showing results for 
Search instead for 
Do you mean 
Reply
Lunchb0x
Posts: 3
Registered: ‎10-07-2008

802.1q trunking SLM224P to existing Cisco based VLAN setup

I have 2 VLANs set up in my environment on the Ciscos. The default is our corporate LAN and VLAN 2 is our Guest network. I have a port on the Cisco configured as a trunk. I plugged from that port to the Linksys Port 1. According to what I have read so far, leaving all ports in the default port EXCEPT the ones I want on VLAN 2 will work, but I have to have Port 1 on the Linksys be a member of both VLANs and ingress filtering should be disabled on that port. I have done that.

The documentation for this switch says it is 802.1Q, but makes NO mention of how to setup a trunk. I have read other posts on trunking here on this forum and they don't pertain to the model number that I have, so they aren't exactly correct.

Basically, what I am looking to accomplish is Port 1 should be the trunk, ports 2 through 6 should be my existing Guest network (on the Ciscos referred to as VLAN 2) and the other 18 ports should be on my corporate LAN (the default VLAN on the Ciscos). Is my problem that the corporate network is not set up on a specific numbered VLAN so the Linksys doesn't know the difference?

I think a step by step from Linksys would be great, since they "support" this configuration and enough people are baffled on how to do it...

Anyone have any ideas?
KangKong
Posts: 39
Registered: ‎09-29-2008

Re: 802.1q trunking SLM224P to existing Cisco based VLAN setup

Actually there is no way to configure the any of the ports as trunk nor access. They designed the SLM switches having all ports set as general. Just match all the VLANs that you have on the Cisco switch. Member port 1 of the SLM to all VLANs and set it's PVID with the Cisco's native VLAN.
Lunchb0x
Posts: 3
Registered: ‎10-07-2008

Re: 802.1q trunking SLM224P to existing Cisco based VLAN setup

That is how I have it set up now and all access to the default VLAN works but I cannot access anything on VLAN 2.
 
The way I have it configured now is this...
In the VLAN Management - Port Settings tab:
SLM Port 1 is PVID 1 with Ingress Filtering DISabled.
SLM Ports 2-6 are PVID 2 with Ingress Filtering ENabled.
All other SLM ports are PVID 1 with Ingress Filtering ENabled.
 
In the VLAN Management - Port to VLAN tab:
VLAN 1 shows that all ports are untagged, except for ports 2-6 which are excluded.  Everything is grayed out so no changes can be made here.
VLAN 2 shows Port 1 is untagged, ports 2-6 are tagged and all other ports are excluded.
 
In the VLAN Management - VLAN to Port tab:
All ports show as 1U, EXCEPT for ports 2-6 which show as 2T.
 
It still doesn't work.  What is it that I am missing?
Lunchb0x
Posts: 3
Registered: ‎10-07-2008

Re: 802.1q trunking SLM224P to existing Cisco based VLAN setup

Anyone?
Expert
Expert
Posts: 12,649
Registered: ‎07-16-2006

Re: 802.1q trunking SLM224P to existing Cisco based VLAN setup

Without knowing the exact VLAN trunk configuration on the Cisco it is a little bit difficult to tell.

Usually, a trunk port carries the management VLAN untagged and the other VLANs tagged. On the Cisco the untagged management VLAN is the "native" VLAN on that port. Considering your setup I assume you have set up VLAN 1 as native and added VLAN 2 to the trunk port on the Cisco.

This would mean that the Cisco sends and receives untagged frames for VLAN 1 and sends and receives frames for VLAN 2 tagged. On the SLM you have to match this on the trunk port. You have to add VLAN 1 untagged and VLAN 2 tagged on that port. PVID should be 1. This should establish the connection between the Cisco and the SLM.

Ports 2-6 for guests should probably operate with standard untagged frames. I doubt that all your guests have VLAN capable NICs and set up the necessary VLAN 802.1q tag on their computers. To assign a port to a single untagged VLAN 2 you set the PVID on these ports to 2. Moreover, the port should only carry VLAN 2, i.e. it should only be untagged member of VLAN 2 and not of any other VLAN.

Likewise you configure all other ports to be untagged member of VLAN 1 by setting PVID to 1 and making them untagged member of VLAN 1.

The problem may be (I don't know the SLM): the SLM uses VLAN 1 as management VLAN and adds it automatically untagged to all ports and there is no way to remove it, i.e. you cannot remove VLAN 1 from ports 2-6. That would complicate things. You could try a few things:

* change the management VLAN on the SLM to a completely different one (e.g. VLAN 9). Hopefully then you can remove VLAN 1 from those ports.

* change the VLAN numbering. Do not use VLAN 1 for any normal VLAN but only for management, i.e. change the company VLAN from 1 to something else, e.g. VLAN 10. Now, on the trunk port, run VLAN 1 untagged and VLAN 2 & 10 tagged.