Reply
Posts: 5
Registered: ‎10-26-2007

srw224g4 v1.0 upgraded causes port lights to go out

[ Edited ]
Hi, I just upgraded my SRW224G4 (h/w v.1.0 - yes, the Canadian version!) with the latest firmware:

Firmware Date: 1/28/2007
Firmware Release Version: 1.2.2a

And after about an hour of running, all the led port lights on the first segment (ports 1-4 and ports 13-16) all go dark. The ports are alive and my devices on those ports are working, but the indicator leds are out. Only a reboot restores the lights and in an hour there out again. I searched the forum and couldn't find anyone else with this problem and I can't seem to find the older version to downgrade back to.

Can anyone provide me some suggestions? Thanks, -Rob

Message Edited by Smelly on 10-26-2007 11:15 AM
Posts: 181
Registered: ‎10-27-2007

Re: srw224g4 v1.0 upgraded causes port lights to go out

You may try to connect your computer to the switch via hyperterminal and then reflash the firmware via xmodem. Check if that will fix the problem.
Posts: 5
Registered: ‎10-26-2007

Re: srw224g4 v1.0 upgraded causes port lights to go out

I HTTP uploaded AND tftp'ed the image - twice. No luck. Why would the xmodem transfer be any better? Thanks, -Rob
Posts: 5
Registered: ‎10-26-2007

Re: srw224g4 v1.0 upgraded causes port lights to go out

So, after digging for hours for a Hyperterm replacement (since Hyperterm doesn't exist on Vista anymore!) I used a program called Poderosa with the XModem plugin and successfully uploaded the image via XModem.

Still have the same problem. First segment of lights go out about an hour later.

Is there no one from Linksys support reading this that can give me some advice before I start wasting my time on telephone support?

Thanks,

-Rob
Expert
Expert
Posts: 12,649
Registered: ‎07-16-2006

Re: srw224g4 v1.0 upgraded causes port lights to go out

No. There is no one from Linksys here.
Posts: 1
Registered: ‎05-18-2008

Re: srw224g4 v1.0 upgraded causes port lights to go out

I have the same problem with my switch. It has the latest firmware. Was there ever a solution discovered? Thanks.
Posts: 5
Registered: ‎10-26-2007

Re: srw224g4 v1.0 upgraded causes port lights to go out

[ Edited ]
My solution was an RMA return/replacement to Linksys. The new unit was 1.1 hardware and worked like a champ.

I've decided not to upgrade firmware unless I have a problem or need a feature a newer firmware brings. If it ain't broke, don't fix it!

Thanks,

-Rob

Message Edited by Smelly on 05-19-2008 08:21 PM
Posts: 1
Registered: ‎11-06-2009

Re: srw224g4 v1.0 upgraded causes port lights to go out

Same problem here, upgraded firmware to 1.2.2 for version 1.0 hardware. Boot Loader is 1.0.0.06

Sometime the 1 to 4 and 13 to 16 port activity leds just go dark. 

I bought it off ebay so no RMA to linksys. Anyone else have the LED problem? Thanks, Rick

Expert
Expert
Posts: 12,649
Registered: ‎07-16-2006

Re: srw224g4 v1.0 upgraded causes port lights to go out

Call Cisco Small Business Support and explain the situation. I think they have at least 3 years warranty on the switches. They can check the manufacturing date. If it is less then three years old they will RMA it definitively. If it is older, maybe they still do it.