Reply
amaramrahul
Posts: 2
Registered: ‎01-21-2010

Ignoring userid for direct inbound calls

I was wondering if it is possible to ignore the userid and accept all inbound calls to my Linksys PAP2 device. The reason being I have configured my outbound VOIP provider on my Linksys PAP2. Now when I receive direct inbound calls, my friends are forced to use this user id of the VOIP provider. But this is a bad idea as I keep changing my VOIP provider often. Therefore I was wondering if there is any option in Linksys PAP2 which enables me to ignore the userid for direct inbound calls.
scrooge
Posts: 2,610
Registered: ‎09-07-2006

Re: Ignoring userid for direct inbound calls

You need unique SIP ports and unique userids for the two lines. NOTE: It's quite OK to use whatever "userid" the provider on that line supplied (for logging into their SIP proxy). You don't need the UserId set to any specific value, just something unique!
amaramrahul
Posts: 2
Registered: ‎01-21-2010

Re: Ignoring userid for direct inbound calls

I will try to explain the problem in a bit more detail. Let us assume the below values for explanation.

 

VoIP Provider User id: johndoe1984

VoIP Provider Proxy:  sip.somevoipprovider.com

Public IP of my PAP2: 123.234.125.22

 

Now these are the settings which I configure on my Line 1 so that I can make outbound calls using this VoIP provider.

 

Now if from some other SIP phone, I dial "sip://johndoe1984@123.234.125.22", my PAP2 device rings and I am able to talk properly. But if someone tries "sip://john@123.234.125.22", then the call doesn't go though. And I cannot change the user id field to "john" as the user id for the VoIP provider is "johndoe1984". But I would still like to be reached at "sip://john@123.234.125.22".

 

Is there any way I can configure my PAP2 device to help me accomplish this?

hw
hw
Posts: 371
Registered: ‎07-18-2007

Re: Ignoring userid for direct inbound calls

If your friends are making direct ip calls to your PAP2 you do need to include the userid (and port number if it is not 5060) in the sip uri unless the userid field is blank. 

If your userid changes because you are changing voip providers for your outgoing calls and this is a problem, then I would consider having your friends call a separate voip account that you keep where you forward the incoming call to your current address.  You should pick out a voip provider/account that allows both incoming and outgoing sip uri calling/call forwarding.  You can find a free voip provider that will do this.