Posts: 4
Registered: ‎12-30-2009

MagicJack and the PAP2T

My MagicJack works fine under XP and Vista when plugged into the USB port.  But I cannot get the the PAP2T to give me anything more than - Registration State:Can't connect to login server.  


I have sussed out my MagicJack username E[phone_number]01, my twenty-upcase-alpha-num-character password and my  I have found several links on the web with configuration info.  My PAP2T has a fixed IP address because I intend to use it through an old Linksys router I have successfully reconfigured as a wireless bridge.  But first I need to get the PAP2T to work hard-wired with my MagicJack account.  


"Sip User Agent Name" and "SIP Reg User Agent Name" have me confused.  Different folks seem to use different info there.  My MJ has SW version 1.80.499.2.  Does this affect those entries?  


What does "Mailbox Subscribe Expires" [2147483647] mean?  That was the same in one of the config tips that I saw, but it sure looks like somebody's phone number to me.


My PAP2T is set for a fixed IP address

The router that I am going through has IP addresses[1-50] set up for DHCP.    Is that what I should do?


I entered the fixed IP for my PAP2T in my router DMZ.

Ports UDP: 5060-5061,  53, 69, 10000-20000 have been forwarded.

Do I need to forward 5070?


I've power-cycled everything many times.  


I could have bought a used xp box to run as an always-on MagicJack server for the time I have invested in trying to get this PAP2T to work with my MagicJack account.  

If MagicJack does what they have announced and come out with Linux support in 1Q10, then I won't need the PAP2T since my desktop machine runs Ubuntu, but I currently get the same registration failure error running twinkle on 9.10.


Any suggestions would be most appreciated before I put this thing back in the box and return it. 


Thanks in advance for your time and expertise.







Posts: 3,271
Registered: ‎09-07-2006

Re: MagicJack and the PAP2T

Try this link.
Posts: 4
Registered: ‎12-30-2009

Re: MagicJack and the PAP2T

Hi Carrot,


Thank you very much for your reply.  Until now, I was feeling totally abandoned.  Before making my initial posting, I had followed your supplied link to the PAP2T-related posts at that site.  There were two posts.

was posted in August 2009 and has zero replies.  It is now January. was posted in June 2009, includes excrutiating detail and has a few replies.   Before my initial post, I spent several hours going over the jpgs of his setup and comparing mine, box by box, entry by entry.


First, those JPGs do not show EXACTLY the same version of PAP2T web setup screens that I have.  Second, some of his entries are indecipherable, blocked by the border of the entry window.  So I found some text versions of configuration files and used that information to complete my setup, which still doesn't work.  Now that we are literally on the same page, maybe you (or someone else) can answer my questions about setup.


I have:

Product Name:    PAP2T   
Serial Number:    FLI00J9xxxxx
Software Version:    3.1.15(LS)   
Hardware Version:    0.3.5
MAC Address:    002369xxxxxxx   
Client Certificate:    Installed
Customization:    Open


My PAP2T is wire-connected to a Netgear WGR614v7 router connected to a cable modem supplied by comcast.  The Netgear router is connected to a desktop PC that runs Linux but can also boot into XP or Vista.  It also connects to a Mac.  There is a wireless connection to an HP laptop running Vista.  HP/MS destroyed the ability of that box to recognize its internal wireless card, so my first solution was to DDWRT reconfigure a Linksys WRT54Gv5 router as a wireless bridge.  Then the USB WLAN dongle I ordred arrived and I use that.  The point of mentioning all these details is to demonstrate that there is PROBABLY nothing wrong with my modem, router or my ability to follow directions to get this technology stuff operable.   Yes, conceivably there is something goofy in my router setup.  There are additional notes on this below.  However, the "Attached Devices" list from my router setup shows, which is what I assigned my PAP2T, connected.   


Most of my entries are identical to the linked example jpgs.  His system setup is omitted.  Mine is:


Restricted Access Domains:   
Enable Web Server: YES       
Web Server Port: 80   
Enable Web Admin Access: YES       
Admin Passwd:    [entered]
User Password:    [entered]       
Internet Connection Type                          
        DHCP:    NO (because I have a static IP, below because I plan to use DDWRT-configured wireless bridge)
        Static IP:   

        Gateway:    (IP for my wired-router)   
Optional Network Configuration                         

        Primary DNS:   

        Secondary DNS:   
        DNS Server Order: Manual   

        DNS Query Mode:    Parallel
        Syslog Server:       

        Debug Server:   
        Debug Level:    0   

        Primary NTP Server:
        Secondary NTP Server: 


SIP:  (Most of my entries are identical to the linked example jpgs.)

SIP User Agent Name: MagicJack/1.80.466c (SJ Labs)  This is from the jpg example.

SIP Reg User Agent Name: MagicJack/1.80.466c (SJ Labs)

These entries are cut off in his window, but I found them elsewhere in some text files.  My MJ is software version 1.80.499.2. 

I have also tried the above yellow entries with the number changed to 1.80.499.2 and 1.80.499b without success.  Looking in the text files used to find my password, I find 

User-Agent: MagicJack/1.80.499b (SJ Labs)  But this entry results in Can't connect to login server.  The example, ...466c entry, results in Offline.

STUN Server: 

I have tried, (found while sniffing my password),, sip.stun.server with and without :3478 (like everything else I've tried),, talk4free,,, and the IP address for these provided by nslookup, with and without :3478. Once I have completed and saved, it returns to the INFO page.  Some of the entries result in Registration Status: Can't connect... and some result in offlineWhich is a "better" REGISTRATION STATE, "Offline" or "Can't connect to login server?"  I assume that connecting and being offline is better than not connecting.  I assume that because it seems to me that if I am at least connected to the login server and then correct whatever the problem is, registration would be completed and MJ would be connected.  


My Provisioning and Regional pages are identical to the examples, unless there are slight omissions on my page for the entries to even exist.  


Line 1  (Set per the jpg examples except as noted below)

Proxy: proxy1,  (I have also run nslookup on and lower case denver with and without the 0 and they all resolve to the same IP.   I have tried it with and without 5070 and I have tried it with 5060 as well.  Yes, my wired router has ports forwarded to the static IP of the PAP2T for ports 5060-5070, 53, 69, and 10000-20000.  Also, the PAP2T IP has been assigned as DMZ.) 

Mailbox Subscribe Expires: 2147483647  (The default entry, IIRC.  WHAT DOES THIS MEAN?)

Display Name:    [my 10-digit-phone-number]   
User ID:    Exxxxxxxxxx01
Password: [20 characters, found to be numbers and capital letters]       
Use Auth ID:    [same as User ID]
Auth ID:  [blank]

Dial Plan: (*xx|[3469]11|0|00|[2-9]xxxxxx|1xxx[2-9]xxxxxxS0|xxxxxxxxxxxx.)  = The default PAP2T plan.  I will change this if/when I get it functional.


Line 2, User 1 and User 2 were left in the default condition.  Yes, my phone is physically plugged into the Line 1 port.  


That is EVERYTHING I can think of that is at all related to this. 

ANY HELP WOULD BE MOST APPRECIATED.   I'd be thrilled to answer any questions, try any suggested changes or test any ideas. 



 - Flash412
Posts: 4
Registered: ‎12-30-2009


[ Edited ]

After setting IP in the PAP2T back to DHCP, I plugged my PAP2T straight into my Comcast cable-modem and rebooted both.  There was still no dial tone.  That test eliminates any router setup issues, boiling the system down to a known-good modem and a new, never-known-to-have-worked PAP2T.


The internet and power lights work properly on the PAP2T.  If my PAP2T is not yet properly connected/registered to a VOIP service, should the PHONE light illuminate on the PAP2T box?  I have NEVER seen any phone lights, one or two, even when doing DHCP-off, static IP set, authorize web-access, via voice setup through the telephone handset.  Should I see a light when using the voice menu?  Oddly, the HOOK STATE correctly shows OFF or ON when I lift or replace the handset and refresh the PAP2T Info page and still no PHONE 1 light. Maybe the problem is that my unit is partially dead on arrival. 


If there is no response in this forum, then I will restore the factory settings and exchange the unit for replacement.  If the replacement unit behaves the same, maybe it is safe to assume that is proper operation.  The Linksys Pap2T manual and "support" are quite disappointing. 



Message Edited by Flash412 on 01-03-2010 06:30 PM
Posts: 1
Registered: ‎01-05-2010


haven't looked through all of your post but after struggling with a similar problem (device clearly hooked up to wgr614 + adsl modem and recognised but no leds for lines 1&2 and "no registration" in the config, no dialtone on phone), 


i finally switched from the static ip to dhcp WITH stun server enabled (bottom of the SIP config page) and everything clicked into place (STUN server means you don't have to worry about port forwarding on your modem/routers at all). leds lit, dialtone on, ready to go.


i'm about to try switching back to static and adding the DNS servers that my ISP is giving my modem, just to see if it works- could be that for some reason the pap2 ain't getting these with static ip (but happy with dhcp as forwarded). i am no expert just muddling my way through trial and error.


good luck

Posts: 4
Registered: ‎12-30-2009

Thank you for your reply, odusseia.  Previously I had been using Static IP with STUN Server.  


After I changed my settings, I unplugged my PAP2T, router and modem.  Then plugged the modem back in until it was happy, plugged the router in until it was happy and then the PAP2T.   I'm still not getting registered.  Sometimes it says offline and sometimes it can't find the login server.  Upon refresh, the Hook State always matches whether or not I have the handset lifted.  Still no Phone 1 light or dialtone. 


Please compare your settings to mine in yellow below and let me know what differences you see, if any. 


Advanced View


DHCP: YES  (Cleared out my Static IP, Gateway, Netmask and DNS entries for good measure.)  


DNS Server Order: DHCP, MANUAL

Primary and Secondary NTP Servers both have entries, &, but the time sets properly so I don't see that as a problem.

For your USER PASSWORD, are you using the 20 character MagicJack password set in the Line 1 page?  I am not. I think that is just for access to the PAP2T over the web. 



SIP User Agent Name: MagicJack/1.80.499b (SJ Labs)  <- because my unit has sw version 1.80.499.2

If you have success with a different entry, what is it and what sw version does your PAP2T have?

SIP Reg User Agent Name: MagicJack/1.80.499b (SJ Labs)

STUN Enable: Yes


STUN Test Enable: No


 - LINE 1

Line Enable: YES

Proxy: proxy1,

Use Outbound Proxy: NO

Register: YES

Use DNS Srv: NO   (I've also tried YES without improvement.)

Display Name:    <my phone number>   
User ID:    E<10 digit phone number>01

Password:     <20 characters, capital letters and numbers>

Use Auth ID:    NO
Auth ID: (same as User ID above)




 - Flash