Reply
eenright
Posts: 4
Registered: ‎01-19-2009

WIP310 and Caller ID/Contact List

Hello,

 

With most phones, when you receive a call from a number that you have in your contact list, it will display that contact's name, etc, as the phone rings.  This phone, a new WIP310-G1, on the other hand, always displays "Unknown" along with the number -- even though I have this number saved on a contact.

 

This seems to defeat the purpose of having a contact list to begin with.  If I knew everyone's number by memory, I wouldn't need a contact list.  So what gives?

 

pretzel19
Posts: 176
Registered: ‎07-18-2007

Re: WIP310 and Caller ID/Contact List

Does it happens in all callers? (all in the contact list)
eenright
Posts: 4
Registered: ‎01-19-2009

Re: WIP310 and Caller ID/Contact List

All callers.  This happened with the 5.0.8 firmware, and as well on 5.0.11.  A factory reset was also done after the upgrade to 5.0.11, still no luck.
seico
Posts: 2
Registered: ‎01-21-2009

Re: WIP310 and Caller ID/Contact List

My WIP310 have no problems matching the CID # to stored contact list in either .08 or .11 firmwares.

 

You should contact 1-866-606-1866 for trouble shooting support.

 

 

 

dnagel
Posts: 2
Registered: ‎01-27-2009

Re: WIP310 and Caller ID/Contact List

Where did you download a version of the 5.0.11 firmware that did not cause you to no longer be able to register with your SIP provider from?

 

I am now going on day 5 (five) with a Cisco support case (incident number available) and they took a 5.0.8 phone installed my information on it at their lab the phone registered and was operational then the unit was updated/upgraded to 5.0.11 (as downloaded from the Cisco.com web site) and their phone as well as mine would no longer register with the provider.

 

On another note how do you enable the speakerphone on the WIP310, supposedly it has one, however even the support rep at Cisco has yet to be able to tell me how to activate/use it.

 

FYI, don’t even attempt to find the “User Guide” for this phone as evidently it was lost in the Cisco/Linksys change over. Anyone who has one I would appreciate a copy.

 
eenright
Posts: 4
Registered: ‎01-19-2009

Re: WIP310 and Caller ID/Contact List

I downloaded 5.0.11 from Linksys prior to the changeover, however I've also got a free cisco.com account and the firmware was available there beginning on or about the weekend of the 17th/18th.  It had previously been missing for a while...   You can also get the software manuals there as well, but probably need an account for that too.

 

What I posted above is really only more of a cosmetic problem with the phone.  I actually had a much more deal-breaking problem where the device would randomly lose registration with my Asterisk.  Asterisk would repeatedly flag the phone as LAGGED, then Reachable, then LAGGED, then Reachable, and so on forever.  After a while, the phone would lose registration and does not attempt to reregister until it's SIP registration timer expires, which by default is 3600 seconds (an hour and a half.)

 

At which point it registered flawlessly, and would work well until the next blip.

 

Furthermore, this loss of registration would sometimes happen in the middle of a call -- pretty embarassing for someone showboating their new $250 phone.

 

This occurred with both 5.0.8 and 5.0.11.

 

I first suspected Wifi interference was killing it, as I was primarily using the device in a 30 floor condo, but extensive twiddling with my wireless settings seemed to indicate otherwise.  Bringing the device into the office where we have extremely low wireless usage inside the building, which is an island far away from other buildings, exhibited the same problem.

 

I believe that phones should be as reliable as tapwater, so with all this combined  I returned it to my supplier.  I would normally cut some slack as it's been out less than a month, but given all the time it's wasted me I just can't be bothered to waste more time on the phone with tech support.

eenright
Posts: 4
Registered: ‎01-19-2009

Re: WIP310 and Caller ID/Contact List

Oh, and I was able to activate the speakerphone via a button on the left edge of the device.  It was pretty poor quality, and the mic would pick up the speaker causing an echo on the other party's end.
dnagel
Posts: 2
Registered: ‎01-27-2009

Re: WIP310 and Caller ID/Contact List

Just an update, being that is officially day 7. Cisco found that under the SIP tab that the “SIP Reg User Agent Name” must be filled in with the ”User ID” even though the documentation states on page 80 “User-Agent name used in a REGISTER request. If not specified, the SIP User Agent Name is also used for the REGISTER request. Defaults to blank.”

 

This resolved the registration issue, they are now working to figure out why the unit will not initiate or pick inbound calls, and the unit itself does ring on inbound calls.

 

I have been unable to locate an available download for the 5.0.8 firmware, does anyone have a copy I could obtain, or know of a valid link where I would be able download the older version from.

  

Thanks in advance,

David

blackc2004
Posts: 1
Registered: ‎06-22-2009

Re: WIP310 and Caller ID/Contact List

I was wondering if there has been any update on this? I am having the same cal problem where I cannot accept incoming calls. The phone rings, but once I press the "send" button to answer the call, nothing happens.
ColinS
Posts: 1
Registered: ‎08-31-2009

Re: WIP310 and Caller ID/Contact List

I have just got a WIP310 which came delivered with 5.0.11 already installed.  I have it connected to Asterisk and the operation is absolutely fine but I do have the issue stated in the original post that it doesn't display the name from the contacts.  Is this just how it is or is there an issue here.  It may seem cosmetic but I find it a real pain not knowing who is calling me.  Surely this should be a standard feature.