Showing results for 
Search instead for 
Do you mean 
Reply
edenkers
Posts: 14
Registered: ‎09-02-2009

Re: MagicJack SIP VOIP Device - drops incoming calls behind WRT610N


sgreene2 wrote:
Yeah I contacted them, lost the online chat session and continued it via email.  It didn't lead anywhere.

 

I'm waiting for "Case Management Team" to contact me on open case.  Perhaps you can find some time to contact them again.

 

I don't know about you, but the MagicJack is my only "land line" at home and I got to have it working.  This is going to be a deal breaker and if this issue is not resolved by LinkSys support, it's going to be returned and I will look into other routers.

 

Are there any other "simultaneous" dual band routers out there that you know of?

 

Erik

edenkers
Posts: 14
Registered: ‎09-02-2009

Re: MagicJack SIP VOIP Device - drops incoming calls behind WRT610N

I did a lot of digging around on the internet and stubled upon the "Unofficial MagicJack Forum".  There are several threads there on the dropped incoming calls issue.

 

However, after reading the first thread, someone posted that the latest wrt610n firmware (Ver.1.00.03 B15 - 07/28/2009) has "Added support of enabling/disabling SIP ALG (Application Layer Gateway)".  I wonder why one of LinkSys' tech support reps never had me try this option.

 

I have not yet verified or tested this, but supposedly if you open the router's web interface this option should be found under Administration -> Advanced Features.  Simply DISABLE SIP ALG and the magic jack is supposed to work.  I will test this as soon as I get home and thanks needs to go out to tDogEast for posting this solution in this forum (http://www.magicjacksupport.com/incoming-calls-drop-after-30-seconds-pending-ack-t4448-15.html).

 

I will report my findings as soon as I can.

 

Erik

 

 

 

sgreene2
Posts: 9
Registered: ‎05-13-2009

Re: MagicJack SIP VOIP Device - drops incoming calls behind WRT610N

Yes that option is listed in there (checkbox), id did not help.  The only thing that improved was that I could get a second incoming call (after the first dropped) without having to re-start the magicJack software.
edenkers
Posts: 14
Registered: ‎09-02-2009

Re: MagicJack SIP VOIP Device - drops incoming calls behind WRT610N


sgreene2 wrote:
Yes that option is listed in there (checkbox), id did not help.  The only thing that improved was that I could get a second incoming call (after the first dropped) without having to re-start the magicJack software.

 

Well, in my case, I never have to re-start the MagicJack software, it always drops calls after about 30 seconds, whether it is the first incoming call or the second incoming call, and so on so forth.

 

There was another "temp solution" posted on the same thread found here... http://www.magicjacksupport.com/incoming-calls-drop-after-30-seconds-pending-ack-t4448.html

 

Scroll down and look for the post from tDogEast that was Posted: Wed Jan 21, 2009 10:12 am

Post subject: Here is the temp Solution that works for me.

 

I am still going to test the DISALBE SIP ALG when I get home and let you know what I find out.

 

Good luck,

Erik

 

edenkers
Posts: 14
Registered: ‎09-02-2009

Re: MagicJack SIP VOIP Device - drops incoming calls behind WRT610N

I have joy.  I went to the Administration page, found the check box and check off DISABLE SIP ALG.  Re-booted the router, and low and behold my MagicJack is no longer dropping calls.

 

My MagicJack is now working perfectly.  No SINGLE PORT FORWARDING, no PORT RANGE FORWARDING, no PORT TRIGGERING, and no DMZ.  No special configuration except to DISABLE SIP ALG.

 

I suggest that if you have the issue described in this thread, that you do the following....

 

Do Hard reset of router (30-30-30), flash or reflash the latested firmware, DISABLE SIP ALG and re-boot.  Then go to computer with MagicJack and restart it.

 

Good luck,

Erik

 

sgreene2
Posts: 9
Registered: ‎05-13-2009

Re: MagicJack SIP VOIP Device - drops incoming calls behind WRT610N

I to tried disabling SIP ALG under administration (I didn't reboot the router) and it worked.  I guess originally I thought that SIP SLG had to be enabled in order for magicJack to work.  I tested it and it's working fine now.  I have version 1 of the 610N router with the latest firmware.  When I tried re-enabling SIP ALG the incoming calls started dropping after 30 seconds again.  I guess this checkbox was Linksys fix to the magicJack problem.
edenkers
Posts: 14
Registered: ‎09-02-2009

Re: MagicJack SIP VOIP Device - drops incoming calls behind WRT610N

Just got a call from LinkSys Level II support tech.  He asked me if I was using the latest firmware (Ver.1.00.03 B15), to which I replied, "Of course".  He told me that firmware was supposed to fix issues with SIP devices like the MagicJack.  Well, I told that it did not fix any issues, but however, having the option to DISABLE SIP ALG, was a winner for me.  He replied with "That's very interesting".  I told him that I was a happy camper now that my MagicJack is working with SIP ALG disabled.

 

I guess they are going back to the drawing board and will try to "fix" the issue again.

 

Erik

sgreene2
Posts: 9
Registered: ‎05-13-2009

Re: MagicJack SIP VOIP Device - drops incoming calls behind WRT610N

well the disable/enable SIP ALG was new with that firmware version - so I guess that's why they added that option in there.
Lux Aeternus
Posts: 1
Registered: ‎01-17-2010

Re: MagicJack SIP VOIP Device - drops incoming calls behind WRT610N

I recently switched the magic jack from my my wife's computer to our home server and started to experience dropped call at the 32-second mark.  Regardless of what configuration settings I tried it consistently dropped any call at 32-seconds.  I was convinced the "PENDING ACK" on the magic jack display was the key.  After reading all of the posts in this thread I realized that the host computer's IP (one that the magic jack is attached to) must be updated in the Linksys router.

So, here's how to FIX this issue.

1. Get your CURRENT IP Address.  Open a command line and type:  ipconfig /all

2. Open your Linksys router's web interface and go to the section for "Port Range Forward".  In this section you'll find ports 5060 and 5070 are listed and have an assigned IP Address. 

3. Update your old IP from Step# 3 with the new one from the command line and ensure the appropriate enable checboxes are checked.  Save Settings.

4. Update the IP Address under DMZ and Save Settings.

5. In Magic Jack go to Advanced Users --> Restart.

6. Test Incoming/Outgoing calls.

7. Rest & Relax.

 

NOTE:   This fix is based on a Linksys WRT54G, but should work for anyone switching between computers and modem/router resets.  The focus is the dynamic IP enabled by default on a linksys router vs.. a static one assigned by an advanced user.

 

I hope this helps,

Lux Aeternus 

edenkers
Posts: 14
Registered: ‎09-02-2009

Re: MagicJack SIP VOIP Device - drops incoming calls behind WRT610N

[ Edited ]

Lux Aeternus wrote:

 

 

So, here's how to FIX this issue.

 

4. Update the IP Address under DMZ and Save Settings.

 

I hope this helps,

Lux Aeternus 


Lux, I know that your solution works and it would be great, however, I don't think any one wants to put their home server in the DMZ.  That would leave it unprotected and vulnerable to attack.

 

If you read through the entire thread, you will see that there is a fix that works that does not require you putting the computer with the MagicJack in the DMZ.

 

Basically, on the WRT610N (which is what this thread is about), go the Administration page and check off the DISABLE SIP ALG option, reboot the router and then restart the MagicJack.

 

You don't need any SINGLE PORT FORWARDING or PORT RANGE FORWARDING or PORT TRIGGERING and you definately don't need to put it in DMZ.

 

This has been confirmed by LinkSys Technical support to be a working solution.  Due to privacy restrctions I can not reference my case number.

 

As far as the WRT54G router, I never had an issue with the MagicJack and that router.  It worked from day one without any special configuraitons.  I only began to experience issues when I upgraded to the WRT610N.

 

Best wishes,

Erik

 

Message Edited by edenkers on 01-18-2010 03:19 PM