Showing results for 
Search instead for 
Do you mean 
Reply
mikeschumann
Posts: 6
Registered: ‎01-17-2009

WRTU54G-TM Bridge Mode Issues

I have a WRTU54G-TM T-Mobile Router configured in Bridge Mode.  The firmware was involuntarily updated to V1.00.20 by T-Mobile recently.  The WAN port is connected to my LAN and is configured with a Static IP address of xxx.yyy.zzz.6. The LAN port on this router is configured using address xxx.yyy.zzz.50 (configuring this was VERY convoluted;  I had to configure the router LAN port address 1st while in Router mode, with the WAN port set to a different subnet;  Then I switched to Bridge Mode, and reconfigured the WAN port address).

 

The router basically works in bridge mode.  I can connect wirelessly.  Both my wireless connect and my hardwired LAN connections all use my main router DHCP server and have full connectivity to both my LAN as well as the internet.  I can ping Yahoo.com successfully from the WRTU54G-TM using the diagnostic interface, so my DNS server and default gateways are working properly.

 

However, with this configuration, the router will NOT register the Voice Ports with T-MOBILE.  I get the following errors:

 

NA     W005.1    ISP Error. Retry.
NA     W005.2    ISP Error. Retry.
NA     W005.2    ISP Error. Retry.
NA     W005.2    ISP Error. Retry.
NA     W006.1    ISP Error. Retry.

 

This all worked in firmware V1.00.19

 

In firmware V1.00.20 if I configure the LAN address on this router (in bridge mode) to a different subnet address, then everything works.  The wireless and hardwired devices connected to the WRTU54G-TM are still using subnet addresses from my main LAN and can talk to everything, and the T-Mobile voice ports register and work.

 

This is all very confusing, as Bridge Mode is not explained anywhere.  I assumed that in bridge mode the addresses for the WAN and LAN ports should both be on the same subnet (actually I would have assumed that in bridge mode the router would only have one address).  Any explanations on what is going on would be helpful.

 

This is either a BUG or VERY bad documentation, or both!

saber_tooth
Posts: 2,653
Registered: ‎09-07-2006

Re: WRTU54G-TM Bridge Mode Issues

Are you trying to Seyp Dynamic Routing on your Linsys Router ?

 

With Dynamic Routing you can automatically adjust to physical changes in the network's layout. The router, using the RIP protocol, determines the network packets route based on the fewest number of hops between the source and the destination. The RIP protocol regularly broadcasts routing information to other routers on the network.

To set up Dynamic Routing:

    * Choose the correct working mode. Gateway Mode should be used if your Linksys router is hosting your network's connection to the Internet. Router Mode should be selected if the router exists on a network with other routers.
    * Choose the protocol by which you transmit data on the network.
    * Choose the protocol by which the Router receives network data.
    * Click the Apply button to save your changes.

mikeschumann
Posts: 6
Registered: ‎01-17-2009

Re: WRTU54G-TM Bridge Mode Issues

This router has two modes you can select in the Advanced Routing tab:  Router or Bridge.  Gateway is NOT an option.

 

There is no documentation that describes what this means.  I am assuming that Bridge means that the unit essentially works as a switch and that the WAN, LAN, and Wireless connected devices are all on the same subnet.

 

Bridge mode does not work reliably (I am running V1.00.15)  The SIM card will not register.  There are numerous other problems that I will list in a separate thread.