Posts: 2
Registered: ‎01-03-2010
Accepted Solution

PLK300 unable to reset after failed attempt to use "advanced security" feature!

[ Edited ]

Help!  I had my PLK300 (PLS300 and PLE300) working great out of the box in two different rooms, and then I tried to set up advanced security.  Nothing works now, and the reset buttons don't get me back to where I started either.  I struggled with this for a week now, and actually bought another set which also worked great out of the box. I did not attempt advanced security and I'm willing to live without it.  But  I foolishly called linksys tech support and tried to get the other units working again -- the level of communication was very poor and they insisted on having me apply advanced security to my new working units as well as the original units. Result:  NONE of them works now, including the new ones that were working fine (again, without adv security) until I followed tech support instructions and they no longer work.  When I explained to tech support that now the new ones didn't  work the guy became evasive and complained of static on my phone line, and made a quick exit after giving me a case number.  Really useless system of support, I must say.


Anyway, ALL I WANT is to find out how to return the units to their original and unsecured but working state!  The 3 second reset does not work, and I have tried 5, 10, 30 seconds on the reset button as well.  Anybody got any ideas??? 


- Dave 

Posts: 2,766
Registered: ‎09-07-2006

Re: PLK300 unable to reset after failed attempt to use "advanced security" feature!

[ Edited ]

You may just press and hold the reset button for 30 seconds with the Power cable connected, then leave the unit unplugged and wait for 1 minute and re-connect the power cable...


Download 67.3 MB, re-install using the Utility...


You can also try upgrading the firmware for PLK300..You can find the Upgrade tool with firmware on

Message Edited by vai_fan on 02-04-2010 03:21 PM
Posts: 1
Registered: ‎02-05-2010

Re: PLK300 unable to reset after failed attempt to use "advanced security" feature!

[ Edited ]

I had the exact same problem that you did, and was getting very frustrated.  I fixed it by doing the following:


1. Go to:

2. Download Upgrade Instructions

3. Download Quick Installation.

4. Download latest firmware upgrade

5. Do the Upgrade first.  This will completely wipe out your security settings.  

        -This is a good thing as you probably know.

        -Do the upgrade on all units (PLE300 and all PLS300s that you have.

        -For the 4 port PLS300 just plug right in to your router)

6.  After firmware upgrade, follow the instructions in Qucik Installation TO A TEE.

     Do exactly what in says in the exact order it says.


This worked for me.  Good Luck.



Message Edited by bsgram on 02-05-2010 10:16 PM
Message Edited by bsgram on 02-05-2010 10:17 PM
Message Edited by bsgram on 02-05-2010 10:19 PM
Posts: 2
Registered: ‎01-03-2010

Re: PLK300 unable to reset after failed attempt to use "advanced security" feature!

[ Edited ]

Thanks to all for your helpful comments.  I was able to reset the PLE300 and PLK300 units to default by following the quick guide info posted AND by "power stabbing" the reset button -- it took a pretty hard press for 4 seconds or so until the powerline symbol blinked rapidly and then all was good!  I now have 6 units stationed throughout my house (without "advanced "security, so far) and they all work great!  I think it would be helpful training for the long-distance techs to play around with this problem and really see that the timing required for the various button presses is quite variable, especially for the reset button!


Many thanks,



Message Edited by dht67 on 02-08-2010 08:06 AM