Posts: 6
Registered: ‎08-26-2008

BEFSR41 v 4.3

I've got the wired router hooked up and can share files and a printer between my computers, and the computer that is near the modem can get on the internet fine, but the remote computer cannot access the internet.  All I get is "little or no connectivity."  I called the phone support and they guy was very patient as he led me through a bunch of steps checking this and that (most of which I didn't understand).  He said that there is a limit on the length of the cable between the router and the computer of about 20 feet.  I was told that the maximum length (maximum certifiable length) for CAT 5 patch or crossover cables is 328 feet (100 meters), but the cable I'm using is only 40 feet long!
Why can I share files but cannot get on the internet from the remote comptuer?
I can ping the router from the remote computer but not anything on the Net.  I'm totally confused...
Posts: 2
Registered: ‎06-11-2008

Re: BEFSR41 v 4.3

No way it is the cable.  If you can share files, it isn't the cable.
You are correct.  Maximum distance for a twisted pair ethernet cable is 100 meters (328ft.).
Here are some other good cable tutorials:
Posts: 2,766
Registered: ‎09-07-2006

Re: BEFSR41 v 4.3

Well try disabling the firewalls on the pc & you will be able to resolve the issue.
Posts: 6
Registered: ‎08-26-2008

Re: BEFSR41 v 4.3

Which firewall, the local pc (where internet works) or the remote pc (where it doesn't)?
Posts: 6
Registered: ‎08-26-2008

Re: BEFSR41 v 4.3

I tried disabling the firewall on the remote PC to no effect.  Through further investigation I have discovered that the remote PC is not able to reach the router to obtain an IP address and resorts to the Alternate Configuration (which is why I can share files).  When I turn off the alt config it uses an IPA from the XP apipa range and I can't do anything at all.
What is most odd is that the remote comptuer can ping the router when the alternate ipa within the range specified when the router is set up is used.
How can I tell if the router is attempting to assign the same IPA to both computers and once I know that, how do I correct it?
Posts: 6
Registered: ‎08-26-2008

Router not assigning IP to remote

I checked the DHCP Client table in the Linksys Local Network Setup and the remote computer isn't listed...  What's going on?
Posts: 6
Registered: ‎08-26-2008

more info

Atheros L2 Fast Ethernet 10/100 Base-T Controller Properties claims the device is working properly

I updated the driver to the most current for XP from the Atheros Communications website ( v2.6.7.15)

Under [Advanced] are the following options (current setting first, alternates follow slash)
Flow Control - on/off
Interrupt Moderation - on/off
Max IRQ per Second - set at 5000
MediaType - Auto / 10 Mbps or 100 Mbps at Full or Half Duplex
Network Address - Not Present / enter value
Number of Receive Buffers - set at 256
Number of Transmit Buffers - set at 64
Shutdown wake up - off/on
Wake Up Capabilities - Magic Packet & Pattern Match / All; Link Change; Magic Packet; None; Pattern Match

Right clicking on the property window gets a "What's This" description. It says "These properties are device dependent. Read the device manufacturer's instruction manual to determine the correct property settings." I don't seem to have an instruction manual and can't find one on the Atheros' website as they seem to be pushing the wireless technology. I can't even guess what any of these do so I'm not going to monkey with them.

Under [Resouces] I have
Memory Range - DFFC0000 - DFFFFFFF
IRQ - 17

There is no value for I/O and I don't see any way of setting one...

Any suggestions?
Posts: 6
Registered: ‎08-26-2008

Solution found!

Solved for me by kimsland at
Start-->Run--> CMD

On the command line type (copy and paste) each of these lines followed by Enter key:

ipconfig /release

ipconfig /flushdns

ipconfig /registerdns

ipconfig /renew

netsh winsock reset catalog

netsh int ip reset reset.log

netsh winsock reset
Worked like a charm!