Posts: 1
Registered: ‎04-02-2009
Accepted Solution

BEFSX41 Installation

[ Edited ]

Hello, this is my first thread on this forum.  Thanks for taking the time to review my question.

I had just purchased a BEFSX41 wired router yesterday, and I'm running into a "looping" issue when installing from the provided setup CD.  

It appears to be installing just fine until step 6, which is when it brings up a window that says "enter your password.  default password is admin".  So, I type in admin, click next, and let it do it's loading.  But the problem is, once the loading reaches 100%, the password window pops up again.  Again, I'll enter admin, click next, and it'll reach 100% again, only to bring up the password window again.  "looping"...

Any suggestions?

I'm an electrical engineer, and home networking still frustrates me.


Posts: 2,324
Registered: ‎09-07-2006

Re: BEFSX41 Installation

If you are trying to setup your router, with the Setup disk , you can remove the setup disk from your computer and configure your router manually.Before you configure your router manually, Press and hold the reset button for 60 seconds...Release the reset button...Unplug the power cable from your router, wait for 60 seconds and re-connect the power cable..


Click Here to setup your router with Cable ISP. 


Click Here to setup your router with DSL ISP. 



Posts: 3
Registered: ‎11-13-2010

Re: BEFSX41 Installation

Hi, I have been using the BEFSX41 in my network configuration for years with no problems with the WinXPPro machines.


I recently added a Windows 7-64bit system and now cannot get access to the internet with this new system.


The reason given in Windows diagnosis is "DNS server not responding" and "Windows cannot cummunicagte with the device resource (primary DNSserver)".


I have researched forums for days and tried just about everything recommended to no avail.


I have upgraded the router's firmware to the latest (BEFSX41_v1.52.10_code.bin), tried different settings on the router and windows 7 to no avail.


Attaching the W7 computer directly to the cable modem get's me instant access to the internet.


I upgraded my network drivers (Atheros gigabit lan) to the 64bit version. I have also upgraded all drivers of my ASUS MB to 64bit...still no joy.


When I try to access the router from a web browser, it will not accept authentication.


I have tried disabling DHCP and UPnP and still no joy.


I even tried putting W7 computer on DMZ to see if that would fix the problem but to no avail.


So, now I am at a loss and hope you can provide some assistance


Regards Doninoz