Reply
nickweavers
Posts: 3
Registered: ‎10-15-2009

Enabling ICMP for a specific IP address WRT610N

We have a service in the UK that allows us to sign up for free broadband connection quality graphing here Broadband Quality Monitor

It uses ping and records response times to measure latency and packet loss so you need to allow their server to communicate to your router via ICMP. Is there a way of configuring the WRT610N (v2) to allow only a specified IP address (or addresses) to get a ping response?

 

At the moment, the only way I could find was to disable SPI Firewall protection and Filter Anonymous Internet Requests which I would rather not do.

 

TIA,

Nick. 

yleclerc
Posts: 371
Registered: ‎05-23-2007

Re: Enabling ICMP for a specific IP address WRT610N

I believe you might need to check the Internet Filter section under the Security tab.  Uncheck the "Filter Anonymous Internet Requests" option.
nickweavers
Posts: 3
Registered: ‎10-15-2009

Re: Enabling ICMP for a specific IP address WRT610N

Hi yleclerc, yep, as I said, checking that option along with the unchecking of State Packet Inspection (SPI) is what I had to do. The question was, is there a more targeted way to do this. I don't want to drop my whole defence shield just to let one trusted machine (IP address)

through to do something I approve of and would like to sanction.

 

Thanks 

 

yleclerc
Posts: 371
Registered: ‎05-23-2007

Re: Enabling ICMP for a specific IP address WRT610N

It must be noted that most every home / soho routers are only NAT based "re-director" and not true firewall.  You should be running software firewall and anti-virus software.  ICMP is not re-directable via most "port-forwarding" settings.  You should only really need to set the  Filter Anonymous Internet Requests to off.