Posts: 18
Registered: ‎10-31-2007

GIFException in module aviWUSB54Gv4.dll @ 0002516B & memory could not be read

[ Edited ]
I suddenly started getting the error GIFException in module aviWUSB54GvV4.dll@0002516B today. At first I was still able to connect to the internet without any problems (the little Linksys icon was just missing from the toolbar). However, after checking here about the problem and seeing the posts at I tried that. Since I cannot connect my pc directly to the router I downloaded the drivers and installing only to have more problems and not being able to connect to the internet at all. I have finally been able to get connected (not sure exactly how) after uninstalling the linksys software and then reinstalling it (a few times) but I still keep getting the same message. I had to open up the folder in c:/program files and click on the icon in there that looks like the one that is usually on the toolbar and then kept trying to get connected to the internet. When I finally was able to get the connection came right back here to see if anyone has any suggestions. I'm only hoping that when I try to connect to the internet again tomorrow I will be able to do so to see what I should do.

Well when I turned on the pc this morning I am still getting the same error box popping up but I also noticed that there is also a box stating The instruction at "0x0044408d" referenced memory at "0x00000168". The memory could not be "read". Click OK to terminate the program. Click cancel to debug program. To be honest I'm not sure which I clicked on but the box with the application error was under it and popped up 4 more times.

I do have an internet connection but the little linksys icon is not in the toolbar.

How do I get rid of these errors???
Any Suggestions would be greatly appreciated. I'm just glad that I still have my connection but would like to fix these errors.

Message Edited by lmreif on 05-11-2008 07:58 AM

(Edited post for guideline compliance. Thanks!)

Message Edited by JOHNDOE_06 on 05-12-2008 12:50 PM
Posts: 3,650
Registered: ‎09-07-2006

Re: GIFException in module aviWUSB54Gv4.dll@0002516B & memory could not be read

Seems like your adapter installation has got corrupt. Use a good registry cleaner software to clean invalid registry values, and remove corrupt installations.
Posts: 18
Registered: ‎10-31-2007

Re: GIFException in module aviWUSB54Gv4.dll@0002516B & memory could not be read

Thanks for the suggestion. I'm not sure how my registry got corrupt and I haven't done anything new lately but I'm sure that is a possibility. I've never messed with the registry so I honestly don't have any ideas for a registry cleaner. Any suggestions? By the way .... for whatever reason when I turned the pc on this morning I was still having the same problem but after having turned it off and a then turning it back on a couple hours later it seems to be working fine now. I guess using a registry cleaner couldn't hurt anyway. Any suggestions? Thanks Again!