Reply
mmm_unit
Posts: 10
Registered: ‎08-27-2009
Accepted Solution

[PING SPIKE] issue SOLVED!!! (if you have ping spikes, this is probably the answer)

[ Edited ]

Hey all,

 

If you have a ping spike/temporarily stopped connection with your wireless adapter, this is probably the solution for you!

 

You can read about my story here from my previous thread about my problems and solutions I tried along the way.

http://forums.linksysbycisco.com/linksys/board/message?board.id=Wireless_Adapters&thread.id=22612

 

I have yet to hear back from the offical linksys support that promised they would contact me and did not find a solution here in the forums so I took matters a step further and did the research myself to fix this problem.

 

 

See my reply direcly below for the solution.
Message Edited by mmm_unit on 09-02-2009 05:18 PM
mmm_unit
Posts: 10
Registered: ‎08-27-2009

Re: [PING SPIKE] issue SOLVED!!! (if you have ping spikes, this is probably the answer)

[ Edited ]

So the problem lies mostly with people with linksys adapters and vista 64 (could also affect other OS's, but found a lot more 64 when researching).

 

 

1. If you have vista 64 bit drivers, first download the XP 64bit drivers from linksys for your adapter, then uninstall your current drivers completely by removing them (through device manager) and all linksys managers (through control panel > program features)

 

2. Reboot your computer.

 

3. Install the XP 64bit drivers through device manager > network card (should have an exclaimation mark next to it now) > driver update (then point to where the XP 64 driver is, MAKE SURE that there are NO OTHER DRIVERS IN THE SAME FOLDER!!!! so after you download the linksys files, DELETE ALL FILES BUT THE XP 64 bit ones.

 

4. connect to your wireless router, then go to start menu > type in cmd (open in admin mode) > type [netsh wlan set autoconfig enabled=no interface="Wireless Network Connection"] (without the brackets []), replace wireless network connection with whatever your network connection your computer is connecting to.  You can check which one you are connected to by going here.. Control Panels > Network and Sharing Center > Manage Network Connections

 

Now you should have no problems with your connection and any ping spikes, verify that this works by going to your command prompt and typing ping 192.168.1.1 -n 100

 

change the 192.168.1.1 to whatever your router addresss, at the end of the check, there shouldn't be any high spikes and everything works!

 

 

Here's the crappy part, everytime you start your computer again or lose connection with the wireless signal, you must re-enable the autoconfig in the cmd prompt, netsh wlan set autoconfig enabled=yes interface="wireless network connection"

 

And once you've connected to your router, you must disable this auto config connection again.

 

 

I am not sure how this will work on other OS's, but I assume it will be a similar solution (unless this issue is strickly caused by 64bit)

 

 

 

Now seeing as how my other wireless adapaters do not have this problem, I suspect this is a issue with linksys and their drivers for these affected products. It is an annoyance to do these things, but I guess that's the way things will work until linksys sees this post and hopefully fixes it with a new driver update :-D

 

 

Feel free to post your sucesses here! I will accept replies and kudos as a form of payment :-D

 

And if any moderator can sticky, I believe that this will help many people since I have noticed quite a few on these forums with this problem.

Message Edited by mmm_unit on 09-02-2009 05:19 PM
Neojonus
Posts: 1
Registered: ‎09-09-2009

Re: [PING SPIKE] issue SOLVED!!! (if you have ping spikes, this is probably the answer)

Sorry to bring up a dead thread, but I'm having a bit of an issue here. Everything goes good until the CMD input. By "Wireless Network Connection" as the end to your line, I'm sure you're talking about the SSID, right? 'Cause whenever I try using it, I get the message: "There is no such wireless interface in the system". At first I thought I misspelled, or didn't do something very simple in the line, but I've tried just about everything.

 

 

Anyone wanna help a guy out?

Schreder
Posts: 1
Registered: ‎09-14-2009

Re: [PING SPIKE] issue SOLVED!!! (if you have ping spikes, this is probably the answer)

SSID is the name of the wireless network, as set on the router, not the name of the network adapter.

As mmm_unit said: (emphasis mine)

4. connect to your wireless router, then go to start menu > type in cmd (open in admin mode) > type [netsh wlan set autoconfig enabled=no interface="Wireless Network Connection"] (without the brackets []), replace wireless network connection with whatever your network connection your computer is connecting to. You can check which one you are connected to by going here.. Control Panels > Network and Sharing Center > Manage Network Connections

Unless you have two wireless cards in your computer, it's likely called "Wireless Network Connection".

I'm guessing that the confusion came from the first part of step 4, "connect to your wireless router".  This means you need to connect to your wireless network, not log into your router's admin page.

Oh, and I was successful with this technique, although I did not need to replace my vista_64 drivers.  Thanks mmm_unit.

varissul
Posts: 1
Registered: ‎11-04-2009

Re: [PING SPIKE] issue SOLVED!!! (if you have ping spikes, this is probably the answer)

Okay, first off, I'm new to Vista and cannot seem to do this step by step even though it seems easy.

 

I've downloaded the drivers and placed them on my desktop but when I try to "update" the driver from the device manager, I cannot find them in the listing.

 

So, I tried the cmd prompt thing but then it tells me I do not have sufficient privilage or a group something-or-orther is in place.  **bleep** does that mean??  I'm the sole user of this computer and am connected to a wireless router with privilages. I don't understand why this isn't working for me.  Is there something I'm missing?

 

This ping is so annoying... It almost makes me want to toss this adapter in the garbage and by a different one altogether.

callipygous
Posts: 1
Registered: ‎01-05-2010

Re: [PING SPIKE] issue SOLVED!!! (if you have ping spikes, this is probably the answer)

I have done this. it seems to work short term, but the problem keeps coming back. i have tried redoing the netsh 'wlan set autoconfig enabled=no interface="Wireless Network Connection"'

part several times. (on and back off again)

 

havent found a consistant way to fix it.

Splatus
Posts: 1
Registered: ‎01-24-2010

Re: [PING SPIKE] issue SOLVED!!! (if you have ping spikes, this is probably the answer)

Thanks for the help.  I run XP Pro SP3 and all updates.  Upgraded to latest wpm600N driver (date 5/13/09) and I get ping spikes from (baseline) 2ms to 2986ms.  There is nothing else running on the computer. I used your line in cmd but to no avail.  

 

This is not enough to be noticed in regular  browsing but it is very noticable in gaming - in fact to a point where I install my old g card if I cant sort it out by tomorrow.  


Anyway, thanks for the help but it doesnt see to work for XP

koopatroopa
Posts: 1
Registered: ‎02-25-2010

Re: [PING SPIKE] issue SOLVED!!! (if you have ping spikes, this is probably the answer)

I just wanted to give my testimony to this problem and share how I fixed it. I'm running Vista 32 bit and I was getting ping spikes. I dove through a bunch of forums on this site and did a combination of things.

 

- First thing I did was update the driver. Download it right off the support page and install it in Device Manager.

 

- Then, in Device Manager, I opened Properties on the adapter, and enabled the following in the Advanced tab:

                Frame Aggregation

                Gaming/Multimedia Environment

 

 - I was still getting some studdering online, so I went into my router and changed a few settings. These settings are usually under Advanced Wireless Settings or something like that.

                Set Beacon Interval to 75

                Set Fragmentation Threshold to 2304

                Set RTS Threshold to 2304

 

After that, everything was crystal clear.

 

For those of you who might have trouble getting into your router, here's a few quick instructions. Note that you have to be connected to your router, either wirelessly or hardwired, for this to work.

 

- Open start menu and type in "cmd" and hit enter.

 

- On the command line prompt, type "ipconfig." Write down the Default Gateway.Should be something like 192.168.1.1  .

 

- Open a web browser (Firefox, Internet Explorer, ect.) and enter the gateway in the address bar and hit enter. You might be prompted for a user and password. The default user/password on most routers is admin/admin or admin and no password. If you're unsure, check the documentation for your router. 

 

- Now you just have to poke around until you find what you're looking for. Usually, wireless has its own tab and you have to find Advanced wireles settings in the tab.

 

Hope this helps.

mardisbagley
Posts: 1
Registered: ‎03-04-2010

Re: [PING SPIKE] issue SOLVED!!! (if you have ping spikes, this is probably the answer)

@koopatroops

Thank you Thank you Thank you!

 

I almost returned my WRT160N router because of lousy performance and very short wifi distance, then I saw your comments about ping spikes. I adjusted my wireless settings as you suggested (below) and everything is working great now. 

 

                Set Beacon Interval to 75

                Set Fragmentation Threshold to 2304

                Set RTS Threshold to 2304

 

It is beyond my why Linksys was not able to set the router to these standards at the factory, or from within the Setup Wizard when I installed the router utility. Seriously, the comments from a third party (namely you) has saved Linksys a considerable amount of money and customer service headaches. Thanks again Koopatroopa

 

Mardis

MacBook Pro os 10.6

Powerbook os 10.4

HP w/Windows  7-64bit

robbiemacg
Posts: 1
Registered: ‎05-05-2010

Re: [PING SPIKE] issue SOLVED!!! (if you have ping spikes, this is probably the answer)

I just set up an account for the sole purpose of sayign that I am truly grateful for the advice shared in this post.

 

THANKS!