Posts: 2
Registered: ‎10-20-2007

SOLUTION! USB wireless adapter "Can't find the Internet" problem with Windows XP SP2

Fixed the "Can't connect to the internet" problem:  I ran into the same "Can't find the Internet" problem with a new Linksys WUSB54GC Wireless-G USB adapter -- running XP Home SP2. 
We have a Linksys WRV200 wireless access point, and Comcast-supplied RCA cable modem.  The cable modem and access point are running fine; three of our other computers were connected.  I replaced an old USB wireless adapter on one desktop PC with a new Linksys WUSB54GC adapter.  After the drivers were installed, Windows could "see" the access point -- with good signal strength etc. -- but couldn't connect to the internet.  It apparently couldn't access the DHCP server on the router, and didn't retrieve an IP address.
I tried everthing, including the Linksys installation utility on the CD,  removing and replacing the drivers manually, manually changes TCP/IP, DHCP and DNS settings, etc. 
The solution suggested by Helm fixed this maddening problem: open a Command Prompt window and type:  netsh winsock reset catalog <enter>  Note:  it can take a few minutes for your computer to respond after you hit <enter>; don't close the Command Prompt window.
To open a Command Prompt window, click on the Windows "Start" button, then click on the Accessories folder.  The list of accessories will appear.  Click on "Command Prompt".  A small window will appear with a flashing cursor.  Type the commands shown above. 
Linksys should definitely add this to the FAQ list, to save users hours of frustration!
Mark Hays