Posts: 1
Registered: ‎06-05-2007

WMP54G and 4.1 driver not working on Vista

I installed the WMP54Gv4 wireless adapter from my previous Win'Xp machine in a new Acer running VISTA.  After installing the 4.1 driver (netr61.sys) I get a message saying Windows can see the adapter but could not load the driver.  "Update Driver" results in "best driver loaded".  Error code is 31.
I tried another WMP54Gv4 from another XP computer, working fine there.  Uninstalled all drivers, reinstalled first v.4 with its setup utility, then v.4.1 driver.  Same error.  Network runs on a WRT54Gv.2.2 router.  Working well with 2 XP machines.  No networks detected by Vista machine.
 What should I try next?
Posts: 3,376
Registered: ‎09-07-2006

Re: WMP54G and 4.1 driver not working on Vista

I don’t think you can load version 4.1 drivers for Vista on WMP54Gv4 adapter, you need to have WMP54Gv4.1 adapter to get in work with Vista…WMP54Gv4 would now work win Vista, however there are no vista compatible drivers are available for WMP54Gv4.

Posts: 1
Registered: ‎06-07-2007

Re: WMP54G and 4.1 driver not working on Vista

Windows update driver over the network can find one
version 12/11/2006

Linksys site has one

This work somewhat with 4.1 version.

Mine continually gives an interrupt request error and blue screen
when it wakes up after going into power save mode, but otherwise
it works fine.

Note that update driver in the control panel will say that you have the
best driver, no matter what it is. you have to remove the old one
to install an updated one.

jack f

PS Would appreciate any comments on the IRQ problem
there are no indications of an IRQ problem looking under device