Posts: 3
Registered: ‎06-18-2009
Accepted Solution

[WUSB11] + WRG45E + WRT54GS working in harmony todether

[ Edited ]

 After a few days of trial and error and playing around with the settings on my router and expander, I finally got my wireless g range expander to work with my router and set up a proper network key


I have a laptop that can connect to this wireless signal flawlessly through its built in card after entering the password.  I am trying to use this usb connected to connect a desktop wirelessly to my network


However, before i could use my wusb11 to connect to the network with ease, but now it seems to be  "broken"


When i try to connect using "automatically find ip / nameserver settings" the network comes up as found, connects briefly, then pauses at aquiring network adress, before disconnecting moments later


I figured i have to automatically assign this an ip, when doing so (say, assigning it it holds the connection yet i have no connectivity to the internet.


I remember when setting up my wireless g range expander i had to assing it it's own ip through the main router page ( and now im thinking I have to do that and enter those settings on my usb reciever's TCP/IP settings to get it to work


Can sombody guide me through this process? Thanks in advanced 

Posts: 3,012
Registered: ‎09-07-2006

Re: [WUSB11] + WRG45E + WRT54GS working in harmony todether

If you have a WinXP Computer then un-install and re-install the adapter drivers...


Remove the Linksys Adapter and un-install the Linksys Software from Programs menu...To re-install the Drivers insert the Linksys Adapter Setup CD into your CD-ROM drive, When the Welcome screen appears click Exit, connect your USB adapter now...When the  Hardware Update Wizard window appears, click Install the software automatically (Recommended) then click Next.

NOTE: The Hardware Installation screen may appear indicating that the Adapter has not passed Windows Logo testing. Ignore the window and click Continue Anyway to proceed with the installation since the Adapter has been tested and found to work with Windows XP.When Windows has finished installing the driver, click Finish.

Click on Start and goto Control Panel and double click on Network Connections...Right click on Wireless Network Connection and select View Available Wireless Networks"- If you see your wireless network in the list, highlight it by 'single' clicking on it- Now click on the 'Connect' button below- As your wireless network is secured, it would ask you to provide the network key- Provide the wireless network key and confirm it again in the confirmation box and click "Connect".It should work...

Posts: 3
Registered: ‎06-18-2009

Re: [WUSB11] + WRG45E + WRT54GS working in harmony todether

Thanks for the post, this looks suspiciously similar to something I read in linksys own support pages.


However my problem is not a basic one, like I said that Used to work but ever since i starting using the range expander stand alone the usb device has not worked.


Even after completeing the outlined steps above my problem is still the same, everything installs fine and it finds the network, the problem is that it connects and displays a message ( i have taken  a screenshot so you can see it )


it displays this message for a few seconds, then dissappears and disconncts from the network.


Now, i have tried manually editing the tcp/ip settings (connection properties -> tcp ip -> properties) and changing the setting from obtain ip automatically to manually.  I use for the adress, the subnet fills in automatically, and (ip adress) for default gateway.  For the dns server i manually put in the two dns servers i get from /ipconfig all.


Now when i do this I am able to connect to a network and hold the connection, about 7 or 9 packets are sent and recieved and then it remains connected but I cannot connect to the internet.


This problem is not unqique to the computer, I am having this problem on two pcs, both running windows xp and they both share exactly the same symptoms.


Thanks for your time!

Posts: 1,275
Registered: ‎02-02-2008

Re: [WUSB11] + WRG45E + WRT54GS working in harmony todether

You have a conflict between your wireless and your wired connection.  You need to disable your local area connection.  The Icon showing two computers with a red X means that you wired connection is disconnected and running.  You have to enter your network connections in your computer and disable your wired connection.
Greetings from Northern Ontario, Canada
Posts: 113
Registered: ‎05-28-2009

Re: [WUSB11] + WRG45E + WRT54GS working in harmony todether

Hi pmal19,


What is the Security Mode you're using on the range expander and router?
If you're using WPA, the WUSB11 device cannot work with it actually.

So, if this is the case, better use WEP since this is the only Security mode that a WUSB11 can support.


Woman Wink

Posts: 3
Registered: ‎06-18-2009

Re: [WUSB11] + WRG45E + WRT54GS working in harmony todether

Success! I guess sometimes you overlook the most basic of details, changing the security settings on my expander through its login and then changing them on the router to match resulted in a connection that I am using to post this message with.



Posts: 1
Registered: ‎12-02-2011

Re: [WUSB11] + WRG45E + WRT54GS working in harmony todether