Showing results for 
Search instead for 
Do you mean 
Reply
sublightnova
Posts: 4
Registered: ‎02-14-2008

WUSB300N vista 64-bit drivers

This week becuase of a bricked WRT54G I purchased a WRT150N router and a WUSB300N. I've been unable to get the WUSB300N adapter to connect to my network. Mainly because I am unable to locate drivers for this product. Can anyone point me to a a linksys download link where I can download the correct 64-bit drivers? I've heard rumors about a driver not existing. This is unacceptable and I will return both router + adapter immidiately if that is true. I would like an official linksys rep to comment on this or do they not care at all?
sublightnova
Posts: 4
Registered: ‎02-14-2008

Re: WUSB300N vista 64-bit drivers

????????????????
Eckoforce_1
Posts: 1
Registered: ‎02-21-2008

Re: WUSB300N vista 64-bit drivers

Still waiting here........Good thing I got the 64 bit version of Vista and cant even use it. Had to downgrade to 32 bit. Everything else works good 64 bit but no internet no point.
JetLi
Posts: 3
Registered: ‎05-13-2007

Re: WUSB300N vista 64-bit drivers

[ Edited ]
Hi

there is a driver for this.

http://catalog.update.microsoft.com/v7/site/Search.aspx?q=Linksys

http://catalog.update.microsoft.com/v7/site/ScopedViewInline.aspx?updateid=580d9d4e-9957-44aa-950a-11ea07aab462

I got Windows Vista 64bit next week, so I cannot test it now.

Message Edited by JetLi on 02-24-2008 02:16 AM
ispy
Posts: 3
Registered: ‎11-10-2008

Re: WUSB300N vista 64-bit drivers

Hi.

 

I did what you said, and downloaded that specific thing. When I click on that icon that shows the metal file cabinet, it shows 4 things, and i have no idea what to click on. Mabye someone can help?

KILLER_K
Posts: 10
Registered: ‎04-11-2008

Re: WUSB300N vista 64-bit drivers

I always used the windows update driver on mine and it worked great for me. Generic drive but worked 100% and never had issues with it.

 

Good Day

mikstarz
Posts: 1
Registered: ‎11-23-2008

Re: WUSB300N vista 64-bit drivers

[ Edited ]

Ok folks - figured it out. Vista 64 with WUSB300N works ---- but you have to be connected to the internet first before you plug in the WUSB300n. Once you plug in it will fetch the drivers from Msoft and load up. Once this is done disconnect the old connection and - your WUSB300N will be active.

 

 

Good luck.

 

Mike

 

 

 

 

(Mod note: Edited post for guideline compliance. Thanks!)

 

Message Edited by JOHNDOE_06 on 11-30-2008 07:56 AM