Posts: 4
Registered: ‎02-15-2010

WUSB600N crashed Windows 7

[ Edited ]

I completed my new PC with i7-870 Quad-core, 16GB RAM, and Windows 7 64-bit Ultimate on 2/13/2010.  My WUSB600N wroked fine with Windows XP 32-bit but it prevented my new PC from RESTART, SHUTTING DOWN, or STARTING WINDOWS.  What I had to do was to mannually turn off the PC.  Then, removed the adapter before turn on the PC again but the PC either goes to the START NORMALLY mode or the REPAIR (RESTORE) mode.  I used the Driver SW dated 01/26/2010 Ver. from the Linksys site.


I contacted the Linksys Chat Line on 2/14/2010 but they referred my case to the Linksys WIndows 7 department.  Does anyone experience the same problem or know why my PC crashed with WUSB600N plugged in?

Posts: 24
Registered: ‎02-14-2010

Re: WUSB600N crashed Windows 7

Greeting Gvtran. 


I do not have this particular problem however I do know that sometimes my i7 quad use to take up to 5 minutes (or longer) to shut down after clicking the shutdown or restart button. 


One thing you may want to do is check your motherboard's support page to see if there is a new BIOS (as result of the Windows7 release).  If you find that your device manager is reporting Unknown Devices, Windows7 will continue to try to find new device drivers for the unknown device during the shutdown process.  I had that problem when I upgraded to Win7 with my internal card reader and temporarily solved the problem by disabling the unknown device.  I later found that Gateway had released a new BIOS flash in January and after the flash the card reader was identified as a valid device and I reenabled them.  My system shuts down and starts normally with the WUSB600N in the cradle.


If you do a manual shut down by keeping the power button pressed, Windows does not finish its shut down routine, this will create a bootstrap for the next boot making Windows think there is a problem.  The bootstrap will generate the option to start in safe mode/restore or normally on your next restart.  This is not the USB Adapters fault, it's your's for forcing the shutdown.


I just got my WUSB600n working yesterday (it would not enable but I don't think this is your problem right now), I have applied all Microsoft KB Updates available and my i7 quad is operating fine, (I'm not sure how you can trace the shutdown problem back to the USB adapter)


I would be glad to assist if I could but maybe this might help.  Believe it or not, my problem with the WUSB600N was caused by my Anti-Virus program.





PteJack Is a Windows7 Guinea Pig
Posts: 3,650
Registered: ‎09-07-2006

Re: WUSB600N crashed Windows 7

I agree with PteJack and all the suggestion given by him..Try using the different USB slot and check..also try this link.
Posts: 4
Registered: ‎02-15-2010

Re: WUSB600N crashed Windows 7

First of all, many thanks to PteJack and Helm for your advice and tips.  PteJack is right on the money that the original BIOS of the ASUS M/B prevented the PC with plug-in WUSB600N from Shutting Down or Starting Up.  However, Windows 7 does not accept the latest WUSB600N driver sw for Windows 7 from Linksys.  Instead, it automatically installed the Ralink driver sw dated 5/25/2009 Ver.


The good thing is the WUSB600N is up and running  beautifully for me.  Again, thank you so much and another good thing is Linksys created the forum so people can get help from each other as needed and learn more about the products.

Posts: 24
Registered: ‎02-14-2010

Re: WUSB600N crashed Windows 7

WOOHOO!!!!!! That's win number 2 for me in less than 24 hours, I should join the Linksys Helpdesk team!!!  (not!!)


Now gvtran, here is the tricky part if you want to load the Linksys Drivers.


STEP #1 Get the latest driver from Linksys and save it to your computer!!


STEP #2 If you did not download and save the drivers from Linksys go back to Step #1 and repeat


Extract the Zip file to your Computer where you can find it later  


Right Click on Computer and select Manage.


Open Device Manager


Find the Network Adapters and expand it by clicking on the little triangle


Locate the name that the RALink drivers assigned to your Adapter


Right click the adpter name




In the OK box there will be a check box "Delete the Driver Software for this device"


If you haven't downloaded and extracted the Linksys Drivers select Cancel and GO BACK TO STEP 1 NOW!!!


Make sure you check the box ON (checked) when you click OK this will destroy your connection and delete the RALink drivers.


Now, the device may float down to the Other Devices location in the Device Manager and be identify as a Wireless WAN USB 2.0 device or it may call itself the WUSB600N V2 Network Adapter (I'm not at a computer that has my USB Network Adapter in it right now) but you'll know it when you see it.


(If you haven't downloaded the Newest Linksys driver file as told to in Step #1 - YOU'RE TOO LATE NOW, dig out the Cat5 and hardwire a connection to the router and go get the driver file.) 


Right click on it an select Update Driver Software


Select "Browse My Computer for Software"


Click Browse and point to the Win7_64_v3.0.10.0 folder in the WUSB600Nv2-Win7_3.0.10.0-01182010 folder the you created when you extracted the Linksys Driver File that you Downloaded in Step  #1


Click OK


The system will find the drivers and load them


Reconnect your network and your in... 


(Note - If you run Kaspersky Anti-Virus you will want to turn off the Kaspersky Anti-virus NDIS 6 Filter Protocol in the Property of your Network adapter. You will only have to worry about this IF the Windows7 Drivers load and the device manager reports it is working properly But when you go to set up the network  you find that you cannot enable the connection in Network and Settings Center - Change Adapter Settings function)


Seeing as you already have a connect, I don't think you'll have to worry about that one.


Seem like a lot of work, but you can do this in less than 2 minutes including the 35 second driver download and extraction (once you get the hang of it) 


Remember, the only way to learn and master the inner workings of a computer is to experiment.  That's why God created Support Centers. If it breaks in during a warranty period, they got to help you fix it..... lol


Good luck




(If it ain't broke now and your running Windows7.... You lucky because it will be!!!!!)

It will be easier than Vista,  Trust Me!!!!! 

PteJack Is a Windows7 Guinea Pig
Posts: 4
Registered: ‎02-15-2010

Re: WUSB600N crashed Windows 7

Thank you very much for the precise tips, PteJack.  This is what happened to the Windows 7 Ultimate 64-bit on my PC:


1) I downloaded the latest WUSB600N driver sw for Windows 7 from Linksys.  I unzipped it and saved it to the Desktop.  The unzipped folder has 2 sub-folders: 1 for 32-bit and another is for 64-bit.

2) I went to the Network Adapter tab under the Device Manager to uninstall the Ralink driver sw.  As soon as the driver sw was successfully uninstalled, the text for the Linksys WUSB600N disappeared from the Network Adapter tab.

3) After I rebooted the PC, I went back to the Network Adapter tab and I saw an icon for Linksys WUSB600N with a yellow EXCLAMATION mark on it.  Then, I double-clicked on it in order I can install the Linksys driver sw (64-bit folder) which I saved on the Desktop but the process got denied from the Windows 7.

4) Finally, I put the Linksys driver sw on a thumb drive (flash drive) and repeated the Step 3), the WUSB600N was successfully programmed with the new Linksys driver sw.


My PC is up and running on line since then.

Posts: 24
Registered: ‎02-14-2010

Re: WUSB600N crashed Windows 7

Sounds like you have the drivers installed ok,  If you want to be sure go to the Device manager and find the device. Right Click on it and select properties. Click on the Driver Tab


It should say:


Driver Provider: Linksys, a Aivision of Cisco Systems,Inc  (Gawd I love people that don't use a spell check on thier released product Mine actually says "Aivision" instead of "Division", sheesh!!!)


Driver Date: 1/18/2010


Driver Version:


Digital Signer: Microsoft Windows Hardware Compatibility Publisher


If you Click Driver Detail, you'll find the Provider is RALink Technologies Corp, File Version is Built by WinDDK

Copyright is Copyright (C)  @ 2002-2009 RALink Technology


Driver Files should be netr28ux.sys and vwifibus.sys


Glad to hear you've got everything loaded and everything is working fine. 


I thought I had really screwed up (I pointed the flash to files on the C drive instead of the CD/Rom) when I flashed my BIOS, but everything worked out for me. 


If the drivers are not as listed above, go back to my other post and follow the steps. 


Do not doulble click on the device to load the drivers, that only sends the driver search out to find the first ones it comes across which are usually the ones that came packaged with windows (which have a tendency to be very very old, but most times work.)  Sometimes when the old drivers are loaded, Windows Update will find newer ones in it search for updates and will grab and update them for you, but again these are sometimes 1 or 2 versions behind. 


Safe Computing and Good Luck in 2010




PteJack Is a Windows7 Guinea Pig
Posts: 4
Registered: ‎02-15-2010

Re: WUSB600N crashed Windows 7

Hi PteJack,


I double-checked the description of the installed driver sw for WUSB600N on my PC and its descriptions match perectly with your descriptions.  I also got my Linksys router WRT160NL fixed up today.  Now, I am happy like a clam.  Thank you so much.



Posts: 1
Registered: ‎03-23-2010

Re: WUSB600N crashed Windows 7

Hi guys, kinda the same issue... I DL newest driver extracted it from linksys/cicso, but when i direct it to the folder it says it found the driver but ran into an issue... access denied. (lawnmower man moment) this is on a 7 Ultimate 64-bit ne ideas?
Posts: 24
Registered: ‎02-14-2010

Re: WUSB600N crashed Windows 7

Hi nadam,


I don't mean for this to sound like you don't know what you are doing, but an "ACCESS DENIED" error usually means that you don't have administrator access.  You might want to check that out first.


Sometimes Win7 can be a bug-ger that way and not think you are an administrator and denies access even though you are logged into an administrator ID. Some anti-virus and Firewall stuff does the same.



PteJack Is a Windows7 Guinea Pig