Reply
OHS
Posts: 1
Registered: ‎07-12-2009

WUSB600N does not detect the 5GHz band on my WRT610N router

I removed the Linksys utility and am using the Windows Wireless Configuration to try to connect to my router.

 

I get the 2.4GHz band without a problem, but I don't even see the 5GHz band.  I've tried restarting my router to no avail.  It has had an issue in the past where it lost wireless connectivity, but when that happened, it was both bands that were unavailable.

 

WHen I had the Linksys software installed, both bands were available.

 

Is there a limitation to the Windows configuration utility that prevents it from seeing the 5GHz band?

 

Any help would be greatly appreciated.

Posts: 371
Registered: ‎05-23-2007

Re: WUSB600N does not detect the 5GHz band on my WRT610N router

The WZC system has no limitation for the 5.0Ghz radio

 

BTW:  How did you remove the Linksys utility?

 

You may need to:

 

Check all anti-virus / firewall software on this PC.  Some will block some wireless network names (aka SSID)

 

Check your WRT610N router.  If you set up manually the two wireless networks, then they can not have the same name.  If you use the WPS (Wireless Protected Security??)  then it seems to be automatic.

Posts: 75
Registered: ‎11-09-2008

Re: WUSB600N does not detect the 5GHz band on my WRT610N router

Really?!?

 

My WRT610N router has both bands as the same name and it's working great!!  In fact I'm hitting 300Mbit if my laptop is in the same room as the router.  It will drop to 270 or 243Mbit if it has to go through a few walls to get to me.

Posts: 2,544
Registered: ‎09-07-2006

Re: WUSB600N does not detect the 5GHz band on my WRT610N router

Try to adjust the wireless setting for 5 GHz on your Router...

 

For Wireless Settings, please do the following : -
Click on the Wireless tab
- Here select manual configuration...Wireless Network mode should be mixed...
- Provide a unique name in the Wireless Network Name (SSID) box in order to differentiate your network from your neighbours network...

- Set the Radio Band to Wide-40MHz and change the Wide channel to 9 and Standard Channel to 11-2.462GHz...Wireless SSID broadcast should be Enabled and then click on save settings...
Please make a note of Wireless Network Name (SSID) as this is the Network Identifier...
For Wireless Security : -
Click on the Sub tab under Wireless > Wireless Security...
Change the Wireless security mode to WPA, For Encryption, select AES...For Passphrase input your desired WPA Key. For example , MySecretKey , This will serve as your network key whenever you connect to your wireless network. Do NOT give this key to anyone.

NOTE : Passphrase should be more that 8 characters...

Click on Advanced Wireless Settings
Change the Beacon Interval to 75 >>Change the Fragmentation Threshold to 2304 Change the RTS Threshold to 2307 >>Click on "Save Settings"...


Now see if you can locate your Wireless Network and attempt to connect...
 

Note : Turned off the firewall and antivirus on your computer..

Posts: 371
Registered: ‎05-23-2007

Re: WUSB600N does not detect the 5GHz band on my WRT610N router


JustCurious wrote:

Really?!?

 

My WRT610N router has both bands as the same name and it's working great!!  In fact I'm hitting 300Mbit if my laptop is in the same room as the router.  It will drop to 270 or 243Mbit if it has to go through a few walls to get to me.


 

I set one up for a client in June.  It "never" would allow the same SSID on the two bands manually but somehow the WPS did do ot.  Not certain "what" happened.
Posts: 371
Registered: ‎05-23-2007

Re: WUSB600N does not detect the 5GHz band on my WRT610N router

Would the 2.4Ghz radio "wireless" network name (SSID) "over-power" the 5.0Ghz?  Since both have the same name and the 2.4Ghz radio has tge greater "range" then the adapter could constantly be detecting the 2.4Ghz.

 

As a test, rename the 5.0Ghz wireless network.

Posts: 75
Registered: ‎11-09-2008

Re: WUSB600N does not detect the 5GHz band on my WRT610N router

[ Edited ]

Hi Yleclerc,

 

That's actually a very good question for which I do not have an answer.  Right now my WRT610N router has both bands labled the same thing.  I'm also using the newer WUSB600 Ver 2 adapter.  The new Cisco monitor application will only show one entry for both bands and does not state if it's 2.4Ghz or 5Ghz.  If I name one of the bands differently, then Cisco monitor will show the two different names.  However, that does not verify if the 5Ghz band overrides the 2.4Ghs band.

 

What I can tell you is that my current setup works very well. The new software with the Ver 2 adapter is more stable than the Ver 1 stuff.

Message Edited by JustCurious on 08-07-2009 10:01 AM
Highlighted
Posts: 8
Registered: ‎08-11-2009

Re: WUSB600N does not detect the 5GHz band on my WRT610N router

Hi there. I may have an answer to some of your problems.... (hopefully). 

I am running Ubuntu 9.1 64-bit and Win 7 32-bit dual boot (amongst others). Like other people, I have found that Linksys is almost useless when it comes to providing help and drivers for their own products. Linksys has apparently provided Microsoft with a driver for the WUSB600N which is included in the O.S. install, and which is available via the MS 'update' facility. The driver does not appear to be available for regular download though from their website. There was a version 3.0-something driver which Linksys has withdrawn (links do not work anymore).

Nevertheless, I had to dig around on the interwebs and I discovered a variety of advice, some of which has actually enabled me to connect properly on a 5GHz network using my WUSB600N for both systems. I am a University researcher, experimenting with different operating systems, different wireless configurations, and throughput measurements. For the most part, we are limited by what the adapter manufacturer (Linksys) and the operating system writer (Microsoft) will allow us to do (especially Microsnot), but there are a few things that we can tweak and change. It shouldn't be too hard to do, and I managed it.

 

Ok, this is how to do it in Windoze 7 (32 and 64 bit) (or at least what I found I had to do):

(Ed: actually this first bit is universal for any OS) There are a number of things which the adapter is doing to try to connect for you, one of which is trying to determine which country or region you are in, and then using the appropriate 5GHz channels which it THINKS you are using. So we have to play around a bit with region settings for both the adapter and router to get them the same.

In Windows you can view and change these (otherwise) automatic settings by going here: "Network sharing centre", "change adapter settings", right-click on the WUSB600N adapter line and select "properties" (Windows will not necessarily call the adapter by it's name, but label it something like 'Wireless Connection 1', or similar).

First of all, ensure that Windows is using the correct driver. There are two versions of the device, and it is possible that Windows is not using the correct driver.

 

Select "Configure" in the pop-up dialog box, then the"Driver" tab. Select "Update Driver" and do the "Search automatically..." thing. As long as you are online, it may find an updated driver for the WUSB600N. 

Now that you have the latest from the interweb (or not),  get to almost the same place again as above, but this time select "Browse my computer..." instead of "Search automatically...". Select "Let me pick from a list...". The next view should have TWO drivers in the window. Both seem similar, but the one we want to select should be the "Linksys WUSB600N Wireless-N USB Network Adapter with Dual-Band ver. 2" one.

 

Now go back through  "Network sharing centre", "change adapter settings", right-click on the WUSB600N adapter line again and select "properties", then "Configure" in the pop-up dialog box. Now select the "Advanced" tab in the new dialog box. The dialog box here is simply reflecting values given to it by the driver .inf file.

Under "Property" you should see "Country Region (5GHz)". Highlight it, and the "Value" drop-down box should now have a series of numbers that you can select. These are the channels allocated internationally to regions around the world. You can find out to which countries these correspond elsewhere, however you can play around with various values here (and you cannot 'kill' your device by doing so :-) ).

I would suggest that you ensure that your adapter can 'see' and transmit on a wide selection, especially in the low numbers. I selected the one labelled "#0 (36 - 64, 149 - 165)". Click on "OK" to save any changed values.

 

Now for the router...

I do not have a WRT610N router, but an Apple Airport Extreme. We are also using an enterprise level Cisco access point, but that doesn't affect this. Of course I already know they have different configuration methods, however they all conform to the 802.11n spec. For the Airport Extreme, one has to run the Apple proprietary Airport Utility connection program. In there, click "Manual setup", Wireless" tab, then set "Radio Channel Selection" to "Manual". Now, you can click "Edit" for the channels. I have set the 2.4GHz to "1", and the 5GHz to "36" (the lowest 5GHz channel available). Using channel detection gear, I found that it had previously automatically selected a channel somewhere around 149. This was simply not 'visible' to the WUSB600N even though it had all the correct drivers. Click the "Wireless Options" button and tick the "5 GHz Network Name" box. Now edit the name so that it is unique and recognisable, e.g.:"5GHz Network", click "OK" to save the name change.

You will surely find somewhere in the WRT610N setup pages a place to simiarly manually set the channel. Set it to 36, give it a unique name (if possible) and save it. On the Airport Extreme, one clicks "Update" to save.

 

Now the adapter should 'see' the 5GHz connection.

I found that by default (and for some unknown reason) it was not able to 'see' channels which were in the high numbers. But it should now be able to connect with the correct security password to your router and network as normal.

 

I had to do some simlar, but different things for Ubuntu, but I don't think that affects you., so I won't go into details here.

 

I am available for contact by email if you really need: rto27 at student dot canterbury dot ac dot nz. I am trying to help, so please don't send me spam.

Hope all this helps.

Cheers

Posts: 1
Registered: ‎01-19-2010

Re: WUSB600N does not detect the 5GHz band on my WRT610N router

Thanks so much ReginaldPerrin.  I have the WRT610N v1 with Firmware 1.00.03 B15.  After reading your post, here is what I did so that my Windows XP computer using Windows wireless configuration (and the WUSB600N v1) detects the 5GHz signal:

 

I changed the wireless settings on the 5GHz radio of the WRT610N as follows:

Network Mode = Wireless N Only

Channel Width = 40 MHz only

Wide Channel = 38

Standard Channel = 36 - 5.180 Ghz

 

Previously by default, Channel Width, Wide Channel and Standard Channel were set to Auto (which meant that the Channel that was being used was in the 140s (I can't now remember which one).  So the key change seems to be a low channel vs. a high channel.

 

P.S.  When I went into the Device Manager of Windows XP and looked at the WUSB600N's adapter settings, I didn't even see the ability to adjust the channel range values for "n" (I believe it only had "b" and "g" adjustments -- but I may be a bit foggy on my memory).

 

 

Posts: 371
Registered: ‎05-23-2007

Re: WUSB600N does not detect the 5GHz band on my WRT610N router

For Windows 7, it seems that Linksys did not provide the WUSB600N drivers.  I tried my WUSB600N Ver.2 and it got the Ralink RT2870 drivers instead.