Posts: 1
Registered: ‎07-29-2007

Can't connect to WRT54G after firmware update

I just tried to update the firmware on my WRT54G (version 8.0) and have not been able to connect to the router since then. The firmware said that it had been updated successfully, however I have been unable to connect since it reset itself, and the Ethernet and Internet LEDs are all constantly on even though nothing is connected (the power light on the other hand is behaving normally, not blinking or anything). I have tried resetting the router by holding down the reset button for 30 seconds, but this does not change anything, the router still cannot even be pinged. If anyone can give me any help at all with this, it will be very much appriciated. Thanks.
Posts: 6,365
Registered: ‎09-16-2006

Re: Can't connect to WRT54G after firmware update

It sounds like the router might already be dead.  But there is always hope that you might be able to revive it.
You need to try again to reset the router to factory defaults.

To reset your router to factory defaults, use the following procedure:

1) Power down all computers, the router, and the modem, and unplug them from the wall.
2) Disconnect all wires from the router.
3) Power up the router and allow it to fully boot (1-2 minutes).
4) Press and hold the reset button for 30 seconds, then release it, then let the router reset and reboot (2-3 minutes).
5) Power down the router.
6) Connect one computer by wire to port 1 on the router (NOT to the internet port).
7) Power up the router and allow it to fully boot (1-2 minutes).
8) Power up the computer (if the computer has a wireless card, make sure it is off).
9) Try to ping the router. To do this, click the "Start" button > All Programs > Accessories > Command Prompt. A black DOS box will appear. Enter the following: "ping" (no quotes), and hit the Enter key. You will see 3 or 4 lines that start either with "Reply from ... " or "Request timed out." If you see "Reply from ...", your computer has found your router.
10) Open your browser and point it to This will take you to your router's login page. Leave the user name blank, and in the password field, enter "admin" (with no quotes). This will take you to your router setup page. Note the version number of your firmware (usually listed near upper right corner of screen). Exit your browser.

If you get this far without problems, try the setup disk (or setup the router manually, if you prefer), and see if you can get your router setup and working.

If you cannot get "Reply from ..." in step 9 above, your router is dead.

If you get a reply in step 9, but cannot complete step 10, then either your router is dead or the firmware is corrupt. In this case, use the Linksys tftp.exe program to try to reload your router with the latest firmware. After reloading the firmware, repeat the above procedure starting with step 1.

If you need additional help, please state your ISP, the make and model of your modem, your router's firmware version, and the results of steps 9 and 10. Also, if you get any error messages, copy them exactly and report back.

Please let me know how things turn out for you.