Posts: 1
Registered: ‎07-04-2007

Can't reset password on WRT54G

I have changed the router username/password in the past and either I can't remember it or its not accepting what I am entering, because the router logon will not go through. I have unplugged the router for 5 mins and then let it come back on and still cant get in, pressed the reset button down and let it come back up still nothing, and I have unplugged the cable modem and router for five mins and then plugged them both back up and I still can't get the router to reset to the default admin password. In the past it has worked before but now nothing I try will let me into the router interface to set up anything.
Posts: 6,365
Registered: ‎09-16-2006

Re: Can't reset password on WRT54G

You need to try again to reset the router to factory defaults.

To reset your router to factory defaults, use the following procedure:

1) Power down all computers, the router, and the modem, and unplug them from the wall.
2) Disconnect all wires from the router.
3) Power up the router and allow it to fully boot (1-2 minutes).
4) Press and hold the reset button for 30 seconds, then release it, then let the router reset and reboot (2-3 minutes).
5) Power down the router.
6) Connect one computer by wire to port 1 on the router (NOT to the internet port).
7) Power up the router and allow it to fully boot (1-2 minutes).
8) Power up the computer (if the computer has a wireless card, make sure it is off).
9) Try to ping the router. To do this, click the "Start" button > All Programs > Accessories > Command Prompt. A black DOS box will appear. Enter the following: "ping" (no quotes), and hit the Enter key. You will see 3 or 4 lines that start either with "Reply from ... " or "Request timed out." If you see "Reply from ...", your computer has found your router.
10) Open your browser and point it to This will take you to your router's login page. Leave the user name blank, and in the password field, enter "admin" (with no quotes). This will take you to your router setup page. Note the version number of your firmware (usually listed near upper right corner of screen). Exit your browser.

If you get this far without problems, try the setup disk (or setup the router manually, if you prefer), and see if you can get your router setup and working.

If you cannot get "Reply from ..." in step 9 above, your router is dead.

If you get a reply in step 9, but cannot complete step 10, then either your router is dead or the firmware is corrupt. In this case, use the Linksys tftp.exe program to try to reload your router with the latest firmware. After reloading the firmware, repeat the above procedure starting with step 1.

If you need additional help, please state your ISP, the make and model of your modem, your router's firmware version, and the results of steps 9 and 10. Also, if you get any error messages, copy them exactly and report back.

Please let me know how things turn out for you.
Posts: 1
Registered: ‎04-24-2008

Re: Can't reset password on WRT54G

I have reset the router, and the "admin" password (with empty user name field) is not doing the trick, for some reason. I have powered up and down the router according to the instructions several times, but no cigar. I also forgot my username/password, and now I can't use my router. Smiley Sad Any help would be really appreciated!
Posts: 51
Registered: ‎04-23-2008

Re: Can't reset password on WRT54G

- try clearing cookies, cache, saved pw , browsing history, etc... under : tools - internet options ( of your browser )
- hold reset button while powered on for 30 sec
- keep holding rset button for another 30 sec with power off
- keep holding it down for another 30 sec. with power back on
- wait 1-2 mins
- unplug power , wait 2-3 mins
- plug it back in
- try logging in
- also try usename:admin pw:admin
► by the way make sure power light blinks when you hold the reset button
" I can do all things through Christ which strengthens me. "
Posts: 77
Registered: ‎05-15-2012

Re: Can't reset password on WRT54G

[ Edited ]

There is no shortcut to recover old password of your router instead of restting.


So reset your router and configure a new setting for this, and don't forget to save your login and password this time.




Ask your any Cicso-Linksys question, I am always available on this Cisco Community for help


Mod Note: Link to 3rd party support removed.

Posts: 1
Registered: ‎06-25-2015

Re: Can't reset password on WRT54G

cannot default wrt54g password
Posts: 1,120
Registered: ‎10-26-2013

Re: Can't reset password on WRT54G

Hi robert59linksys. Have you referred to the previous answers in this post? Have you tried doing those steps? By the way,  are you referring to the password to the wireless network or the password to the setup page? If it's the password to the wireless network, you can change that on the Wireless Security sub-tab and you'll see that by accessing the page. Once in, click on the Wireless tab to see the said sub-tab. 


If you are referring to the password to the router's setup page, you can change that on the Administration tab on the setup page. Just type your preferred password on the field.


Now, if you are unable to change any of those two as the router does not accept the change, you may try rebooting the router. If it still does not accept, you may have to reset the unit and start again. To do the proper reset, please press down the reset button at the back of the router for 30 seconds while the device is powered on. Release the button and unplug the unit. Reinstall from scratch.


Hope the above helps.





Posts: 1
Registered: ‎08-18-2017

Re: Can't reset password on WRT54G

hi, hope you're well..

i am having the same problem as in i can not log in to to edit any of my settings at all.

I would like to change my password, & i have done it before although i needed to change it again after sharing it with someone. (thanks for any "don't share it again comments" i'd like to focus on the problem i'm having as opposed to fault. Thanks.)

So before i coud not log in to change ity either, even with my username & password... so i decided to reset the router, which anyone can connect now without a password. The site ( still will not let me log in with default pssword. I'vde tried: "admin/admin" ,"username / password","username / admin", "blank / admin", "blank / password" "1234", "0000" etc.... 

Many combinations &single words & i can't log in. I tried everything listed above, multiple times. I have succesfully reset my router again twice, made sure to follow steps, seen blinking of lights; that went fine.. just logging in i can not do no matter what.

I did the suggestion to see if my computer gets a reply from the router & that went fine. Everything seems to be ok just am not able to log in to the site..

I know this post is old, just trying many places in hope to greater chances of a reply that aids me succesfully in fixing this problem.

Take care, have a good one!