Reply
Posts: 2
Registered: ‎10-14-2007

Cannot access wirless internet with WRT54GS

I have recently  upgraded my aministrative computer (1.8 ghz dual core processor, 2 gig ram) to windows vista home premium.  I connected my WRT54GS (Newest firmware) to the system and can access the internet just fine when wired; however, my computer in another room(Windows XP, 3.0 ghz, 512 mb ram,), accessing the internet wirelessly, has a low signal from the router but cannot stay connected to the internet.  I receive error messages saying it has not received an ip address, so I use the repair wizard to renew my ip address and then can use the internet for a few minutes before it happens again.  I contacted my ISP and they say there is no problem with my internet, which is shown in the fact I can use the internet when wired.  I am using a WPA encryption if that helps any. Thank you.
Posts: 6,365
Registered: ‎09-16-2006

Re: Cannot access wirless internet with WRT54GS

After a firmware upgrade, you must reset your router to factory defaults, then setup the router again from scratch.  If you saved a router configuration file, DO NOT use it.  If you have not done this since your last firmware upgrade, you should do this first.
 
There are many causes for poor wireless connections, and many solutions:

First of all, give your network a unique SSID. Do not use "linksys". If you are using "linksys" you may be trying to connect to your neighbor's router. Also set "SSID Broadcast" to "enabled". This will help your computer find and lock on to your router's signal.

Poor wireless connections are often caused by radio interference from other 2.4 GHz devices. This includes wireless phones, wireless baby monitors, microwave ovens, wireless mice and keyboards, wireless speakers, and your neighbor's wireless network. In rare cases, Bluetooth devices can interfere. Even some 5+ GHz phones also use the 2.4 Ghz band. Unplug these devices, and see if that corrects your problem.

In your router, try a different channel. There are 11 channels in the 2.4 GHz band. Usually channel 1, 6, or 11 works best. Check out your neighbors, and see what channel they are using. Because the channels overlap one another, try to stay at least +5 or -5 channels from your strongest neighbors. For example, if you have a strong neighbor on channel 9, try any channel 1 through 4.

Also, try to locate the router about 4 to 6 feet above the floor, in an open area. Do not locate it behind your monitor or near other computer equipment or speakers. The antenna should be vertical.  Remember that the maximum working distance of your router might be as little as 30 feet (typical max range is 30 to 100 feet).  If you are getting only one or two bars of signal (out of 5), then move the computer closer to the router, and see if this corrects the problem.

Also, in the computer, go to your wireless software, and go to "Preferred Networks" (sometimes called "Profiles" ). There are probably a few networks listed. Delete any network named "linksys". Also delete any network that you do not recognize, or that you no longer use. If your current network is not listed, enter its info (SSID, encryption (if any), and key (if any) ). Then select your current network and make it your default network, and set it to automatic login. You may need to go to "settings" to do this, or you may need to right click on your network and select "Properties" or "settings".

If the above does not fix your problem, download and install the latest driver for your wireless card.
 
Additional things to try if all the above fails:

For wireless g routers, try setting the "Transmission Rate" to 54 Mbps. For wireless n routers, try setting the "n Transmission Rate" to 162 Mbps, and the (wireless g) "Transmission Rate" to 54 Mbps.

Hope this helps.
Posts: 2
Registered: ‎10-14-2007

Re: Cannot access wirless internet with WRT54GS

Thank you.  I am sure your advice is correct; however, I am unable to access my router.  I can get into my main router setup screen, but then any time I select a page I get this message.  
Internet Explorer cannot display the webpage  
  Most likely causes:
  • You are not connected to the Internet.
  • The website is encountering problems.
  • There might be a typing error in the address.
It has also started happening intermitantly on some other websites, but every time I try to acess the router.  Any ideas?
Posts: 6,365
Registered: ‎09-16-2006

Re: Cannot access wirless internet with WRT54GS

To view the router's web pages:

Use Internet Explorer, it usually works.
JavaScript must be enabled.
Use a computer that is wired to the router.
In the non-working computer, temporarily turn off your software firewall.

If you are using Zone Alarm, right click on the ZA icon in the system tray (lower right corner of screen) and then click "Shutdown ZoneAlarm", and see if this fixes your problem. If this does not work, try the following with Zone Alarm: Open the ZAISS control center, go to Privacy, then temporarily turn off Ad Blocking and Cookie Control, and see if that fixes your problem.

If you are using Noton Internet Security with the Add-on Pack, be sure to turn off the Pop-up Blocker. Some users have reported that they needed to uninstall the entire Norton Add-on Pack.

If you cannot get anything at 192.168.1.1 then perhaps this is not your router's address. Go to "Start" > All Programs > Accessories > Command Prompt.
A black DOS box will appear. Type in "ipconfig" (with no quotes), then hit the Enter key. Look at the "Default Gateway". Is it 192.168.1.1 ? Point your browser to the "Default Gateway", then login to your router.

If the above fails, disconnect your modem from the router, and try again. If this corrects your problem, then most likely you have a "modem-router" rather than an ordinary modem. Check to see if your "modem-router" is using the same 192.168.1.x address space as your Linksys router. If it is, then report back with this problem, and also state the make and model of your modem-router.

If all of the above fails, power down your entire system, unplug it from the wall, wait one minute, then power up and try again.

If all of the above tips fail, you need to reset the router to factory defaults. Power down the router and disconnect all wires from it. Wait one minute. Power up the router, allow it to fully boot (1-2 minutes), then press and hold the reset button for 30 seconds, then release the button and allow the router to reset and reboot ( 2-3 minutes). Power down router. Wait one minute. Connect one computer, by wire, to a LAN port on the router. Boot up system.  You should now be able to access your router setup pages.  You will need to setup your router again from scratch.  If you saved a router configuration file, DO NOT use it.