Reply
dalime
Posts: 18
Registered: ‎02-23-2011

E2000 assigning erroneous IP addresses / not allowing access to server on WIFI

Like it says, my E2000 (firmware 1.0.04) is set to DHCP and for the wireless devices on my network, will assign erroneous IP's for these devices unless I assign static IP's.  Additionally, my wireless devices cannot see my media server (even if on the network with a manual IP).  I don't have any of these issues with devices connected over ethernet.

 

The router's setting are the usual default values of 192.168.1.XXX, subnet 255.255.255.0

 

When the router assigns IP's to my wireless devices, they come up as 169.254.194.XX, subnet 255.255.0.0

 

I cannot figure this one out.  Anyone?  Bueller?

TIA

 

 

Expert
Expert
Posts: 12,649
Registered: ‎07-16-2006

Re: E2000 assigning erroneous IP addresses / not allowing access to server on WIFI

169.254 are not assigned by the router. It's self assigned addresses when there is no access to an DHCP server. Basically it means that either the DHCP server is not working or the computer doesn't get the DHCP requests through.

Are you sure you have enabled the DHCP server on the E2000?
Do you have a working connection if you set a static IP address on the wireless connection?
dalime
Posts: 18
Registered: ‎02-23-2011

Re: E2000 assigning erroneous IP addresses / not allowing access to server on WIFI

DHCP is enabled.  Without a doubt. 

The two devices specifically are my laptop and Logitech Squeezebox and have been having this issues since I got the new router.

 

Most my devices are set in the DHCP reservation table so I know what they're assigned.  This includes my laptop.  One day it had no connection.  Even after power cycling everything, it still couldn't connect.  Also tried taking it off the reservation table and letting it get a different IP.  Still nothing.

Only way to get it on the network is to manually assign the network adapter an IP which, oddly enough, makes it unable to see anything on the network except itself.

 

I'm at a total loss here.

Expert
Expert
Posts: 12,649
Registered: ‎07-16-2006

Re: E2000 assigning erroneous IP addresses / not allowing access to server on WIFI

Wire a computer to the E2000. Check whether you have internet or not. Open a command prompt window, enter "ipconfig /all" and copy the full output into your next post.

Then connect a computer (using automatic IP/DHCP) wirelessly to the E2000 and do the same. Again, post the full output.
dalime
Posts: 18
Registered: ‎02-23-2011

Re: E2000 assigning erroneous IP addresses / not allowing access to server on WIFI

Here's the output for the wired PC.

 

Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\James>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : Office
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : socal.rr.com

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . : socal.rr.com
   Description . . . . . . . . . . . : Broadcom NetLink (TM) Gigabit Ethernet
   Physical Address. . . . . . . . . :
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::dd79:1df0:cd59:ac39%12(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.100(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Sunday, May 01, 2011 5:35:51 PM
   Lease Expires . . . . . . . . . . : Wednesday, May 04, 2011 5:35:51 PM
   Default Gateway . . . . . . . . . : 192.168.1.1
   DHCP Server . . . . . . . . . . . : 192.168.1.1
   DHCPv6 IAID . . . . . . . . . . . : 293874475
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-14-2D-40-9C-84-2B-2B-9F-BF-8C

   DNS Servers . . . . . . . . . . . : 208.67.222.222
                                       208.67.220.220
                                       209.18.47.61
   NetBIOS over Tcpip. . . . . . . . : Enabled

Wireless LAN adapter Wireless Network Connection:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : socal.rr.com
   Description . . . . . . . . . . . : DW1525 (802.11n) WLAN PCIe Card
   Physical Address. . . . . . . . . :
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.socal.rr.com:

   Connection-specific DNS Suffix  . : socal.rr.com
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::5efe:192.168.1.100%13(Preferred)
   Default Gateway . . . . . . . . . :
   DNS Servers . . . . . . . . . . . : 208.67.222.222
                                       208.67.220.220
                                       209.18.47.61
   NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter Teredo Tunneling Pseudo-Interface:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e76:2456:36f7:b3a4:d19f(Pref
erred)
   Link-local IPv6 Address . . . . . : fe80::2456:36f7:b3a4:d19f%17(Preferred)
   Default Gateway . . . . . . . . . : ::
   NetBIOS over Tcpip. . . . . . . . : Disabled

C:\Users\James>

dalime
Posts: 18
Registered: ‎02-23-2011

Re: E2000 assigning erroneous IP addresses / not allowing access to server on WIFI

Here's the wireless (no connection when on DHCP)

 

Microsoft Windows [Version 6.0.6002]
Copyright (c) 2006 Microsoft Corporation.  All rights reserved.

C:\Users\James>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : Notebook
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Bluetooth Network Connection:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network)
   Physical Address. . . . . . . . . :
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Wireless Network Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) Wireless WiFi Link 4965AGN
   Physical Address. . . . . . . . . :
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::197b:d676:e7e0:c25f%10(Preferred)
   Autoconfiguration IPv4 Address. . : 169.254.194.95(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.0.0
   Default Gateway . . . . . . . . . :
   DHCPv6 IAID . . . . . . . . . . . : 167779808
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-10-D0-7D-E1-00-15-C5-83-FF-E8

   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                       fec0:0:0:ffff::2%1
                                       fec0:0:0:ffff::3%1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Local Area Connection:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : socal.rr.com
   Description . . . . . . . . . . . : Marvell Yukon 88E8040 PCI-E Fast Ethernet
 Controller
   Physical Address. . . . . . . . . : 
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 6:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : 02-00-54-55-4E-01
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 9:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : isatap.socal.rr.com
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 7:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 10:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : isatap.{4AF65B66-223C-4B64-BEC4-03D5A5C51
CC6}
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

C:\Users\James>

dalime
Posts: 18
Registered: ‎02-23-2011

Re: E2000 assigning erroneous IP addresses / not allowing access to server on WIFI

bump

Expert
Expert
Posts: 12,649
Registered: ‎07-16-2006

Re: E2000 assigning erroneous IP addresses / not allowing access to server on WIFI

The wired looks good. The wireless doesn't talk to the DHCP server.

 

Set a static IP address on the wireless connection:

 

IP 192.168.1.50

subnet 255.255.255.0

gateway 192.168.1.1

DNS 208.67.222.222 208.67.220.220

 

Check if you have a working internet connection on the wireless now. Try to connect your media server using the IP address (if possible).

dalime
Posts: 18
Registered: ‎02-23-2011

Re: E2000 assigning erroneous IP addresses / not allowing access to server on WIFI

The laptop has no issues connecting to the internet when I assign a static IP, but for some reason, will not see the other devices on my network. 

I have at one point (about a month back) gotten the laptop to connect via DHCP and it was able to see my desktop server.  That didn't last more than a day and was dropped from the network.  As soon as I assign it a static IP, it can't see the server anymore.

Expert
Expert
Posts: 12,649
Registered: ‎07-16-2006

Re: E2000 assigning erroneous IP addresses / not allowing access to server on WIFI

Check the security software on your computer. May it blocks broadcasts.

You could also try to disable wireless security for a test. See if the laptop works with DHCP then and can see the other devices in the network.

Otherwise, maybe the firmware on the router got corrupted and the router doesn't properly send out broadcasts. You could try to download the latest firmware for the router, load it to the router. After that, reset the router to factory defaults by pressing the reset button for 30 seconds. Reconfigure the router and check if it works or not.