Showing results for 
Search instead for 
Do you mean 
Reply
RogerSC
Posts: 485
Registered: ‎08-01-2009

Re: E2500 - slow 11g

Yes, I'm currently getting about 2.5MB/s on a wireless-g transfer from my desktop to laptop using an E4200 with tomatoUSB firmware.  This is more than 15Mb/s.

 

On the other hand, if you can use wireless-n, I'm getting about 10MB/s (or a factor of  about 4) for the same transfer using wireless-n.  My laptop is limited to 150mb/s maximum using the build-in wireless-n interface (only one stream).  If my laptop wireless-n adapter had multiple streams, the wireless-n speed might be even better *smile*.

 

Just a note, you can easily add an external wireless-n USB adapter to a laptop.  I've thought about doing that to get up to 300Mb/s or 450Mb/s (again maximum, many factors determine actual throughput), but haven't felt strongly motivated enough to go there.

sjashinski
Posts: 5
Registered: ‎12-05-2011

Re: E2500 - slow 11g

Thanks. I'm somewhat of a novice when it comes to networking so I tend to stick with what I know. That is why I bought the E2500. I am such a creature of habit, that I bought the Cisco AE2500 dual band USB adapter for my wife's desktop. That is why the decreased performance is even more disappointing.

 

Oh well, nothing like looking foward to spending several hours fighting with technology. At least I'll have beer :-)

RogerSC
Posts: 485
Registered: ‎08-01-2009

Re: E2500 - slow 11g

Yeah, but once you've gotten things figured out and configured the way that you want it, then you'll be the guru *smile*.  Learning on the job is a time-honored way to get up on the knowledge ladder.

 

Enjoy the beer, too, have one on me *smile*.

foxxmulder71
Posts: 1
Registered: ‎01-25-2013

Re: E2500 - slow 11g

Help please! I have a e2500 and also have 30mbps internet. I can only get 15mbps from my e2500. If tested on the internet Charter shows 42mbps but not the e2500. It onlyl maxs at 15. If i direct connect to my ps3, it too show 15mbps. Any ideas what is wrong?

opheliaimmortal23
Posts: 1,644
Registered: ‎05-04-2012

Re: E2500 - slow 11g

Since the router filter the packets coming in from the modem, you should at least get 38 MBPS internet speed due to the 10-15% overhead. Try to lower down the MTU size of the router to 1365 if you have Cable Internet or 1472 if you have DSL. If that will not make any difference, update the firmware of your router to the latest.

Bob RR
Posts: 5
Registered: ‎02-22-2013

Re: E2500 - slow 11g

I have an E2500 that I was getting 15 - 25 Mbps speed on all my computers with a 15 Mbps service. I decided to take up an offer from Charter to move up to 30 Mbps. They sent me a new modem. I installed it and now I can only get a max of 11.5 Mbps on ALL my computers. Laptop, iPad on wireless and a desktop hard wired.

I tried all sorts of things to no avail and then decided to go into the router set up. As soon as Cisco connect came up, a noticed that there was a new update posted. I performed the update and then immediately did a speed test. I got 24 Mbps on the laptop over the wireless and 42 Mbps over the direct wired desktop. I was overjoyed and thought my problem was over. These speeds only lasted 20 minutes and they are all back to the maximum of 11.5 Mbps. What gives???
Expert
zee29
Posts: 1,329
Registered: ‎04-22-2012

Re: E2500 - slow 11g

Seems like you only got a burst of the speed expected. Reset the router. It is always good to do a hard reset after a firmware upgrade. Push and hold the reset button of the router for 30 seconds then powercycle it and power it back on. Then proceed in reconfiguring the router.

highspeedneed769
Posts: 118
Registered: ‎09-02-2012

Re: E2500 - slow 11g

[ Edited ]

A n router will not give you full speed on a g device at least for me it never has now on the n band speeds are the same as hard wired. Just my experience. If you disable WMM it may help but then you wont have wireless N only G on the 2.4 ghz band.

Bob RR
Posts: 5
Registered: ‎02-22-2013

Re: E2500 - slow 11g

[ Edited ]

Through much testing all day, it appears what is causing the spped to drop is my Cisco range extender. If I spped test my service and have 11.5 Mbps, and I unplug the range extender and immediately do a speed test, I have 23 Mbps over wireless and 43 mbps on the hard wired desktop. If I plug the extender back in, it takes about 1/2 hour and it is back to 11.5 Mbps on all the computers using wireless. The desktop remains at 42 Mbps.

I don't know if there is a setting on the extender that may be limiting my speed to the top end of the G. Other than that...the extender is amplifying the signal so the range is better, but it seems to be cutting the speed in half.

Bob RR
Posts: 5
Registered: ‎02-22-2013

Re: E2500 - slow 11g

[ Edited ]

Reading further on the WEB, I read that cheaper range extenders DO cut your speed in half because of re transmitting on one radio broadcast channel.  If it had two radio channels like the more expensive ones, it would not cut it in half.  So sounds like the Cisco WRTE54G range extender is the problem of my decreased net speed.

 

Best way around it is a high power access point.  Wished I knew this when I spent  $100 on the range extender a year or more ago.