Reply
electrcguy482
Posts: 2
Registered: ‎02-26-2011

E4200 - FTP access from internet - newbie question

I am completely lost on how I'm supposed to access my FTP server from the internet.  I have an E4200 router, and can access the FTP server on it from within my home network.  If I try to browse to my FTP site from the internet, I don't get anywhere.  Here's how my network is set up

 

Internet --> Verizon DSL -->  Verizon DSL 'Modem' --> E4200 Router (with FTP enabled) --> devices on my network

 

I get my current IP address from: http://whatismyipaddress.com/

 

I type into Internet Explorer: ftp:// [ip address from whatismyipaddress.com]

      *This gives me "Internet Explorer cannot display the webpage"

 

I've also tried: ftp://[ip address from whatismyipaddress.com]/[name of ftp server typed into e4200's FTP Server Setup]

      *This gives me "Internet Explorer cannot display the webpage"

 

I'm sure this is a simple fix, and it may have something to do with settings on my DSL 'modem,' but I've already been flailing about on this for a couple hours...

 

Thanks!

 

--Jon

electrcguy482
Posts: 2
Registered: ‎02-26-2011

Re: E4200 - FTP access from internet - newbie question

bump...

benjaminonken
Posts: 1
Registered: ‎02-27-2011

Re: E4200 - FTP access from internet - newbie question

Have you tried setting up port forwarding to your private device?  If you go to the "Applications & Gaming" tab, you should be able to select "FTP" from the drop down selection box on the left side, and input your devices IP address to the right on the same line.  You can set this up for other traffic as well if you have a web server running, you can port forward HTTP and/or HTTPS traffic to an internal IP as well.

Ricewind
Posts: 3,013
Registered: ‎09-07-2006

Re: E4200 - FTP access from internet - newbie question

As you have mentioned that your ISP is an DSL provider, Login to the setup page of your Router and click on the status tab and check if the Internet IP address.

 

Have you enable the FTP feature on  your Router? If not then login to the setup page of your Router and click on the storage tab and below Enable "FTP Server" and let the FTP Port be 21 and below select the folder which you want to access it from Internet and click on save settings... Then click on the Administration tab and check for the "Server Internet IP Address" and also below check if Anonymous FTP access is it Enable or Disable.If you wish to allow anonymous Internet access then you need to Enable it or let it be Disable and click on save settings... 

 

To access your FTP server from Internet note down the WAN IP, So it should be ftp://ftp.wan-ip:21. This should allow you to access your drive from the remote location.