Reply
Posts: 142
Registered: ‎03-05-2012
Accepted Solution

E4200v2 Bridge Mode + Guest Access: No DHCP IP's assigned?!

New E4200v2 on 2.0.37.  In "Bridge Mode - DHCP" (i.e. Access Point not router).  Guest Access is enabled & SSID broadcast.  Dhcp Server is disabled, because my main Sonicwall router is providing that for main LAN 192.168.1.0.

 

PROBLEM = Client PC can see "-guest" SSID fine and associate to it, BUT PC does NOT receive a DHCP IP address (i.e. 192.168.33.x) therefore the browser login page never appears and guest access does not work.

 

I'm pretty sure that it's all related to DHCP.  I'm assuming that the E4200 is not receiving or sending guest DHCP packets with the client PC.

 

I seen Guest Access work on the older E4200v1's before so I know what it should look like.

 

Can anyone suggest any likely reasons why my E4200v2 wouldn't be providing DHCP guest addresses in the 192.168.33.0 subnet?

 

I only have 24 hrs until I have to deploy 2 new E4200v2's at a remote site, and after that it's going to be really hard to troubleshoot because I won't be at that site.

 

Thanks in advance for any expert advice!

Expert
Expert
Posts: 12,649
Registered: ‎07-16-2006

Re: E4200v2 Bridge Mode + Guest Access: No DHCP IP's assigned?!

Do guests get an IP address if you enable the DHCP server?

Do you see guest DHCP requests on your sonicwall?
Posts: 142
Registered: ‎03-05-2012

Re: E4200v2 Bridge Mode + Guest Access: No DHCP IP's assigned?!

When you're in bridge mode DHCP server option goes away.  And I don't care if DHCP requests are getting to my Sonicwall b/c that device is not going to assign the Linksys Guest IP's... E4200 must do that, apparently in a totally hidden way.

 

In any case, I don't have any more time to waste on E4200v2's so I'm going to try some E4200v1's which I just happen to have handy, thankfully.

 

If Bridge Mode + Guest Access works better on the V1's then I'll retreat back to that older more obsolete hardware. Smiley Tongue

 

I'll report back later.

 

(In meantime if anyone else cares to offer their knowledge experience about this, V2 or V1, I'm all ears)

 


gv wrote:
Do guests get an IP address if you enable the DHCP server?

Do you see guest DHCP requests on your sonicwall?


 

Posts: 2,634
Registered: ‎09-07-2006

Re: E4200v2 Bridge Mode + Guest Access: No DHCP IP's assigned?!

If the router E4200 v2 is connected from the its LAN port to the LAN port of the sonic firewall or from the modem then the guest network will not connect. Since the router looses it's capability to broadcast the IP address from its own DHCP. Due to which the router will not connect to the Guest Network. 

Posts: 142
Registered: ‎03-05-2012

Re: E4200v2 Bridge Mode + Guest Access: No DHCP IP's assigned?!

Yes I have always used the WAN port to connect bridged router to LAN.  That's not the issue for me.

 

But I think I may have found something that is key.  Apparently the router wants to be in NAT mode for Guest-Access, even if you enable Bridge-mode.  So I'm just about to test that out on a V2.

 

I had luck earlier today on a V1 which I left in NAT mode before I enabled Bridge-mode.  And the reason I did that was because when I went to turn off NAT mode the V1 gave me a nice warning that this would negate Guest-Access.  I don't recall the V2 ever giving that warning.

 

I'll let you know what I find w/ my next V2 tests (hopefully tonite)

Posts: 142
Registered: ‎03-05-2012

Re: E4200v2 Bridge Mode + Guest Access: No DHCP IP's assigned?!

I think I SOLVED IT!

 

Apparently you need to ENABLE both NAT & DHCP SERVER on the E4200, *before* you switch into BRIDGE-MODE.

 

When I did this, the Guest-Access works fine!  Hurrah!!!!

 

I guess the E4200 needs to use those 2 services running in the background to make the Guest-Access subnetting & dhcp assignments work, which is a hidden process once you're in Bridge-Mode.

 

Wow, Cisco should really have some user guide section or KB article on that.  Or at least when you click Bridge-Mode a little pop-up telling you to make sure these 2 pre-req's are enabled.

 

I'm moving on now. Smiley Happy