Reply
jrosenbl
Posts: 15
Registered: ‎03-16-2011

EA6500 apparent firmware bug report - Intermittent Internet connection issues

I recently swapped a EA4500 for an EA6500 and have been experiencing intermittent Internet connection issues, specifically periodic disconnects (as some other users have reported). The router is connected to a Motorola SB6121 Cable Modem with Comcast as the cable provider. I contacted Comcast and they specify 1500 as the MTU size. With the Router set to Auto, I experience the periodic disconnects. When the MTU is manually set, I still experience the periodic disconnects, and I noticed that a ping test specifying the packet size with the -l switch results in a fragmented packet and is only resolved when the ping packet size is reduced by 28 bytes. Thus, it appears that the MTU specified on the router fragments all packets of that size and up to 27 bytes less than the MTU setting. For example, with the MTU set to 1500, all packets 1473 or larger are fragmented; with the MTU at 1444, all packets 1417 or larger are fragmented. I believe there is a bug in the current firmware, which I have installed on this router as version 1.1.27.141816. Regardless, even with the router set to Auto, the correct packet size is not properly detected and disconnects occur. Please verify this issue and provide a workaround and ETA for permanent firmware update fix.

Expert
jlbjlb
Posts: 2,718
Registered: ‎07-07-2012

Re: EA6500 apparent firmware bug report - Intermittent Internet connection issues

Have you tried disabling ipv6 on the EA6500?

hillary681
Posts: 800
Registered: ‎04-22-2012

Re: EA6500 apparent firmware bug report - Intermittent Internet connection issues

are you already running FW version 1.1.27? if you're on the initial release, get the latest firmware downloaded from the EA6500 Support Page. RESET and reconfigure your router from there and check if you get the same connectivity issues. MTU should be fine on auto but you can always count on your ping test results to get the ideal MTU size as you already have.

jrosenbl
Posts: 15
Registered: ‎03-16-2011

Re: EA6500 apparent firmware bug report - Intermittent Internet connection issues

This MTU bug is present whether IPv6 is enabled or disabled, however the Internet disconnection issue appears to be more prevalent when running in dual-stack IP mode. In my environment, the Comcast cable modem supplies both an IPV4 and IPV6 address, but the EA6500 appears to lose the connection if it starts a session on IPV4 and switches to IPV6 or vice versa. Has anyone else confirmed this?

jrosenbl
Posts: 15
Registered: ‎03-16-2011

Re: EA6500 apparent firmware bug report - Intermittent Internet connection issues

I am not running the initial release of the firmware. I am running the latest version 1.1.27.141816. The problems are present with this version. In addition, the ping test was how I determined that the MTU packet size is 23 bytes less than how it is set.

Expert
jlbjlb
Posts: 2,718
Registered: ‎07-07-2012

Re: EA6500 apparent firmware bug report - Intermittent Internet connection issues

According to a post in the thread "EA6500 defective??" There us an issue with Comcast not properly implementing ipv6.

Have you called linksys technical support? How do you know the problem isn't with Comcast ?

My advice is to call technics support from both linksys and Comcast. In the meantime, reset the ea6500 to factory defaults , and disable ipv6.
jrosenbl
Posts: 15
Registered: ‎03-16-2011

Re: EA6500 apparent firmware bug report - Intermittent Internet connection issues

I think I need to clarify this firmware bug - There are two issues here. I am aware of the IPV6 issue with Comcast and have disabled the IPV6 on the router. That solves the problem where the router is confused with IPV4 versus IPV6 communication and disconnects intermittantly related to this issue.

 

The firmware bug that I describe relates to the MTU setting on the router which does not match the value entered - It is 23 bytes less per packet. I have confirmed this bug following the MTU procedure described in this Linksys support article 386 and link:

 

http://www6.nohold.net/Cisco2/ukp.aspx?vw=1&docid=fbf8e8564632422eaa8ea80bf9dcba64_386.xml&pid=80&re...

 

Please validate if you can reproduce this bug as I described.

opheliaimmortal23
Posts: 1,644
Registered: ‎05-04-2012

Re: EA6500 apparent firmware bug report - Intermittent Internet connection issues

It is best to check with your ISP again about IPV6. I have not come across with anyone here though having the same issue on a Comcast ISP. BTW, I found this from google: http://forums.comcast.com/t5/Connectivity-and-Modem-Help/Interesting-IPv6-Problem/td-p/1303923

Expert
jlbjlb
Posts: 2,718
Registered: ‎07-07-2012

Re: EA6500 apparent firmware bug report - Intermittent Internet connection issues

I'll try one more time.........,

I think you should call linksys technical support.
@NO_SCREENNAME@
Posts: 2
Registered: ‎01-04-2013

Re: EA6500 apparent firmware bug report - Intermittent Internet connection issues

I have the same problem...on comcast, have EA6500...installed smoothly and worked for two days....then started with intermittent connection.....worked with cisco for over 6 hours on three separate occassions....first they blamed my switch, my computer, comcast....then they reinstalled the most recent firmware...still intermittent connection and can not hardwire my computers into their system.   So far this has cost me way more in time than I will every get back in value, speed or ease of use.   Now cisco promises to send me new router but it sounds like the Ping thing will result in the same crappy intermittent connection.  What should I do....net gear?