Reply
WiiBrawler19
Posts: 2
Registered: ‎08-13-2008

I can't connect to the internet on my wii!

[ Edited ]
Hello,Im New.
I can't seem to connect to the internet on my wii wirelessly.
The wii can search for it but when i test it, it says Error Code:51331...
Help me!My modem is SpeedTouch671411(i thing I'm right).
I dont know how to log into the modem...Or the channel thingy:smileysad:
Help me please!
 
I can't live without wifi brawling:robotwink:


Message Edited by WiiBrawler19 on 08-13-2008 06:45 AM

Message Edited by WiiBrawler19 on 08-13-2008 06:46 AM
larbel1
Posts: 29
Registered: ‎07-06-2008

Re: I can't connect to the internet on my wii!

WiiBrawler:
 
   In my opinion, you don't provide NEARLY enough information to be helpfull to you. 
 
I presume that you are using a wireless ROUTER to connect your PCs and the Wii to the internet.  I don't kow if a  "SpeedTouch671411" is a router, or a model of a cable modem you have.   And even though my son has a Wii, I have no idea what  a "Code: 51331" is.
 
PRESUMING THAT YOU HAVE  A LINKSYS ROUTER, you would need to enter the router setup interface.  In your browser, enter the IP address of the router (default of 192.168.1.1, and the default user/password are I believe admin/password. but check the router docs or website for exact default user/password )
By the way, you should immediately CHANGE all of these default settings so someone doesn't park outside your house/apt with a wirless laptop and get into your network and thorouhly TRASH your computers and network.  I've seen it happen to a business.
 
 
The instructions I have listed below for another user should work for you .  These instructions are based on the presumption that you have the router set to be a DHCP server (set so the router assigns IP address to the computers on your network. I think this is a default setting).   They are also presuming that the router is set up for "WIRELESS NETWORK MODE" of "MIXED"  (look on the WIRELESS tab in the Router setup pages).  
 
   We have the Wii set up just fine on a WRT600N.    NO port forwarding like others might suggests.   
 
    Without having it in front of me, all I can suggest is to carefully write down all the security settings on the router EXACTLY, including encryption method ( I use WPA-Personal), and the encryption/pass/hex key.  The hex key is the 26 or so characters in what should be the box under where it says "WPA-Personal" in the setup page on the router.
 
   On the setup page on the Wii, you have to enter all the same parameters from the router into the Wii -- EXACTLY. 
 
1) On the Wii, get to the page where you can select which of the 3 connections
     you want to use.
2) Select (click on) the connection you wish to use, and select "change settings"
3) I believe the next box is for the SSID of the router.  Click on the box for the SSID
     to get the on-screen keyboard, and enter the EXACT same SSID name you
     used on the router.  The SSID is CASE SENSITIVE !!
4)  Click on the blue arrow to the right to select the Security Method you are using
     on the router. Click on the Security Method used on the router, and then you
     should get the prompt to enter the phrase/passkey in the box.  Again, click on
     box to get the on-screen keyboard, and enter the same EXACT passkey from
     the router.  This should not be case sensitive.   I believe you have to click 
     'Confirm' and enter the passkey again.   When done, click on the blue
     arrow on the right.
5)  Yes to 'Auto Obtain IP Address'  (click on right arrow to continue)
6)  Yes to 'Auto Obtain DNS'   (click on right arrow to continue)
7)  DON'T use "Proxy Server"  (click on right arrow to continue)
8)  I left the MTU set at '0'.
 
At this point, I think you can SAVE the settings, and give the connection a test.  It may take a couple of minutes for the router to assign an IP address.
 
If it STILL will not connect, check the router to make sure that you have allowed the Wii to access your wireless network.  I have my router set up to allow ONLY the wireless devices I specify (by MAC address).   Check the router "Wireless MAC filter" to make sure you are allowing your Wii access.  If you haven't specifically allowed it, you have to get the MAC address from the Wii (go back into the settings page on the Wii to find it), and enter the Wii MAC address into the list to 'allow' on the router.
 
If you have done all that correctly, you should get internet on the Wii (ALL without port-forwarding).
 
It is pretty much the same hassle as setting up a new wireless PC connection.  You have to be really carefull to enter all the information correctly in all the right places.
 
This should get you going on the internet with the Wii, so Happy Gaming!
 
Remember WiiBrawler, if you want help on this forum, you MUST give us some information as to what the heck you are doing, what you have tried, and especially what equipment you have.   Just saying "I NEED HELP!" isn't enough.   The text of the any error code (if it was given) would also be of help.
 
 
vai_fan
Posts: 2,766
Registered: ‎09-07-2006

Re: I can't connect to the internet on my wii!

You need to assign the static ip address to Wii & forward the port numbers for the same on the setup page of the router & you will be able to play the games wirelessly.
CScott135
Posts: 2
Registered: ‎08-14-2008

Re: I can't connect to the internet on my wii!

[ Edited ]
Wow! Thanks larbel1! That was actually helpful information! My router is currently set to disable the MAC filter, but, I still cannot connect my Wii to the internet. Do I need to enable MAC filtering? And if I do, will I have to put the MAC addresses in to continue using both laptops that I already setup with the wireless PC connection??
 
Thanks for the help!
 


Message Edited by CScott135 on 08-14-2008 11:05 PM
larbel1
Posts: 29
Registered: ‎07-06-2008

Re: I can't connect to the internet on my wii!

Aye Mr Scott (HAD to get my Star Trek chuckle in there):
 
I'm glad that you thought my information was usefull, though appearantly not usefull enough for you to get your Wii online.
 
First of all, No, you shouldn't have to enabel the MAC filtering to get the Wii to connect to the internet through your router.    I choose to use MAC filtering on my router as a way to try to limit who has access to my network, and thus my computers.    Without MAC filtering to limit just YOUR machines being able to access your network, I could sit outside your home, and access any network shares on any of your machines.  And if you had private information on those shares, your A*# could be mine.  There was a point where I COULD access the wireless router and computers of a neighbor.  I found a file with bank and credit card information.  If I was a  really bad person, I might have tried something with that information. 
 
So anyway, I like to MAC filter my network and allow ONLY those MAC addresses on the list to have access to my network.  And of course don't broadcast the SSID of the router, and use the strongest encryption all your adapters can use (I use WPA2 personal if possible with TPIK+AES ) 
 
So yes, if you use the MAC filtering to keep neighbors off your network and out of your computer files, you HAVE to have to get the MAC addresses for ALL of the computers in the house, including the Wii, and enter all that information into the MAC Addresses list on the router for all the wireless clients.   Be carefull that each of the MAC addresses are entered correctly.   Needless to say  the Encryption method, the encryption key, and the SSID and channel need to match between the router and all the wireless adapters (and Wii) or not everyone on your network will be able to 'talk' to each other and the internet.
 
The fact that you are not using MAC filtering, and are not able to get on the internet with the Wii (while the laptops are able to access the internet)  indicates to me that you have either an Encryption method, encryption key, SSID, or perhaps channel number set incorrectly on the Wii.  I suggest you go back into the ROUTER set up pages and write down all the information  from the router (SSID, Encryption method and key, the channel number, and whatever else I'm forgetting).  Then go back to the Wii setup pages and verify that you entered everything in correctly.  Remember that the SSID  IS CASE SENSITIVE!!!  The encryption key is not case sensitive. 
 
  You don't have to use MAC filtering on your router, but I think is a good idea.  But if you do, you DO have to enter all wireless Client MAC information into the router wireless MAC list.    I think you simply oopsed a setting on the Wii, and that is what is keeping your Wii off the internet.
 
Setting up a wireless network can really be a pain sometimes.
 
Larbel1
 
 
larbel1
Posts: 29
Registered: ‎07-06-2008

Re: I can't connect to the internet on my wii!

I should have also mentioned that I have the Wii DHCP enabled (I think), and I didn't do any port forwarding as VIA_Fan suggests.  
 
I don't truely know if this is causing any problems for my son in playing some of his games.  I DO hear him yelling at it a lot, complaining on response times mostly.  But he has ADHD, and I would suspect that it is his impatience and not a real problem with internet delay times or the fact that ports are not forwarded.
 
But I'm not going to worry about it.
CScott135
Posts: 2
Registered: ‎08-14-2008

Re: I can't connect to the internet on my wii!

It's Ms. Scott actually. lol
I had my router password protected. I don't really know what the problem was, but I had Linksys walk me through fixing it a few days ago. Thanks for your help though! Having the internet connected really didn't matter anyway, because I have a new tv, and apparently the downloaded games cannot be displayed properly. And I don't have a dvd player that I can connect the wii to. So, oh well.
Thanks again for your help.
jessica2332
Posts: 2
Registered: ‎08-14-2013

Re: I can't connect to the internet on my wii!