Posts: 2
Registered: ‎12-03-2007

Laptop takes forever to connect to wi-fi.

I have a wrt54g wi-fi router a befcmu10 cable modem connected to my desktop with WPA2 security enabled. I use the wi-fi to connect my laptop to the internet. The problem is that the laptop takes forever to connect. When I boot the laptop, I get an error balloon stating that my preferred connection can't be accessed. When I bring up the list of connections, it shows the router with excellent signal strength. If I click connect, it makes an attempt, then the list refreshes and nothing happens. If I let it sit, it eventually connects and works fine. I don't have any other computers to test the connection nor do I have another access point local to test the laptop. Any advice would be appreciated.
Posts: 6,365
Registered: ‎09-16-2006

Re: Laptop takes forever to connect to wi-fi.

There are many causes for poor wireless connections, and many solutions.  With the problem that you described, I would suggest you try items 1 and 5 first.   If that does not fix your problem, try the other items in numeric order. 

1)  First of all, give your network a unique SSID. Do not use "linksys". If you are using "linksys" you may be trying to connect to your neighbor's router. Also set "SSID Broadcast" to "enabled". This will help your computer find and lock on to your router's signal.

2)  Poor wireless connections are often caused by radio interference from other 2.4 GHz devices. This includes wireless phones, wireless baby monitors, microwave ovens, wireless mice and keyboards, wireless speakers, and your neighbor's wireless network. In rare cases, Bluetooth devices can interfere. Even some 5+ GHz phones also use the 2.4 Ghz band. Unplug these devices, and see if that corrects your problem.

3)  In your router, try a different channel. There are 11 channels in the 2.4 GHz band. Usually channel 1, 6, or 11 works best. Check out your neighbors, and see what channel they are using. Because the channels overlap one another, try to stay at least +5 or -5 channels from your strongest neighbors. For example, if you have a strong neighbor on channel 9, try any channel 1 through 4.

4)  Also, try to locate the router about 4 to 6 feet above the floor, in an open area. Do not locate it behind your monitor or near other computer equipment or speakers. The antenna should be vertical.

5)  Also, in the computer, go to your wireless software, and go to "Preferred Networks" (sometimes called "Profiles" ). There are probably a few networks listed. Delete any network named "linksys". Also delete any network that you do not recognize, or that you no longer use.   If your current network is not listed, enter its info (SSID, encryption (if any), and key (if any) ). Then select your current network and make it your default network, and set it to automatic login. You may need to go to "settings" to do this, or you may need to right click on your network and select "Properties" or "settings".  Reboot computer.

6)  If the above does not fix your problem, download and install the latest driver for your wireless card.

7)  For wireless g routers, try setting the "Transmission Rate" to 54 Mbps. For wireless n routers, try setting the "n Transmission Rate" to 162 Mbps, and the (wireless g) "Transmission Rate" to 54 Mbps.

8)  If you still have trouble, download and install the latest firmware for your router. After a firmware upgrade, you must reset the router to factory defaults, then setup the router again from scratch. If you saved a router configuration file, DO NOT use it.

Hope this helps.
Posts: 2,800
Registered: ‎09-07-2006

Re: Laptop takes forever to connect to wi-fi.

Try changing the security mode to WPA and check whether the laptop connects to the router's wireless network. If it connects without any issues try this link to use WPA2 security on your laptop.
Let me know how things work for you.
Posts: 2
Registered: ‎12-03-2007

Re: Laptop takes forever to connect to wi-fi.

Forsaken, Thanks for the response. That seems to be the problem. When I switch to WPA, the laptop connects immediately. I have installed the patch on both the desktop and laptop, and the problem persists, though. It still takes forever to connect using WPA2. Do you have any more advice?