Reply
boognish1
Posts: 2
Registered: ‎09-27-2009

My WRT54GL 1.1 router keeps disconnecting

Ever since I have had this router, I keep getting disconnected from the internet on a very irregular basis. This happens even when running my wired desktop through the router. If I connect directly to my Clearwire modem, the connection is fine, so I know that the router is causing the problem. Sometime it will go for days without disconnecting, but other times it will disconnect several times in an evening, usually at the most inopportune time, of course. I have the latest firmware upgrades installed.

 

Any help would be greatly appreciated. I'm about to throw this unit in the trash and start over with another brand of router.

boognish1
Posts: 2
Registered: ‎09-27-2009

Re: My WRT54GL 1.1 router keeps disconnecting

This may be a dumb question, but I'm new at this. What does client lease time mean in the setup screen? The default is set to zero. Could that be the cause of my problems? Would setting it to 9999 help?

 

zetoune
Posts: 2
Registered: ‎09-29-2009

Re: My WRT54GL 1.1 router keeps disconnecting

[ Edited ]

Hi,

 

It's very weird. I use this router and I do recommended it to my customers because it's more than reliable.

I never had any problems with any of the WRT54GL  my customers and I used.

You don't have to change the lease time value. This value represents the time a computer will keep an IP from the DHCP server before being renewed.

 

 

One thing you can try :

Unplug the ethernet cable of the router from the modem. 

Switch your modem off for 30 seconds (at least).

Switch your router off for 30 seconds (at least). 

Switch your router on and press the reset button for 10 seconds (at least).

Switch your modem on.

Plug the ethernet cable of the router to the modem back.

 

This procedure will erase all personal settings you set in the router. It will make the router go back to its factory settings.

So If you use a DSL modem, enter your info into the router again. If you use a cable modem, everything should be ok.

 

Let me know if it works.  

Message Edited by zetoune on 09-29-2009 08:50 AM
castor
Posts: 3,376
Registered: ‎09-07-2006

Re: My WRT54GL 1.1 router keeps disconnecting

Try adjusting the wireless settings of the router...Under the Setup tab,change the MTU value to 1300.Under the wireless tab, change the wireless channel to 11 and click on save settings.Change the Beacon Interval to 75 ...Change the Fragmentation Threshold to 2304 Change the RTS Threshold to 2307 ...Click on "Save Settings"..under Advance Wireless Settings.

 

Now check the connection...