Reply
Ronbo4442
Posts: 3
Registered: ‎11-13-2009
Accepted Solution

No internet when using Ethernet port on WRT54G

Router worked OK in a.m., but in/op later that day. Ethernet light works when plugged into it, but no internet on desktop. Do get wireless internet on laptop. Unplugged from Ethernet port to port #2 and can get internet. Settings look to be the same, but I'm no expert, so who knows what happened. Tried rebooting, turning everything off/on, and went to brouser page 192.168.1.1 to see if anything changed. Also, the USB connected to my Tivo shows a signal but will no longer connect to the network. Any ideas? I have Windows XP. I also updated the WRT54G drivers after the problem occurred.
Expert
Expert
Posts: 12,649
Registered: ‎07-16-2006

Re: No internet when using Ethernet port on WRT54G

Open a command prompt window on the computer which does not connect to the internet and enter "ipconfig /all". Copy the full output of this command into your answer. Maybe it shows something wrong...
Gollum
Posts: 2,517
Registered: ‎09-07-2006

Re: No internet when using Ethernet port on WRT54G

When you connect your Computer to the Non Working Port, in the Command Prompt type "ipconfig" and hit enter and check the IP, and you can do the things what GV suggested you. Just past the Output on the Next post.
Ronbo4442
Posts: 3
Registered: ‎11-13-2009

Re: No internet when using Ethernet port on WRT54G

    

Microsoft Windows XP [Version 5.1.2600]

(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\default ipconfig/all

Windows IP Configuration

Host Name . . . . . . . . . . . . : OFFICE

Primary Dns Suffix  . . . . . . . :

Node Type . . . . . . . . . . . . : UnknownIP Routing Enabled. . . . . . . . : NoWINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix  . :

Description . . . . . . . . . . . : SMC EZ Card 10/100 PCI (SMC1211TX)Physical Address. . . . . . . . . : 00-10-B5-DB-2A-71Dhcp Enabled. . . . . . . . . . . : YesAutoconfiguration Enabled . . . . : YesIP Address. . . . . . . . . . . . : 192.168.1.101

Subnet Mask . . . . . . . . . . . : 255.255.255.0

Default Gateway . . . . . . . . . : 192.168.1.1

DHCP Server . . . . . . . . . . . : 192.168.1.1

DNS Servers . . . . . . . . . . . : 192.168.1.1

Lease Obtained. . . . . . . . . . : Tuesday, November 17, 2009 8:59:33 AMLease Expires . . . . . . . . . . : Thursday, November 19, 2009 8:59:33 AMPPP adapter Centurynet:

Connection-specific DNS Suffix  . :

Description . . . . . . . . . . . : WAN (PPP/SLIP) Interface

Physical Address. . . . . . . . . : 00-53-45-00-00-00

Dhcp Enabled. . . . . . . . . . . : No

IP Address. . . . . . . . . . . . : 207.118.207.83Subnet Mask . . . . . . . . . . . : 255.255.255.255Default Gateway . . . . . . . . . : 207.118.207.83DNS Servers . . . . . . . . . . . : 207.230.192.251                                              209.206.136.9NetBIOS over Tcpip. . . . . . . . : Disabled

C:\Documents and Settings\default

                 

 

  
Expert
Expert
Posts: 12,649
Registered: ‎07-16-2006

Re: No internet when using Ethernet port on WRT54G

The computer has an active PPPoE connection. You connect directly to the internet either bypassing the WRT through the ethernet connection or because your modem has an additional USB port through which your computer connects to the internet effectively blocking out any other connection.

You have to unconfigure the PPPoE connection. Select "Internet Options" from the control panel. On the Connections tab make sure to select "Do not dial a connection" (below the list of configured dial-up connections). OK the change. Then disconnect your active PPPoE connection ("Centurynet") from the Network Connections control panel.

After you have disconnected the PPPoE connection you should be able to connect to http://192.168.1.1/ again. Your router should also be able to connect with PPPoE now. Check on the Status page. Press Connect if necessary. This should go through if you have configured your router correctly for your PPPoE connection.
Ronbo4442
Posts: 3
Registered: ‎11-13-2009

Re: No internet when using Ethernet port on WRT54G

Alakazam. Thanks.