Reply
Kalidascorp
Posts: 3
Registered: ‎11-23-2006

Port Forwarding not working properly.

Router: WRT54G V.6
Firmware: 1.00.9

Basically, my port forwarding does not work. Using this link (https://www.grc.com/x/portprobe=55554), I can test a port to see if it's open or not.

Whenever I open a port on the router, it displays the port as "CLOSED", while I am aiming for "OPEN". This is a new router, and this problem also was occuring on my old V.2 one. Strangly, when I first tried opening the ports, it worked fine. Next day, it appeared as close, and no other settings were changed.

Any help out there? If any more information is needed, please tell me.
Expert
Expert
Posts: 12,649
Registered: ‎07-16-2006

Re: Port Forwarding not working properly.

Only if grc reports the port "STEALTH" you have no port forwarding. If it is "CLOSED" then the port on the computer you are forwarding to has the port closed. You must check the settings on the computer where you forward to to see whether the port is open or not. Simply setting up a port forwarding does not open a port. It simply forwards everything to the ip address configured in the port forwarding. Thus, if the port is closed there it is closed and not open.
Posts: 837
Registered: ‎09-05-2006

Re: Port Forwarding not working properly.

[ Edited ]
Ignore what Shield Up says about your port if its says Stealth....  I use port 65534 with Azureus and everything is fine.  Shields Up says that my port is Stealth but everything works great.  Forward the port you want to use with Azureus.  Then then go to Tools > Nat / Firewall Test.  Enter the port and press Test.  Should come back with an OK! almost immediately.  If not that port will not work so try another.  Also make sure you entered your IP in Advanced Network Settings under Tools > Options > Connection. 

Message Edited by wehowardjr on 11-23-200611:22 PM

Kalidascorp
Posts: 3
Registered: ‎11-23-2006

Re: Port Forwarding not working properly.

Ok, well that answers one question. But even with Windows Firewall having exceptions on the port, the port still appears as closed. Are there any other settings I should change on the router or on the computer I'm forwarding to?
Posts: 837
Registered: ‎09-05-2006

Re: Port Forwarding not working properly.

On the router all you need set is the port you are forwarding and making sure its enabled in Applications and Gaming.  Are you using Port Forwarding or Port Range Forwarding?  I use the Port Range Forwarding to forward ports I use.  Just trying to cover all bases here. 
Kalidascorp
Posts: 3
Registered: ‎11-23-2006

Re: Port Forwarding not working properly.

Yeah, I go to the Port Range Forward under Applications and Gaming.

I set whatever ports I use, check enable, the save the changes.
jokieman
Posts: 2
Registered: ‎11-25-2006

Re: Port Forwarding not working properly.

[ Edited ]
Contact your internet provider. They have closed that port on their end, so it appears that you have your port closed when in fact it is your ISP that has closed it on their servers.

Your port is probably open, but if the ISP is blocking the port before the data leaves their network, it's going to act like the port is still closed on your computer.

Message Edited by jokieman on 11-25-200612:52 PM

Posts: 837
Registered: ‎09-05-2006

Re: Port Forwarding not working properly.

You dont need to contact your ISP to open a port, just try another as I did.  Some ISP's blacklist a port because its used for P2P programs.  Thats why they tell you to stay away from 6881 to 6889...
 
The following pretty much applies to all programs that need port forwards.
 
So what can I do about it if I'm already blacklisted?
  1. Choose a new TCP listening port for Azureus. The best range to choose a new port from is: 49152–65534 If you really need to choose a port within the range 1024–49151 make sure you pick an "unassigned" port listed at the IANA port list. Remember that Azureus needs one listening port only, so please choose one port from the above range.
  2. Go to Azureus > Tools > Options > Connection and input the new TCP listening port that you have chosen.
  3. Click "Save" at the bottom left side of the screen.
  4. Go into your router and/or firewall, if any, and forward the port you have chosen using the methods as described in NAT problem, Port forwarding and Router configuration. Remember to forward that port not only for TCP but also for UDP protocol, DHT needs that! (If your router is using UPnP, it should update automatically.) The "Port xxxx is blacklisted" message from the tracker should disappear and the torrent will start. If not, check your router and firewall, then go on to step 5.
  5. Stop all your actively running torrents. (This is temporary, just until you get the port sorted out. Azureus will remember all the peers you were connected to when you start the torrents up again, even if the tracker is offline. No need to panic. Please ring a friend if you need any extra support during this trying experience.) :-)
  6. Quit Azureus.
  7. Wait a few minutes.
  8. Run Azureus
  9. Go to Tools -> NAT/Firewall Test and do the port test. You will see a port tester with 6881 entered in it by default. Change 6881 to the port number you chose earlier and click "test". You will then get any one of three results from this:
    1. "This port can not be tested because it is already in use" If you get this message, repeat steps 4–8
    2. "NAT Error" If you get this message, please see the Port forwarding and/or the RouterConfiguration page.
    3. "OK!" If you get this message, then you have just done everything right, all is groovy, and the world should appear a much rosier place to live in. :-)