Reply
Feenster
Posts: 3
Registered: ‎07-12-2009
Accepted Solution

Port Forwarding on Linksys WRT54G

Hey I am having trouble with Port Forwarding on my Linksys WRT54G. The port I need opened is 28960. I have followed guides and thought I did everything correctly but its not working. Here is what I've done so far:

-I set a static IP address and took a screenshot of my settings here:


-Here is my port forwarding page:


-Under the "Security>Firewall" tab I unchecked "Block Anonymous Internet Requests"
-Also, I tried setting "DHCP Server" to disabled


Is there something I'm forgetting or did wrong?
MjrNuT
Posts: 13
Registered: ‎07-11-2009

Re: Port Forwarding on Linksys WRT54G

In your last image...

 

 

Starting IP Address is set to x.x.x.100

 

That won't work given you've assigned in TCP/IP an IP of x.x.x.2

 

Options:

 

1.  You can change the router starting IP to 2. (leave port forward page as-is)

 

2.  You can change the PC static IP to 100. (modify port forward page accordingly)

 

3.  Set PC to obtain IP automatically.  In router find DHCP Reservation and reserve that connected PC (assuming you recognize the MAC) to an IP.  It will tell you what it is.  (modify the port forward page accordingly)

 

 

 

great_white
Posts: 2,324
Registered: ‎09-07-2006

Re: Port Forwarding on Linksys WRT54G

Evreything is fine...Just make sure that DHCP Server is Enabled(don't Disable it)...

The only reason why port forwarding is not working because that port might still report as 'Blocked' , this happens only if you have an old firmware on your Linksys Router...

Upgrade your router's firmware, reset and re-configure it from scratch and do the port forwarding, see if it works...

 

Download the Firmware from here

 

Follow these steps to upgrade the firmware on the device : -
Open an Internet Explorer browser page on a computer hard wired to the router...
In the address bar type - 192.168.1.1...Leave the Username blank & in Password use admin in lower case...
Click on the 'Administration' tab- Then click on the 'Firmware Upgrade' sub tab- Here click on 'Browse' and browse the .bin firmware file and click on "Upgrade"...
Wait for few seconds until it shows that "Upgrade is successful"  After the firmware upgrade, click on "Reboot" and you will be returned back to the same page OR it will say "Page cannot be displayed".

Now reset your router :
Press and hold the reset button for 30 seconds...Release the reset button...Unplug the power cable from your router, wait for 30 seconds and re-connect the power cable...Now re-configure your router...

Feenster
Posts: 3
Registered: ‎07-12-2009

Re: Port Forwarding on Linksys WRT54G

I upgraded my firmware and reconfigured my settings but that port is still blocked
Feenster
Posts: 3
Registered: ‎07-12-2009

Re: Port Forwarding on Linksys WRT54G

Nevermind I got it working thank you
Pansopher
Posts: 1
Registered: ‎08-10-2009

Re: Port Forwarding on Linksys WRT54G

Feenster,

Don't leave us hanging!  What was the solution??

(I may be in the same boat.)

 

Thx,