Showing results for 
Search instead for 
Do you mean 
Reply
PhoenixFlame9
Posts: 7
Registered: ‎02-13-2012
Accepted Solution

QoS and WMM settings slow internet down when enabled

Ok, so I recently upgraded to a Linksys E3200. I am trying to get the QoS to work properly. I know that it is supposed to prioritize network traffic, so that if I have busy traffic but I am playing an online game, it should keep my gaming from stuttering while slowing other traffic down. It's a great idea in theory.

 

The problem is that every time I enable QoS everything slows down dramatically. I had a 200MB download that was going to take 5hrs with QoS enabled, that took 10min with QoS disabled. And with QoS enabled I can't even watch a youtube video without it pausing to buffer every 10 seconds. And that was the only PC/device using the network at the time. Again turning off the QoS WMM option solved  the problem. I have noticed this problem with multiple routers and brands and usually just disable QoS as soon as I set up a router, however I heard that I won't get the full benefit of 300Mbps without QoS enabled. Does anyone know if that is true?

 

I don't have any special Voice over IP needs, or video streaming etc. and I rarely am using multiple network devices at the same time. Is there really any reason I should enable QoS? 

 

Also I never really play with the settings for QoS, I just figure that since it comes enabled by default it should work for the average consumer. Does anyone know if changing the settings will help?

 

Thanks for your help

Expert
sabretooth
Posts: 5,312
Registered: ‎11-11-2008

Re: QoS and WMM settings slow INTERNET down when enabled

So leave it off since it's not working for you.  FWIW I have never found it to be of any benefit.  The router works fine without it.

hiptechboy
Posts: 1,557
Registered: ‎01-03-2011

Re: QoS and WMM settings slow internet down when enabled

[ Edited ]

You're correct, you need to have WMM support enabled to achieve the full benefits (link rates higher than 54mbps, that is) of wireless-n. 

 

You don't have to set up the other QoS features (e.g max upload rate, priorities, etc) to use it. If you're still able to achieve your adapter's max rate with WMM off, then I would do as sabretooth said and leave it disabled.

 

Personally, I have no idea why you're experiencing those issues when you only enable WMM support. 

I don't work for Cisco. I'm just here to help.
PhoenixFlame9
Posts: 7
Registered: ‎02-13-2012

Re: QoS and WMM settings slow internet down when enabled

Thanks. I have never turned the QoS priorize option on. I looked at it last night, but I really don't want to have to mess with/set up all of my network traffic to some priority. That seems like a lot of work, especially for a regular consumer.

 

I did a quick test last  night. It was pretty late so I got some good results. using speedtest.net I tested the speed with WMM enabled on my E3200 and WMM disabled. I get the same upload speed and ping for both tests (15ms ping and 5Mbps upload). However with WMM disabled my download speed was 20Mbps and with WMM enabled my download speed was 1Mbps. I know that this method isn't exactly scientific, but that seems like a big enough difference to say that WMM is screwing something up for me. Again I only enabled WMM I left the prioritization disabled. And my smart tv and PS3 were off, although my android had connected to the wifi it was not downloading anything.

 

So for now WMM is disabled. I do stream videos occasionally from my laptop to my TV but they do fine with the 54mbps speed. However I have always hated QoS and WMM so I'd really like to get to the bottom of this and see if it's just some settings I need to adjust to fix this and actually get to use the full benefit of having an N router. I did chat with a representative yesterday, and she told me that if I come back with my router pin or something on the lable underneath it they could look at it. So I am going to try that after valentines day and see what they say.

Corleone
Posts: 2,785
Registered: ‎09-07-2006

Re: QoS and WMM settings slow internet down when enabled

First of all please verify that you have got a 802.11n card in your computer. New generation routers (i.e. E3200) speaks an entirely different language with 802.11g cards, so while those adapters can work with the E3200, but they are not optimized to provide good performance. It is like having to translate from one language to another in real time when going from N to G.

 

Well, there are few things you should keep in mind with regards to N routers:

 

1) For the best possible speeds, you need to be using WPA2-AES as your security mode. Any other security mode will see your speed/range capped. 

 

2) Any G devices in your wireless network will tend to hamper the performance of your overall network.

 

3) Ensure that your router is running the latest firmware from homesupport.cisco.com The new firmware includes performance enhancements and fixes.

 

4) The router by default uses a channel setting of auto, which means that it would keep switching channels depending on the interference. I’d recommend you set it to a fixed channel. Usually, 1, 3, 6 and 9 give you the best performance depending on your environment of course. I’d suggest you try different channels, observing each for a while, to see which gives you the best performance. You can follow the link here on how to change channels.

PhoenixFlame9
Posts: 7
Registered: ‎02-13-2012

Re: QoS and WMM settings slow internet down when enabled

I do have an 802.11n card, however it is only single band. It can't do 5Ghz, so after speaking with a cisco rep for a while yesterday they informed me that I won't be able to use the full capabilities of the N router withouth a dual band card. My understanding is that this means I can only top out at 150Mbps instead of 300Mbps. Although this was informative, it did not help me with the WMM setting slowing my internet down to a crawl.

 

I am usng WPA2-Personal

 

I made it a wireless N only network

 

The firmware is up to date

 

I did test it setting a fixed channel. I used inSSIDer to see what channel was available, and used channel 6. (I have no wireless networks nearby. Only 2 had enough power to show up occasionally on inSSIDer, so any interference should be minimal.)

 

Still WMM brought internet download speed to well below 1Mbps. Traffic was busier at the time, so without WMM I was getting around 9Mbps down. 

 

I guess for now I will just leave WMM off, even though I don't know what sort of in network transfer speeds I will achieve without it. I've owned a few routers, and I have never liked what WMM did to my network. I was only investigating this because I heard that I may only be able to achieve 54Mbps wifi speed without WMM, oh well.

 

 

 

hiptechboy
Posts: 1,557
Registered: ‎01-03-2011

Re: QoS and WMM settings slow internet down when enabled

What is the model number of your wireless adapter?

I don't work for Cisco. I'm just here to help.
PhoenixFlame9
Posts: 7
Registered: ‎02-13-2012

Re: QoS and WMM settings slow internet down when enabled

Cisco Linksys 3200 and it has firmware 1.0.02 build 9.

hiptechboy
Posts: 1,557
Registered: ‎01-03-2011

Re: QoS and WMM settings slow internet down when enabled

That's the route. The wireless adapter is either the external or internal device that your PC uses to connect wirelessly to the router. Go to change adapter settings in the network and sharing center to find out the model number. \

 

I'm not sure if you've done this already, but you should probably try reinstalling your wireless adapter's driver in the device manager. 

I don't work for Cisco. I'm just here to help.
PhoenixFlame9
Posts: 7
Registered: ‎02-13-2012

Re: QoS and WMM settings slow internet down when enabled

Sorry, it's an Atheros AR9285 Wireless Network Adapter.

 

I know that the driver is 2 years old, which is how old my laptop is, but Sony doesn't have any updates to it on their website. (On another note I really would like to build my own pc so I don't have to deal with slow sony/dell/etc driver updates) I will try to reinstall the driver, also I checked for any QoS or WMM settings on the Atheros driver in the device manager, but didn't see any.