Reply
pancho
Posts: 5
Registered: ‎01-17-2007

RMA Problems

Last month I got an RMA number, wrote it on the outside and the inside of the box and sent it via UPS. According to UPS, someone signed for it at the Linksys Return Center in Round Rock, Texas. The Linksys status page says it hasn't arrived. I'm unable to get through to tech support via the phone and my emails are unanswered. I need to talk with someone in the United States who can resolve this for me. Suggestions?
Posts: 837
Registered: ‎09-05-2006

Re: RMA Problems

Give it a few more days.  I had my RMA replacement in my hands and the website said it was being still being processed.  They are slightly behind.
 
Where did you ship from?  Use the link below and enter your tracking number.  It will tell you when it was delivered and who signed for it.
 
 
Also, try sending an email to support@linksys.com with your concern.  They helped me a lot.
pancho
Posts: 5
Registered: ‎01-17-2007

Re: RMA Problems

I had already checked the tracking number which showed my dead router arrivng last month at the RMA addresss in Texas. I shipped from southern California.

Linksys website shows "unit status" as "still awaitng your product return". That's a full month after UPS shows it being delivered.

The signature reads "shed". Sounds like an outhouse.

Again, THEY HAVE IGNORED MY EMAILS!

I want to talk with someone directly in the United States who can resolve this for me.

Is there anyone on this forum that can help with this?

Other Linksys users need to keep an eye on this thread as this could happen to you.
Posts: 837
Registered: ‎09-05-2006

Re: RMA Problems

Check your PM's
Posts: 837
Registered: ‎09-05-2006

Re: RMA Problems

pancho....
 
Whatever happened with your RMA?  Did you get it solved?
pancho
Posts: 5
Registered: ‎01-17-2007

Re: RMA Problems

I was able to talk with United States Linksys, who assured me that this problem would be dealt with, but as of today, January 24, 2007 I do NOT have a router.
nktwinpeaks
Posts: 2
Registered: ‎01-26-2007

Re: RMA Problems

I am having the same problem with my RMA. Router received in TX & signed for by Shedd on 1/9/2007 but status still says awaiting product return. I phoned Linksys on 1/9/07 & spoke with Julie who checked and said my router had been received, regardless of what the online status shows, but because of their recent transfer to a new warehouse it could take 2 more weeks for them to get around to sending me another router. Two weeks has passed, status still the same. Luckily I still have my old wired router. Linksys technical support was a lot better than their customer support.
Posts: 837
Registered: ‎09-05-2006

Re: RMA Problems

You have to realize that there are probably alot of RMA's being handled so they cant stop what they are doing to focus on only one customer.  Like I said above, I had my replacement router delivered to me before the website even acknowledged that it was being sent.
pancho
Posts: 5
Registered: ‎01-17-2007

Re: RMA Problems

This is the second bad Linksys router I've purchased. The first one I didn't bother to RMA. The second one is currently lost at some twilight zone warehouse. Promised callbacks have not happened and I don't have my router.

When somone attemps to excuse Linksys because there are "probably alot of RMAs being handled", what does that imply about Linksys quality?
mjm0771
Posts: 4
Registered: ‎01-23-2007

Re: RMA Problems

There seems to be a real problem with the customer service.
I posted a rant in this forum a few days ago, and the thread got deleted. 
(probably because I was angry and upset and used a few choice words that violated policy)
 
I'm pretty much in the same boat as all of you. (RMA #8490204). I called several times and got the wild goose chase. One customer service rep even lied to me and told me that my replacement shipped. She gave me a UPS tracking #, when I verifiyed it on UPS.com, it was obviously the wrong number (the package was being shipped to OH, I live in NJ) I believe she gave this the bogus tracking number just to get me off the phone...
 
However, there was one Cust Svs rep who was honest and and told me the truth regarding my RMA. She told be that due to the MANY internal problems and issues inside the company, it may take weeks for my replacement WRT54G v6 to get shipped.
(I cannot disclose her name or badge #, for reason she might get fired for being honest, truthful and sympathetic) If your reading this, Thanks again K****!!!
 
FOR ALL THOSE LOOKING FOR THEIR REPLACEMENTS:
DO NOT use the website to check the status of your RMA, its broken and is rendered worthless at this time. call the RMA Dept 800.546.5797 option 3-3-3.
 
Good luck Everyone with getting you RMAs resolved!
Where ALL going to need it!!!!
 
-Mike