Reply
BOBB
Posts: 3
Registered: ‎05-30-2009
Accepted Solution

ROKU

[ Edited ]

I HAVE A WRT160N WHICH I CAN CONNECT JUST FINE AND I HAVE NETWORK MAGIC. I AM TRYING TO INSTALL A NEW ROKU PLAYER FOR NETFLIX AND THE ROKU PEOPLE TELL ME I NEED TO HAVE YOU CHANGE MY STATIC DNS TO 208.67.222.222 AND 208.67.220.220

I HAVE NOT A CLUE HOW TO GET TO YOU AND HOW TO DO THIS AND WHY

CAN YOU HELP? ALL MY NETWORKED PCS SIGN ON INTERNET JUST FINE BUT THE ROKU CANT FIND THE INTERNET.

 

THANKS BOB HICKMOTT

 

 

 

 

 

 

 

(Removed Email address. Edited for guideline compliance. Thanks!)

Message Edited by JOHNDOE_06 on 05-31-2009 01:45 PM
toomanydonuts
Posts: 6,365
Registered: ‎09-16-2006

Usually, if a device (such as the ROKU) needs to use specific DNS servers, the DNS addresses must be entered into the device itself, not into the router.

 

However, with some "Internet connection types", you can specify your DNS servers in the router.

 

1)  What type of Internet connection do you have?  PPPoE?  Static?  DHCP - automatic?  Other?

 

2)  Also, please state your ISP and the make and exact model number of your modem.

 

3)  Do you have other computers connected to your network?  Can they access the Internet without problems?

 

4)  Did ROKU say that you needed to put these DNS addresses into the router?  or into the ROKU?

 

 

BOBB
Posts: 3
Registered: ‎05-30-2009

my router is a linksys wrt160n and i am using a dsl modem. internet connection is set to auto detect

AOL is my ISP and modem is zhone 6212-13-200

 

all pcs can currently connect wirelessly with no problem. The Roku will not connect and searches but says it cannot connect to internet.

Thanks

Wizzard
Posts: 3,025
Registered: ‎09-07-2006

If you are using ROKU you need to use specific DNS Addresses on your ROKU and not the router...

If you were to setup Static DNS on your router you have to use Static IP Address and your ISP will provide with all the IP Address and Static DNS...You cannot just setup static dns addresses on your existing router...

I would cbe sure that they meant to setup Static DNS Addresses on your ROKU and not the router or computer...Check this link

toomanydonuts
Posts: 6,365
Registered: ‎09-16-2006

Re: ROKU

[ Edited ]

Your Zhone is not just a modem, it is a "modem-router" and it likely uses the same 192.168.1.x  subnet as your WRT160N.  This might well be the cause of your problem.

 

To be sure that your Zhone is using 192.168.1.1 , please do the following test:

 

1)  Power down your entire network.  Using an ethernet cable, connect your modem directly to your computer.  (Do not use the WRT160N for this test.)  Power up the modem and computer.  Verify that you have a working Internet connection, then proceed with the following:  (Even if your Internet connection does not work, state this, and proceed.)

 

Go to "Start" > All Programs > Accessories > Command Prompt.
A black DOS box will appear. Type in "ipconfig /all" (with no quotes), then hit the Enter key.   Copy all the results to your next post.  To do the copy, highlight the results, then use the copy (Ctrl-c) keys and the paste (Ctrl-v) keys.  If your "IP address" does not start with 192.168 , then for security reasons, erase the last half of your IP address.

 

2)  Also, is your WRT160N still using the default 192.168.1.1  ?

Message Edited by toomanydonuts on 05-31-2009 11:32 PM
BOBB
Posts: 3
Registered: ‎05-30-2009

i setup the pc direct to router and it would connect fine the roku still does not. here is a copy of config maybe that will help thx bob

Microsoft Windows [Version 6.0.6001]
Copyright (c) 2006 Microsoft Corporation.  All rights reserved.
C:\Users\BOBH>ipconfig/all
Windows IP Configuration
   Host Name . . . . . . . . . . . . : BOBH-PC
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
Wireless LAN adapter Wireless Network Connection:
   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Atheros AR5007EG Wireless Network Adapt
   Physical Address. . . . . . . . . : 00-1B-9E-B0-B7-22
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
Ethernet adapter Local Area Connection:
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Realtek RTL8101E Family PCI-E Fast Ethe
et NIC (NDIS 6.0)
   Physical Address. . . . . . . . . : 00-1E-EC-33-76-23
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::b18c:3b1e:8033:467a%10(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.100(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Monday, June 01, 2009 9:21:07 AM
   Lease Expires . . . . . . . . . . : Tuesday, June 02, 2009 9:21:08 AM
   Default Gateway . . . . . . . . . : 192.168.1.1
   DHCP Server . . . . . . . . . . . : 192.168.1.1
   DNS Servers . . . . . . . . . . . : 192.168.1.1
   NetBIOS over Tcpip. . . . . . . . : Enabled
Tunnel adapter Local Area Connection* 6:
   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : isatap.{38345E4D-9E2C-42F5-AC8A-C5DAC44
AD7}
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
Tunnel adapter Local Area Connection* 7:
   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : isatap.{122A6998-924E-41E7-A8AD-B009D4C
327}
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
Tunnel adapter Local Area Connection* 11:
   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : 02-00-54-55-4E-01
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
toomanydonuts
Posts: 6,365
Registered: ‎09-16-2006

Re: ROKU

[ Edited ]

The "ipconfig /all"  results that you posted look like you connected your computer to the WRT160N.

 

I need you to do the same test with your computer connected directly to the zhone modem.  Please post the results.

Message Edited by toomanydonuts on 06-02-2009 01:47 AM