Reply
lexus37
Posts: 4
Registered: ‎05-08-2007

Router keeps losing connection!?! Don't know why

[ Edited ]
Hi, I have a Linksys wireless router WRT54GS version 6 and originally I thought it was my ISP was the issue with my internet being down. After troubleshooting with them for hours and hours it was the Linksys router. If I power cycle the router or login on to the main page and hit save settings the internet works. I upgraded the firmware on the router and it seemed to fix the problem for a while, but the issue is back again. Does anyone know what the issue could be?

Message Edited by lexus37 on 05-08-200709:03 AM

Message Edited by lexus37 on 05-08-200709:04 AM

AP19
Posts: 19
Registered: ‎02-05-2007

Re: Router keeps losing connection!?! Don't know why

Hello,
Did you try upgrading the firmware. If not, here is the link: http://www.linksys.com/download
-cn0BaAko-
Posts: 73
Registered: ‎05-06-2007

Re: Router keeps losing connection!?! Don't know why

Hi
 
Does all your computers lose connection? Or is it just the wireless ones?
Just helping out... :smileyvery-happy:

"Success usually comes to those who are too busy looking for it"
grace
Posts: 112
Registered: ‎04-25-2007

Re: Router keeps losing connection!?! Don't know why

Hi can u please tell me what's the version of the router's firmware?We'll try to check if your  firmware meets the miminum requirement.
 
 
Take the risk. Conquer your limitations!
spideyboy
Posts: 6
Registered: ‎05-08-2007

Re: Router keeps losing connection!?! Don't know why

Make sure you have the firmware version of 1.52.0..if only wired is having disconnection..try reducing the mtu to 1400..if w/l is disconnecting try changing the channel to 11.
toomanydonuts
Posts: 6,365
Registered: ‎09-16-2006

Re: Router keeps losing connection!?! Don't know why

After you do a firmware upgrade, you must reset the router to factory defaults, then set up the router again from scratch.  If you have a router configuration file, DO NOT use it.  If you do not reset the router to factory defaults after a firmware upgrade, this alone can sometimes cause router problems.
 
Are you running any peer-to-peer (P2P) software?  If so, this is a known cause for crashing routers and disconnections.  To fix it, go into the P2P software and reduce the number of connections that the software can make.
Hemo2
Posts: 4
Registered: ‎05-09-2007

Re: Router keeps losing connection!?! Don't know why

I thought I would post that I have a similar problem.  I have a WRT54G v6 with v1.02.0 firmware.  Once about every 2-4 weeks, my router will loose it's connection to the internet.  I have to power cycle it and then it's fine again.
 
Both my wired and wireless connections are affected by this.  Both my wired and wireless computers work fine with the "internal" network, but when they try to access the internet everything times out.  Under the Status page, I have clicked the "DHCP Release" button to release my IP and then "renewed" it, which works fine, but the internet connectivity still times out.  After a power cycle, it's fine and all computers work ok.  I hadn't thought of trying to hit the "save settings" button, but the next time it occurs, I'll try to remember to do that and see if that gets it working like a power cycle does.
 
I doubt there is a solution and since it doesn't happen regularly enough for me to troubleshoot I don't know that there's a good way to look into it anyway.  But I wanted to post what is occuring with mine.
 
 
lexus37
Posts: 4
Registered: ‎05-08-2007

Re: Router keeps losing connection!?! Don't know why

Firmware is upgraded.

Firmware Version: v1.52.0
lexus37
Posts: 4
Registered: ‎05-08-2007

Re: Router keeps losing connection!?! Don't know why

MTU is setup as Manual 1400 and after the upgrading the firmware I manually keyed in all the settings again. I am running some p2p software from time to time and I will check that to see if it fixes the problem.
lexus37
Posts: 4
Registered: ‎05-08-2007

Re: Router keeps losing connection!?! Don't know why

What connections do you mean on the p2p?