Showing results for 
Search instead for 
Do you mean 
Reply
Orchid
Posts: 1
Registered: ‎10-19-2009

Router suddenly stopped working

Hi, I'm really not very techy and I've pretty much exhausted everything I can think of to do. The next step if I don't get answers here is to go out and buy a new router.

 

I have a Wireless G WRT54GS Linksys router. I have a HP Pavillion laptop, and my hubby has a HP laptop, too. We also have an older Mac iBook G4 which I'm not very familiar with yet, as it's new to me.

 

We had a wireless connection, which suddenly stopped working. I can't find my network on the list of available networks anymore. When I go through the linksys program it says it can't detect the router. I've even tried setting up a new network, but I can't get beyond the part where it's supposed to detect the router. (This is wireless OR wired.)

 

I called my internet company, because after this happened, I can't even get internet on my PCs by plugging in the cat5 cable directly from my modem! I was able to get it on my mac this way for a few days, but then it stopped working. They had me check the ip address and said it was invalid and that was because I had switched from using a network to hardwiring it. So they reset it and had me restart my mac and it worked again. My PC takes forever to start up so they told me to unplug the wires and cable from the back of my modem, restart my PC and then plug the stuff back into the modem, then the router, then my pc and it would work. But it doesn't. I've even tried the 'reset' button on the modem. (Pressing down for over 1min)

 

I'm just at a loss as to how to fix this problem, and I find it strange that I can't get internet on either of my PCs even when I'm not going through my router, but why can I get it on my mac?

 

If anyone can help I'd be greatly appreciative. Sorry this is so long but I wanted to give as much info as I can.

 

TIA!!

Orchid 

Terry Morse
Posts: 2
Registered: ‎10-19-2009

Re: Router suddenly stopped working

I developed the same problem with my WRT54G2 today.  I have a dial-up internet connection, so that's not an issue, but am unable to connect my laptop to my desktop.  Tried the same steps to re-establish a connection (running the set-up wizard) and it is unable to detect the router.  I've had the router for just under a month, and it has worked flawlessly until now.  I, also, would appreciate any help anyone can offer.

 

Terry

scrooge
Posts: 2,610
Registered: ‎09-07-2006

Re: Router suddenly stopped working

First of all you must get an Internet Connection,when you connect the computer to the Modem directly.It might be the case that the Mac Computer is picking up and connected to some unsecured network of your area.

 

If the connection between the modem and the router is working fine then,I would suggest you to reset the router,power cycle the router and reconfigure it from the scratch.

 

If your Internet Service Provider is Cable follow this link

If your Internet Service Provider is DSL follow this link

Terry Morse
Posts: 2
Registered: ‎10-19-2009

Re: Router suddenly stopped working

I did a chat session with a linksys support tech this morning, who solved my problem with Windows not detecting my router.  It might be worth seeing whether it solves yours, as well.  The problem was with the TCP/IP settings for my LAN.  The "Obtain an IP address automatically" radio button should have been selected, but wasn't.  To check this setting in Win XP, open the control panel, then open "Network Connections."  Right-click "Local Area Connection" and choose "properties" from the drop-down menu.  Scroll down to "Internet Protocols," highlight it, and click the "properties" button.  If "Obtain an IP address automatically" isn't selected, select it and close both properties dialogue boxes with the "okay" button.  Then disconnect the power to your modem and router and turn off your computer.  Wait at least two minutes, then reconnect the power to your modem and router.  After the lights on the modem stop flashing, restart your computer.  Windows should now detect it.

 

I hope this fixes your problem.  If not, you might try a chat session (http://www.linksysbycisco.com/US/en/chat).  I found the support tech very knowledgeable.  He quickly diagnosed the problem and provided me with a solution that worked.

 

Terry