Posts: 1
Registered: ‎11-05-2011

Setting a E4200 as primary router for Uverse (Making the Gateway a modem)

So we just received Uverse a week ago, and we switched from Comcast. For Comcast, it was simple enough if you wanted to change routers, as the modem was separate when provided by Comcast. As a result, I really do not have a lot of knowledge with AT&T's configuration of hardware.

So my goal for today was to turn the Uverse provided 3801HGV Gateway into a simple modem, and set up a Linksys E4200 as the primary router. I assume that this is the best setup speed and bandwidth wise for high bandwidth applications like gaming and streaming (Compared to having the Gateway allocate IP addressing and firewalls).


So my steps were as followed:


Dynamic IP - DHCP is already enabled for the gateway.

1) Hooked up laptop to Gateway through ethernet cable, and turn off wireless interface (transmission) here:

2) Disconnected ethernet cable from computer and gateway.

3) Connected ethernet cable from a LAN port on the gateway to the broadband WLAN main port on the router. Hooked up another ethernet cable from a LAN port on the router to my laptop.

4) Installed and configured router through provided CD (DHCP was enabled by default) (Firmware is latest)

5) Accessed the gateways settings through computer, went to "firewall, pinholes, dmz" setting (, and changed the router's specific firewall access to DMZplus.

6) Reset Router.


After I did all of these steps, the internet worked like a charm. I didn't test speed or play any online games to check latency, but browsing seemed normal.


However, after browsing the routers settings for a bit, I noticed NAT was enabled. I turned this off, seeing that in my previous Comcast setup it was just an inconvenience for gaming (xbox).

The result of this after a reboot was complete loss of internet from LAN and WLAN (but I could still access router and gateway settings (just because of the ethernet cable I assume)). Chrome gave me DNS errors every time I tried a website. I renabled NAT and rebooted, and it still gave me DNS errors. I rebooted the router multiple times, and unplugged it, and it still would not connect to the internet. I later learned that DMZ or some other firewall setting in the gateway required NAT, so it seemed as though I messed up something indirectly, even after enabling NAT again.

I tried multiple factory resets of the router, and cleared the device list under diagnostics in the Gateway's settings. However, the gateway still showed the router under devices after the multiple device wipes for some reason (I disconnected the router from the gateway too). After I reset the router through the pinhoel button on the back, I tryed to install and configure the router again through the CD, but it got stuck at 90 percent and an error accuired. I tryed this multiple times. Now I can not even access the routers settings.



I don't know what to do at this point, other than ask AT&T and/or Linksys on what to do.



I spent hours trying to get this to work. Can anyone help me out?

What should I do from here? If I get this working again, what should be my router's and gateway's settings?

Posts: 1,559
Registered: ‎01-03-2011

Re: Setting a E4200 as primary router for Uverse (Making the Gateway a modem)

Check out the second post in this forum. If you still have any issues with the gateway, you would be better off asking them, but feel free to ask us also Smiley Happy.
I don't work for Cisco. I'm just here to help.